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Accessibility Handbook for Teaching 
and Learning 

Preface 

This book was created by Luke McKnight (Assistive 
Technologist) and Briana Fraser (Educational Technologist, 
Langara College) with assistance from Clover Duong (Assistive 
Technologist Project Assistant, Langara College). This resource 
is intended as a reference for anyone to understand digital 
accessibility, create accessible content, and ensure everyone 
can access digital material. 

Please use, share, and copy from this book as you see fit. 

License 

Accessibility Handbook for Teaching and Learning by Briana 
Fraser and Luke McKnight is licensed under a Creative 
Commons Attribution-NonCommercial-ShareAlike 4.0 
International License, except where otherwise noted. 
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Accessibility Statement 

The authors of this work are committed to providing a fully 
accessible experience for all users of all abilities, including 
those who rely on assistive technologies like screen readers, 
text to speech, screen enlargement software, voice control, and 
alternative keyboard input devices to navigate and consume 
content. 

Accessibility Features of this 
Resource 

The web version of this Pressbook is designed to meet Web 
Content Accessibility Guidelines 2.1, level AA. To create an 
accessible resource, authors incorporated the following: 

• Minimum 12 point body text. 
• Pages are built with a consistent heading structure. 
• All content has appropriate colour contrast (apart from 

two instances of poor contrast intentionally included as 
examples of what not to do). 

• Information is not conveyed by colour alone. 
• Content in web and EPUB export can be zoomed to 200% 

with no need for horizontal scrolling. 
• All videos with audio are captioned. 
• All images include alternative text or are marked 

decorative. 
• Tables are properly formatted. 
• All link text is descriptive (apart from examples of what not 

to do). 
• Links do not open in a new window or tab, except where 

indicated. 
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• All embedded H5Ps are verified accessible by the author. 
• Math content is accessible and presented as either: 

◦ LaTeX or MathML rendered by MathJax. 
◦ Images with complete, descriptive alt text. 

As content is added to this resource, every effort is made to 
ensure content is accessible. Any issues will be noted on this 
page. 

Additional Formats 

On the title page of this book open the Download this book 
menu and choose your preferred format. 

Generally, HTML will be the most accessible format. However, 
users can download this resource in PDF, EPUB, and others. 
There is a possibility formatting will not sync perfectly between 
all formats and full accessibility cannot be guaranteed in other 
formats. 
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Known Issues 

The authors have made a dedicated effort to ensure the 
accessibility and usability of this resource. Any outstanding 
issues identified are documented below. 

Table of known accessibility issues 

Location of issue Issue description Timeline for 
improvement 

No current issue No current issue No current issue 

Contact Information 

If you encounter an accessibility barrier or have any other 
questions or comments, contact assistivetech@langara.ca. 

Please include as much of the following information as 
possible: 

• Location of the issue, including the web address and/or 
page title. 

• A description of the issue. 
• The computer or device, software, browser, and other 

technology you are using. 
◦ e.g., iOS, Safari, VoiceOver 

A thorough description will assist us in addressing any issues 
and improving the accessibility and usability of this resource. 
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This statement was last updated on March 11, 2024 
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Using This Resource 

This first chapter explains 
how to navigate this book on 
the web and outlines some of 
the common features you 
will encounter in this 
resource. 

On this page: 
Browser Personalization 
Navigation  Glossary 
Hypothes.is  Videos 

Consider the following tips for accessing this resource on the 
web. 

Browser Personalization 

For reading this book (and much of the web) you may want 
to customize the appearance of the content. Tools such as UI 
Options Plus (UIO+) browser extension for Chrome and Edge as 
well as Immersive Reader for Edge and Reader View in Firefox 
allow users to change the font style, size, background colour 
and use tools like read aloud and line focus. 
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Navigation 

On each page, pressing Tab once moves focus to the Skip to 
content link. Selecting that link moves keyboard focus directly 
to the beginning of the page’s main content. 

At the bottom of each page are next and previous buttons. Use 
these buttons to move between pages and chapters: 
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You can also use the left and right arrow keyboard keys to move 
between pages. If keyboard focus is on an interactive element 
such as an H5P or video, this will not work. Press Tab to move 
out of an element to resume navigating between pages. 

Near the top left of each page is a table of contents. The 
Contents button expands the table of contents menu allowing 
you to navigate between pages and chapters: 

To quickly access the table of contents, use the skip to to 
content link then press Shift Tab twice. This action will move 
focus to the Contents menu. 

Most pages contain an “On this page” list of links to specific 
parts of the page, such as: 
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Select a link to skip to that part of the page. 
Pages that do not have a table of contents are short or only 

cover one significant topic. 
As you move down the page, a Back to top button appears at 

the bottom of the screen: 

Select the Back to top button to move back to the top of the 
page. 

In the top right of each page is the Search in book… tool 

Search results are displayed on a new page. 

Glossary 

Glossary items appear in bold, red text with a dotted underline, 
such as in this example. 

Glossary terms are fully accessible buttons. Screen readers 
will read the glossary term followed by the definition in line 
with the surrounding text. Mouse users can click the button to 
reveal a popup definition of the term. 
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Hypothes.is 

Hypothes.is is a social annotation tool that allows you to 
highlight, annotate, and share content on the web. The 
Hypothesi.s plugin is built into this Pressbook. 

1. Select the Annotation Sidebar in the top right of the page. 

2. Log in or sign up to hypothes.is 
3. Highlight text and select Annotate to add a note or

Highlight to highlight content. 

Hypothes.is is keyboard accessible and text can be highlighted 
using caret browsing. 
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Videos 

This book includes a number of demonstration videos. All 
videos containing audio are captioned. There are some videos 
which contain no audio. 
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DIGITAL ACCESSIBILITY 
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Digital Accessibility 

“Clearing a Path for Everyone” – Michael Giangreco / University Of 
Vermont Center For Digital Initiatives Collection 

The one argument for accessibility that doesn’t get 
made nearly often enough is how extraordinarily 
better it makes some people’s lives. How many 
opportunities do we have to dramatically improve 
people’s lives just by doing our job a little better? 
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– Steve Krug, Don’t Make Me Think, Revisited 
Digital technology is so ubiquitous that it is difficult to think 

of many activities that don’t rely on some kind of technology. 
Many people may take for granted that things just ‘work.’ What 
if something you used everyday didn’t work? What if you 
couldn’t read your email? What if you couldn’t log in to your 
online banking? What if your computer speakers suddenly 
stopped working? 

Every day people encounter something that doesn’t work for 
them. A PDF that cannot be read aloud may not effect you, but 
for some that inaccessible PDF might as well be blank. A form 
that says ‘fill out the forms marked with red text’ may make 
sense to you, but some people will not be able to decipher 
which fields to complete. A video without subtitles excludes 
anyone that cannot clearly hear the audio. 

Accessible digital content can be: 

Accessed, 
Consumed, 
Interacted with, 
by everyone, 
at the same time. 

 

Accessibility accounts for a diversity of access means. 
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Access means can be 
informed by: 

• Choice of device, 
such as a computer or 
phone. 

• Control type, e.g. 
without a mouse. 

• Necessary software, like text to speech tools or 
voice control. 

• Customization including increasing font size or 
inverting colour schemes. 

In the context of digital accessibility, an access profile 
will likely be intimately related to a user’s disability and 
the technology the use. Learn more about assistive and 
adaptive technology in the Assistive Technology User 
Guides Pressbook. 

 

A user’s access means can be influenced by something: 

• Persistent, for 
example blindness. 

• Temporary, like eye 
strain. 

• Situational, such as 
glare from the sun. 
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Access means may also change over time. 

According to Statistics Canada, 27% of Canadians have a 
disability (Statistics Canada, 2022). However, educators cannot 
rely on accommodation requests, or lack thereof, to decide 
when to make accessible content. 96% of disabilities are 
“invisible”, that is they are not outwardly visible to the casual 
observer (Morgan, 2020). There is no way to determine who 
accesses content in what way by looking at them. Additional 
statistics suggest only one-third of college students with a 
disability disclose their status (Adam and Warner-Griffin, 2022). 
Further, 94% of high school students with disabilities get some 
form of assistance, while that number drops to 17% at the 
college level (Krupnick, 2014). Accessible content is built for 
everyone and reduces the need to accommodate specific 
cases, increases the usability of content, and maximizes the 
independence of all users. Accessible content is designed for 
everyone. 

Accessibility is not a feature, inaccessible content is a bug. 

Works Cited 

Adam, Tara, and Catharine Warner-Griffin. “A Majority of 
College Students with Disabilities Do Not Inform School, New 
NCES Data Show.” National Center for Educational 
Statistics. Accessed September, 20, 2022. 
Krupnick, Matt. “Colleges Respond to Growing Ranks of 
Learning Disabled.” Washington Monthly, February 18th, 2014. 
Morgan, Paula. “Invisible Disabilities: Break Down the Barriers.” 
Forbes, March 20, 2020. 
Statistics Canada. “New data on disability in Canada.” 
Canadian Survey on Disability, 2022. 
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Accessible Content 

Creating Accessible Content 

Take a moment to consider who ramps are built for. 
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Many people might answer “wheelchair users”. That is correct. 
Ramps are purpose-built to assist movement. They 
are essential for someone using a wheelchair to navigate and 
access parts of the physical world. However, most people can 
also use ramps. What is essential for some also benefits others. 

Ramps benefit: 

• People pushing a stroller or pulling a shopping 
cart 

• People using a walker, walking stick, or cane 
• Children learning to walk or anyone having 

difficulty with stairs 
• Cyclists pushing their bikes 
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• People on crutches or those with other 
temporary disabilities 

• Movers and delivery people 

In the digital world there are many ‘ramps’. 

Digital Ramps: 

• Headings 
• Colour contrast 
• Alternative text 
• Closed captions 
• Responsive design 

Software like Word, PowerPoint, and Brightspace were 
designed to create accessible content by default. When used 
as intended, those platforms create material that is accessible 
with no additional steps, hacks, or workarounds required. 

As an example, consider when you last (or ever) received 
formal training on creating Word documents. If you have, how 
long ago was it? Or, have you simply been doing things the 
way you’ve always done them? That approach is often adopted 
with good intentions under the assumption that if something 
isn’t broken, don’t fix it. However, inaccessible content is broken 
content. When people can’t access and engage with material, 
that material is broken. 

Creating accessible content may require some unlearning of 
steps in your current workflow. You may need to (re)learn some 
features. But, many platforms and software create accessible 
content by default. 
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The hardest part of learning something new is not 
embracing new ideas, but letting go of old ones. 

– Todd Rose, The End of Average 
Traditionally, one might think of creating accessible content 

as an accommodation essential for some users; but like ramps, 
these elements benefit everyone. 

Maximizing accessibility allows for democratic, just, 
equitable, and inclusive access. 

Accessibility: 

• Minimizes othering 
• Allows maximum independence 
• Increases audience size 
• Aids comprehension 
• Meaningfully includes the greatest number of people 
• Requires less work than accommodation 
• Makes content easier to share and remix 

Some people just have to show up. Others have to hack, plead, 
and ask for favours simply to be able to participate. Creating 
and providing accessible content reduces that burden. This 
handbook seeks to problematize the excess labour inaccessible 
content imposes on some users. 

Accessibility Spectrum 

A better understanding of digital accessibility helps with 
creating accessible content and choosing accessible resources. 
Keep in mind, digital accessibility is not pass/fail; material may 
be more or less accessible than previous versions or alternate 
formats. Aim to provide the most accessible version of content 
to deliver the same information to everyone at the same time. 
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By adopting the best 
practices and consulting the 
resources found in this guide, 

you will learn how to choose and create accessible content 
efficiently and effectively. 

A final note: 
Focus on creation and revision, not remediation. 
When you create new content or update existing 
material, focus on incorporating accessibility best 
practices. Do not focus on all your existing 
documents and worry about ‘fixing’ each one. Aim 
to improve as you move forward. 
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Readable fonts 

For readability prefer sans-serif 
fonts like Aptos, BC Sans, 
Helvetica or Open Sans. 

Use plain serif fonts like 
Cambria, Sitka, or Times New 
Roman. 

Layout and structure 

Use built-in tools for: 

• Headings 
• Lists 
• Tables 
• Titles 

Appropriate use of 
colour 

Use dark text on light 
backgrounds and light text on 
dark backgrounds. 

Do not use colour alone for 
meaning. 

Digital Accessibility 
Quick Start Guide 

For initial accessibility checks, ensure content has: 
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Descriptive link text 

Write unique, descriptive text 
of link destinations and use 
built-in tools to create 
hyperlinks. 

Do not include bare URLs. 

Text equivalents for 
images, videos, and 
audio 

1. Briefly describe the 
information in an image via 
adjacent text, figure 
captions, or coded 

alternative text. 
2. Use Kaltura or OneDrive to generate captions and edit for 

accuracy. 
3. Provide text transcripts of audio recordings. 

Been evaluated by an accessibility checker 

Use tools, such as accessibility checkers in Office programs and 
Brightspace, to check for common accessibility issues. 

Many platforms have tools and features that were designed 
to create accessible material by default. When used as 
intended software like Word, PowerPoint, and Brightspace 
create content that is accessible with no additional steps, 
hacks, or workarounds required. 

Prefer formats such as HTML, Docx, and EPUB that 
allow user customization, as opposed to rigid 
formats like PDF or images of text. The greatest 
affordance for individuality is customization. 
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ACCESSIBILITY FAST 
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Accessibility FAST 

There are three frameworks to use to remember the key points 
of digital accessibility: SCULPT, THRIVES, and FAST. 

SCULPT reminds authors to check: 
Structure 
Colour and Contrast 
Use of images 
Links 
Plain English 
Tables 
THRIVES reminds authors to focus on: 
Tables 
Hyperlinks 
Recordings 
Inclusive font 
Visuals 
Examine 
Structure 

The above frameworks are useful methods to remember key 
accessibility concerns. To focus on the important areas of 
digital accessibility this guide uses the FAST approach to 
organize major accessibility fundamentals. 

FAST emphasizes: 
Function 
Appearance 
Structure 
Text equivalents 

Function 
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Function means material: 

• Conveys information effectively in plain 
language appropriate to audience. 

• Is responsive and customizable (Word 
documents, EPUB, and HTML are much more 
accessible than PDF). 

◦ Can be accessed by mouse, keyboard, on a 
phone, etc. 

◦ Can be read aloud, zoomed in, viewed in 
dark/night mode. 

• Has no media that automatically plays. 
• No content flashes more than 3 times per 

second. 

Appearance 

Appearance means content: 

• Has readable fonts. 
• Has sufficient colour contrast. 
• Does not rely on visual style, such as colour, 

alone to distinguish or emphasize. 

Structure 
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Structure ensures content has: 

• Visual and coded structure, including headings 
(not just larger, bold font), lists, and titles. 

• Tables with headers and logical order. 
• Left-justified text (for languages that read left to 

right). 

Text Equivalents 

Including text equivalents is essential for accessibility. 
Ensure: 

• Images have equivalent descriptions provided 
via adjacent text, figure captions, or alternative 
text or are marked as decorative where applicable 

• Links are presented as descriptive, visually 
distinct, linked text not bare URLs. 

• Charts have linked or adjacent table data. 
• Videos have closed captions 
• Audio has transcripts 

In addition, use available accessibility tools and resources, 
including: 

• Templates 
• Accessibility checkers and 
• This Pressbook 

◦ This resource is organized along the FAST framework. 
The details of FAST are not meant to be memorized, 
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nor is the material in this book. Bookmark this 
Pressbook to use as a guide when creating content. 
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Function 

In assessing the function of content, the 
basic question is: “does it work?” 
Functional content: 

• Conveys information effectively 
using plain language. 

• Works on different devices and 
with user customization. 

• Does not automatically play, move, or close. 
• Has no content that flashes more than 3 times per second. 

Functional content is important for users of assistive 
technology to ensure they can consume and interact with 
material. Ensuring function benefits all users, allowing choice 
and customization when accessing material. 

On this page: 
Plain Language  Robust Content  Media 

Plain Language 

A first step to functional content is to write using plain 
language. Plain language is especially helpful for readers with 
cognitive disabilities and/or using assistive technology, but all 
readers benefit from clear, direct writing. 

Plain language helps readers: 

1. Find what they need. 
2. Understand what they find. 
3. Use what they’ve learned. 
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A Stanford study found that people often make their writing 
“more complex in order to appear smarter”, but doing so often 
results in the opposite effect (Oppenheimer, 2006). That does 
not mean writing can never be complex. Writing should be 
appropriate to the audience and context. For example, a course 
outline or subject introduction should be relatively plain. 
Research materials, textbooks, and journal articles can be 
significantly more complex. 

Plain Language Best Practices 

Write for the intended audience: 

• Accessibility guidelines suggest a 9th grade reading level 
for general content, such as a public webpage or general 
document. 
◦ Academic and technical writing will likely exceed that 

level. 
• Check your Word document’s readability or paste your 

content into the Readability Analyzer for statistics. Learn 
about customizing Word Editor settings. 

• Don’t assume knowledge. Introduce and explain concepts 
and technical terms early. 

• Explain acronyms, initialisms, and abbreviations the first 
time they appear. 

Use clear language: 

• Aim for an average sentence length of 15 words. 
◦ Some sentences should be shorter and some should 

be longer. 
• Avoid long words when possible. 
• Avoid idioms and figures of speech. 
• Use active verbs and personal pronouns. 
• Use contractions. 
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Group content: 

• Publish as much content as possible in one document or 
webpage. 

• Avoid sending readers to additional resources or 
downloading multiple formats to obtain essential 
information. 

Further Resources: 

Read more about Plain Language & Accessibility from 
the Government of Minnesota IT Services. 
Consult the Plain Language Action guide. 
Learn more about using simple words and phrases. 
Read Plain Language and Design for Post-Secondary 
by Melinda Worfolk. 

Robust Content 

In digital accessibility, robustness refers to the strength of the 
code behind material. When creating something, ensure your 
content is robust: 

• By testing on multiple devices and browsers 
◦ Zoom in to 200% in a web browser to test that your 

content is adaptive, responsive, and can reflow. 
▪ EPUB and Word will reflow by default. 
▪ Web content can be be made to be responsive 

with relative ease. 
▪ PDF requires significant work to make accessible 
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and generally do not reflow properly (by design). 
• By pressing Tab to verify reading order and focus states to 

ensure links and buttons can be reached by keyboard 
alone. 
◦ Also use Tab to check that table content is read in the 

correct sequence. 

Ensuring your content is robust allows users to customize their 
experience and use on their chosen device. 

Multiple Formats 

Provide content in multiple formats. Robust content can be 
converted between formats with little to no loss of function or 
formatting. 

Choose the best format based on content: 

• Use HTML (Brightspace, WordPress, etc.) whenever 
possible. 
◦ HTML has many accessibility features. 

• Word documents for short documents. 
◦ Word documents can easily be locked to restrict 

editing. 
• EPUB for longer documents like manuals or books. 
• MS Forms for forms and surveys. 
• PPTX for presentations. 
• Use PDFs only when necessary as they are exceedingly 

difficult to make accessible. 

Media 
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Include captioned media in accessible players. Media players 
must be able to be operated by keyboard alone. 

Ensure audio and video do not autoplay; for carousels or 
slideshows, provide an option to pause. If media autoplays, 
many users will have difficulty pausing. The inability to pause 
media will interfere with many types of assistive technology 
and be a distraction to most users, regardless of access means. 

Ensure no content flashes more than 3 times per second as it 
could cause seizures. 

Works Cited 

Oppenheimer, Daniel M. (2006), “Consequences of erudite 
vernacular utilized irrespective of necessity: problems with 
using long words needlessly”. Applied Cognitive Psychology, 
vol. 20, 139-156, 2006. 
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Appearance 

How content appears is an important 
influence on the accessibility of your 
content. Consider: 

• Font choices 
• Use of colour 

Accessible appearance helps those with 
vision impairments, cognitive disabilities, or a colour vision 
deficiency. However, like many accessible design practices, 
following these best practices will benefit everyone. 

On this page: 
Accessible Font  Accessible Colour 

Accessible Font 

Text content needs to be readable. For people with low-vision 
or dyslexia, good font choices can make content easier to read. 
Consider the following passage: 
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Animation 
demonstrat
ing what 
text may 
look like to 
someone 
with 
dyslexia 

Animation 
demonstrat
ing what 
italic text 
may look 
like to 
someone 
with 
dyslexia 

Consider how much more difficult that is based on font choice: 
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Consult footnote
1
 for an unmodified version of this text. 

The above animation is a brief simulation of dyslexia. 
Creating accessible content, including choosing readable fonts, 
have a great impact on people with dyslexia. 

Font Better Practices 

Sans-serif fonts in sizes between 12 and 14 points are shown to 
be the most readable styles (Morrell & Echt, 1997; Lin et al., 2013). 

Prefer sans-serif and basic serifs: 

• Sans-serif fonts such as Aptos, Arial, Calibri, Helvetica, or 
Montserrat are good choices. 

• Simple serif fonts, such as Cambria, Sitka, and Times New 
Roman are readable. 

• Avoid decorative fonts with elaborate serifs. 

1. “Dyslexia, previously known as word blindness, is a learning disability 
(‘learning difficulty’ in the UK) that affects either reading or writing. 

Different people are affected to different degrees. Problems may 
include difficulties in spelling words, reading quickly, writing words, 
“sounding out” words in the head, pronouncing words when reading 
aloud and understanding what one reads. Often these difficulties are 
first noticed at school. The difficulties are involuntary, and people with 
this disorder have a normal desire to learn.” 

Dyslexia – Wikipedia 
“The one argument for accessibility that doesn’t get made nearly 

often enough is how extraordinarily better it makes some people’s 
lives. How many opportunities do we have to dramatically improve 
people’s lives just by doing our job a little better?” 

Steve Krug, Don’t Make Me Think, Revisited 
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Image of 
the letter a 
in upper 
and lower 
case in 
sans-serif 
and serif 
font styles. 
The 
serifs—sma
ll ticks at 
the end of 
character 
strokes—ar
e circled in 
red. 

Use font size 12 or larger for documents, 18 or larger for 
presentations, and 16 pixels or larger on webpages. 

Left-align text for languages that read left to right. Avoid 
justified alignment as that may create “rivers of white space” 
which are gaps that appear to run through a paragraph due to 
coincidental alignment of spaces and excessive blocks of white 
space when zoomed in. 

Consider spacing. 

• Line height or line spacing must be at least 1.5 times the 
font size. 

• Spacing after a paragraph must be at least 2 times the 
font size. 

• Letter spacing must be at least 0.12 times the font size. 
• Word spacing must be at least 0.16 times the font size. 

Avoid excessive use of italics, long blocks of all capitals. 
Do not use images of text and avoid putting text over images. 

More about Font 

Font choices are part of good design and make content 
easier to read for everyone. 
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A simple test for your font choices is the Il1 test to root out 
imposters. When choosing a font, type a capital i, a lowercase L, 
and the number 1 beside each other with no spaces: Il1.

2
 A good 

font will have obvious distinction between those characters. 
A harder to read font will have imposter characters that look 
similar and can easily be mistaken for one another. Choosing 
a readable font helps avoid character ambiguity which may 
cause confusion for readers. 

Consider these examples: 

Poor (Alata) 

Acceptable 

(Roboto) 

Excellent (Noto 

Sans) 

The Il1 test is not the only factor in choosing the right font, but 
is a good quick test of font legibility. 

Accessible Colour 

Text must have a contrast ratio of at least 4.5:1 against the 
background colour. For example, black on white is 21:1 and 
orange on white is 3.37:1. 

Additionally, do not use visual styling, including colour, alone 
to emphasize content. 

2. Admittedly, the default font of Pressbooks, Montserrat, is not an 
excellent example of best practice. 
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These best practices are essential for readers that are colour 
blind, but benefit users printing in black and white, viewing in 
the sun with screen glare, custom contrast settings, or other 
vision impairments. 

The next chapter examines colour in further detail. 
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Accessible Colour 

1 in 12 men and 1 in 200 women have some 
kind of colour vision deficiency (Colour Blind 
Awareness, 2010). To create inclusive content 
foreground information must have sufficient 
colour contrast against background colours. 
Additionally, it is essential that colour is not 
the only means to convey or emphasize 
information. 

On this page: 
Accessible Colour  Colour Contrast  Use of Colour  Digital 

Colour  Colour Code Tools  Further Reading 

Accessible Colour 

Consider that good colour practices aren’t just for those who 
see colour differently. Better practices are 

Essential for 

• Readers with a colour vision deficiency. 
• Readers with low vision. 
• Readers on an electronic paper screen, like an 

e-reader. 
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But also benefit 

• All readers, regardless of access means. 
• Readers that customize appearance and style. 

◦ Effective use of colour ensures 
information looks similar regardless of 
device and user settings, such as dark or 
night mode or other custom contrast 
settings. 

• Readers that print content in black and white. 
◦ Content that relies on colour or lacks 

sufficient contrast will lose meaning in black 
and white. 

• Readers experiencing eye fatigue. 
• When viewing content in poor lighting or when 

there is glare from the sun. 

Colour Contrast 
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For proper colour contrast, 
aim for at least a 4.5:1 ratio. To 
(over)simplify that ratio, that 
means the text is 4.5 times 
brighter than the 
background. Large text (size 
18 point or greater) or bold 14 
point or greater, requires only 
a 3:1 ratio to be accessible. 
Logos and decorative images 
have no colour requirements. 

As an example of an 
accessible contrast ratio, 
black text on a white background has a ratio of 21:1. Orange text 
on a white background (or vice-versa) has a ratio of 3.37:1 and 
does not provide sufficient colour contrast. 

Colour combinations to avoid: 

• Red and green 
• Green and red or blue or brown or black 
• Light green and yellow 
• Blue and purple of grey 

Use dark font colours on light backgrounds (black text on a 
white page for example) and light font colours on dark 
backgrounds (for example white text on a black background) 

Use of Colour 

Further, don’t rely on colour alone to convey information or 
emphasize importance. Accessible practice is to add visual or 
text equivalents to colour, for example: 

• Use colour, shapes, and text in charts and diagrams. 
• Add text indicators to highlighted table cells. 

40  |  Accessible Colour



• Include reminders like “important” or “required” in 
addition to using bold or a specific font colour. 

If you rely on colour alone, readers with colour vision deficiency, 
using screen readers or text to speech software, or those 
viewing in black and white will miss the meaning. 

Digital Colour 

Digital colours are specified using colour codes. The most 
common colour codes are Hexadecimal (hex), RGB, and HSL. 
Each of these colour codes express colours using different 
values. Try entering a colour in this Color Converter tool to see 
how colours can be coded. 

Hex values are referred to in this guide, but the principles are 
applicable to any colour code system. 

Colour Code Tools 
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There are many options for finding colour codes. 
Firefox 

Firefox has a built-in eyedropper tool. Navigate to Tools > 
Browser Tools > Eyedropper. Click on the colour you want and 
the hexadecimal code is copied to your clipboard. 

Additionally, right-click on any webpage and select Inspect. 
Navigate to the Accessibility pane and select an option from 
the Simulate menu to see how different people may 
experience the colour of that page. 
Chrome 

ColorZilla Chrome extension allows you to easily copy colour 
codes from websites. Simply open the extension and use the 
eyedropper to select a colour. The HEX colour code is added to 
your clipboard. 

In Chrome, you can right-click on the colour you want and 
select Inspect. Navigate to the Styles pane in the DevTools 
window. Additional options are available in the Computed tab. 
On a complicated page, you may wish to use the filter box to 
search for “color.” Click on the colour box next to the element 
you want to get the colour codes. This option display contrast 
ratios only if the colour is coded as a foreground or background 
colour relative to another properly coded element’s colour. That 
is not always the case, however, you can still use this method to 
find the hex codes and compare them in another tool. 
macOS 

Built-in to MacOS is the Digital Color Meter application. Press 
CMD + L to lock the meter’s position on the desired colour. Use 
the Color menu or press SHIFT + CMD to copy the colour code. 
This tool allows users to copy colour codes as RGB. 

Contrast for MacOS is an excellent application to determine 
colours and colour contrast. 
Windows 
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TPGi Color Contrast Analyser for Windows is an excellent 
option. 

You can use Microsoft PowerToys to find Hex codes. 

Use these tools to find colour codes and contrast checking 
tools to verify accessible colour contrast. 

Contrast Checkers 

WebAIM (Accessibility in Mind) is an exceptional resource that 
has a contrast checker (that can be added as a browser tool), 
a link contrast checker, and additional reading on colour 
contrast. 

ACE (Accessibility Colour Evaluator) is an excellent tool for 
checking colour contrast. You can set multiple colours for 
multiple elements (background, text, link, hover, etc.) and see 
the corresponding colour contrast ratios. 

Consider some of these as well and find what works best for 
you: 

Color Contrast Checker 
Palette Checker 
Who can use this color combination? 
Color Blind Web Page Filter 
Safe Hexadecimal Color Codes 

Further Reading 

WebAIM guide to WCAG colour guidelines. 
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Use a hierarchical 
structure 

For example: 
Heading level 1: Main topic or 

title. 
Heading level 2: Primary 

sections. 
Heading level 3: Subsections 

of heading level 2s. 

Accessible 
Headings 

Quick Start Guide 

Headings are essential for screen reader users to 
navigate long documents. Headings benefit all 
readers by providing context, organizing material, 
and emphasizing connections. 

To get started with accessible headings: 

 

Use headings in 
Word 

Use the Word Styles gallery 
to set headings. 
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Headings should describe 
the content below it. 

Multiple subsequent 
heading levels can be nested 
under a higher level and any 
content can follow any heading 
level. 

Do not skip a heading level. 

Include style and 
code 

Headings are not just larger, 
bolded text. Use visual style for 
headings to set them apart, but 
headings must also include 
coded meaning. 

Use built-in tools to create 
accessible headings. 

Verify heading structure 
via View > Navigation. 

 

Use Brightspace 
headings 

Set headings using the 
styles menu in the 
Brightspace editor. 
Heading styles can be 
customized using the 
colour, font, and size tools 
in the Brightspace editor. 
The Brightspace 
Accessibility Checker will 
flag out of order headings. 

Moving forward… 
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Use headings to create an accessible and organized 
reading experience for all readers. Additionally, an 
accessible heading structure can help you create 
outlines, reorganize content, and generate a table of 
contents. 
For more information on headings and document 
structure, move to the next page. 
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Structure 

Properly structured documents are 
essential to allow users who cannot see 
the layout to navigate documents. 
Assistive technology relies on the 
underlying structure to differentiate 
between (and indicate to users) content 
types which allows users to jump to 
specific places in the document, browse or skim information, 
and understand an overview before delving deeper. 
Consistently structured documents help all readers with 
context, organization of ideas, and clarity. 

Consider your user 

User Question Feature used to answer 

Where am I? Page, slide, and document 
titles 

How did I get here, where 
can I go? 

Navigation menu, table of 
contents 

What is here? Headings, lists, labels 

What does this relate to? Consistent style and layout 
across related material 

On this page: 
Headings  Navigation  Lists  Tables 

Headings 

Headings are an important part of documents and web pages. 
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Headings create organizational flow, build connections 
between key concepts, and break up large blocks of text to 
increase readability. Headings create a navigable document 
outline that helps all readers understand the logical structure 
of the page and navigate to different sections. Properly coded 
headings convey the document structure to screen readers 
and speech-to-text software. 

Use built-in tools to create headings in nested, sequential 
order. Proper headings are both visual (often larger font) and 
semantic (code for interpreting content). Simply making text 
larger and bold does not give headings essential meaning in 
code. Proper headings have both style and meaning. 

Headings are 

Essential for 

Screen reader users that rely on headings to navigate 
the web and longer documents. The nest hierarchy of 
headings also provides context and relationships 
between key concepts to screen reader users. 

But benefit 

All readers, regardless of access means. 

• Headings provide context and explain 
relationships between ideas. 

• Headings visually show how information flows 
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and review relationships between concepts. 
◦ Coded headings provide the same 

meaning through their nested hierarchy. 
◦ Consistent style and usage aid readers in 

understanding and navigation. 
• Headings emphasize key concepts. 
• Headings can be used as “bookmarks” in a long 

document for readers to use to take breaks and 
resume their place. 

• Headings allow for skimming to review and find 
specific content efficiently. 

Authors. 

• Headings can be used to create a table of 
contents automatically in Word documents. 

• Headings can be moved in the Word Navigation 
pane to move all subheadings and subordinate 
content under that heading. 

• Easily update heading style to change the 
appearance of all headings of that level. 

• Create a summary or overview document. 

Navigation 

• Ensure documents have a title. 
• Add a table of contents to documents longer than 5 

pages. 
• Provide skip links and multiple ways to navigate (previous 

and next buttons, menus, breadcrumb navigation, site 
map, etc.) in HTML. 
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Lists 

Use the list tools to create lists. Creating lists using asterisks or 
dashes will not inform assistive technology that the content is 
part of a list. Lists are useful for steps in a process or grouping 
items. It is important that everyone is made aware of the 
presence of a list. 

Properly formatted lists organize information and makes 
your documents accessible. 

• Use bullet lists to group items or show hierarchy. 
• Lists where the sequence is not important. 

1. Use numbered lists for items where sequence is 
important. 

2. Such as steps in a process. 

Tables 

Table Best Practices 

• Tables must have a header and/or column row. 
• A concise, descriptive table title or caption helps with 

context and organization. 
• Do not use nested, merged, split, or unnecessary blank 

cells. 
• Use cell borders to keep data visually discrete. There are 

exceptions in which cell borders can be removed. 
• Ensure cells have adequate padding and margins. 
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• Do not use colour alone to indicate meaning. 
• Verify table reading order by placing the text cursor in cell 

A1 and press the Tab key to move cell to cell. Ensure 
reading order matches the visual order. 

• The Brightspace Accessibility Checker offers significant 
checks and resolutions to improve table accessibility. The 
Office (Word and PowerPoint) checker does not offer as 
robust checks, only flagging missing header row. 

Do not use tables to enforce layout. Tables are for 
organizing and presenting data (data can be 
numbers or text) in a tabular format. Use columns, 
text alignment, or other layout tools for layout. 

Later chapters will expand on using built-in tools to create 
headings, lists, and tables in different software suites and 
document types. 
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Text Equivalents 

Text equivalents are 
essential to accessible 
content. Everyone 
benefits from clear links, 
blind and low vision users 
need alternative text, closed captions and transcripts are 
helpful to all but essential for people that are deaf or hard of 
hearing. 

As mentioned previously, don’t rely on colour alone 
to convey meaning or importance. 
Add text equivalents to colour, for example: 

• Use colour, shapes, and text in charts and 
diagrams 

• Add text indicators to highlighted table cells 
• Include reminders like “important” or 

“remember” in addition to bolding 
emphasized text 

If you rely on colour alone, readers with colour vision 
deficiency, using screen readers or text to speech 
software, or those viewing in black and white will 
miss the meaning. 

The following chapters will expand on descriptive link text, 
alternative text, closed captions and transcripts. 

Text Equivalents  |  53



Accessible Links 

Use descriptive hyperlink 
text in place of bare URLs. 
Effective link text helps readers 
locate links and understand 
their destination and purpose. 
For users of assistive 
technology hyperlink text can 
be used to navigate content quickly. Bare URLs or links written 
as “click here” or “read more” provide less information to 
everyone and are not useful to assistive technology users for 
navigation. 

On this page: 
Linked Text  Link Examples  Create Links  Cybersecurity 
Citations 

Descriptive links are essential for screen reader 
users but help everyone understand the purpose 
and destination of links. 

Do not use bare URLS and avoid ambiguous links. 

Why? Watch the following demonstration of screen reader 
software reading links. 

One or more interactive elements has been 
excluded from this version of the text. You 
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can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=4255#oembed-1 

The exceptions are for email addresses or short, top-level URLs 
such as Langara.ca 

If necessary to provide a URL, such as on a document you are 
directly printing for distribution, consider using link shorteners 
like bit.ly or tinyurl. 

Linked Text 

Hyperlink text should be: 
Descriptive 

• Describe the destination and purpose of the link, 
independent of adjacent text. For example: Consult the 
Word accessible link guide for more information. 

• “Click here” or “More” are not useful as those links do not 
include purpose or information and are dependent on the 
surrounding context. 
◦ Screen reader software allows users to navigate a 

document by moving link to link. This is useful to skip 
content, browse, and revisit a link. As such, links 
should be unique and make sense without 
surrounding context. 

◦ Consider the Links List Sidebar Firefox extension to 
review links on a webpage and get a sense of what 
links are presented to a screen reader. 

• Bare URLs are unpleasant to listen to and do not provide 
any meaningful information for anyone. Do not include 
bare URLs. The exceptions are short URLs intended to be 
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memorized, such as langara.ca, URLs shortened using 
tools like bit.ly, or email addresses. 

If the link destination is anything but a webpage, 
indicate the type of document file in the link text, 
for example, Screen Reader Reading Links (video, 
2:04). 

• When linking to PDF indicate the file type, size, and use a 
file landing page (if available on your platform) instead of 
direct download or opening automatically in browser. 
Many users are excluded by PDFs and will appreciate the 
warning. 

Concise 

• Hyperlink text should be to the point without superfluous 
information. For example, How to write and create 
accessible hyperlinks in Brightspace is too long. A better 
link might be: Consult the Brightspace chapter for more 
information on creating accessible hyperlinks in 
Brightspace. 

Unique 

• Each link must have unique link text. For example, 
webpages or newsletters are often riddled with scores of 
“Click here” or “Read more” links. Links written that way 
must be avoided. 

• If multiple links go to the same destination, make the link 
text the same for each. 

Visually distinct 

• Use standard link formatting, often underlined text in a 
contrasting colour. 

56  |  Accessible Links

https://mediaspace.langara.ca/media/t/0_48w7pbpe
https://mediaspace.langara.ca/media/t/0_48w7pbpe


◦ Generally, only use underlined text for links. 

To Create Links 

1. Write a description of the link destination using 
informative and relevant words. For example: Accessible 
links in PowerPoint or Digital Accessibility Essentials. 

2. Select descriptive text and use built-in tools to insert a link. 
In most platforms, the link button will resemble a chain or 

interlocking loops, such as: 
3. Or, on most platforms press Control (Command on 

macOS) k. 
4. Paste the destination URL in the address or URL box. 

Most platforms’ default link styling is accessible on white 
backgrounds. Avoid deviating from the default styling. 

Cybersecurity 

Distributing bare URLs has been justified under the 
counterproductive guise of cybersecurity. The assertion is that 
users do not want to click on descriptive hyperlinks for fear of 
navigating to a fraudulent website. 

Users can hover their mouse over, or move keyboard focus to, 
a link and examine the URL in the floating tooltip in documents 
or the bottom left corner of their browser window. 
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Do not post, publish, or share bare URLs. Write descriptive 
links. 

Citations 

For online-only resources (that is, not to be printed) APA style 
recommends hyperlinking the title of the work in the reference 
list. For online-only content MLA style recommends 
hyperlinking the resource title on the works cited page. 

However, for printed material APA guideline 9.35 requires 
that URLs and DOIs include “http://” or “https://” in a reference 
list citation (298-300). According to MLA Handbook guideline 
5.96, in printed material URLs may be truncated to omit 
“http://” or “https://” but must include the remainder of the URL 
in the location element of a works cited entry (195). However, 
according to guideline 5.93, if the item is identified by a DOI 
(Digital Object Identifier), “https://” must be included (194). 
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MLA APA 

Print 

Camp, Nathan T., et al. 
“The Citation 
Catastrophe: 
Propagation of 
AI-Generated 
Counterfeit Citations in 
Scholarship.” The Journal 
of Academic 
Librarianship, vol. 51, no. 
4, July 2025. 
https://doi.org/10.1016/
j.acalib.2025.103065. 

Camp, N. T., Bengtson, J. 
A., & Sandstrom, J. C. 
(2025). The citation 
catastrophe: 
Propagation of 
AI-generated counterfeit 
citations in 
scholarship. The Journal 
of Academic 
Librarianship, 51(4). 
https://doi.org/10.1016/
j.acalib.2025.103065 

Online 

Camp, Nathan T., et al. 
“The Citation 
Catastrophe: 
Propagation of 
AI-Generated 
Counterfeit Citations in 
Scholarship.” The Journal 
of Academic 
Librarianship, vol. 51, no. 
4, July 2025. 

Camp, N. T., Bengtson, J. 
A., & Sandstrom, J. C. 
(2025). The citation 
catastrophe: 
Propagation of 
AI-generated counterfeit 
citations in 
scholarship. The Journal 
of Academic 
Librarianship, 51(4). 

Unfortunately, neither of these guidelines address the issue 
that a reader may choose to print an ‘online-only’ resource. 
This leaves creators in a potentially tricky position. While some 
may adhere to the rigid rules of various citation guidelines, best 
practice is to prefer accessibility and provide hyperlinked text 
over bare URLs whenever possible. 
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Alternative 
Text 

Quick Start 
Guide 

Alternative text (alt text) is an equivalent text 
description of visual information. 

Visual elements that include information must have a text-
based description. Graphics, such as backgrounds, borders, or 
visual flourishes that do not contribute information are 
decorative. 

Mark decorative images 

Images included for purely aesthetic purposes (or that have an 
adjacent text equivalent or descriptive figure caption) should 
be marked as decorative. 
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If unsure, err on 
the side of adding alt 
text. It is better to 
repeat information 
than have someone 
miss out completely. 

Marking images as 
decorative, adding a 

Describe 
informative images 

For visuals that contain 
information there are three 
methods to provide 
alternative text: 
Adjacent text provides 
details equivalent to the 
visual information. Use 
visuals and text to support, 

reinforce, and reference each other. All users can access 
important information when presented in plain text. 
Figure captions are generally placed below visual elements 
and provides all users with supplementary information such 
as citations, accreditation, and contents and are useful to 
orient all users. 
The alt text field presents a concise description of visual 
content to screen reader software used by blind and low vision 
users. The alt text field is also where images are marked as 
decorative when appropriate. 

Depending on the complexity of the graphic, knowing which 
type of text alternative to provide is important. Alt text depends 
on context and purpose. If equivalent information is present in 
adjacent text or a figure caption, graphics should be marked as 
decorative. 
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figure caption, or 
including alt text will 
differ depending on 
platform or software. 
Refer to later 
chapters in this 
guide for 
instructions to add 
text equivalents to 
visuals in specific 
platforms. 

Alt text = type + focus + details 

To write alt text: Include the type of visual, describe the focus, 
and add essential details. Consider how you would describe 
the image if talking to a friend on the phone. Use proper 
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punctuation and grammar and limit alt text to 2 or 3 brief 
sentences. 

Alt Text Example 

[type] Diagram of [focus] satellite image resolutions 
comparing real object shape to satellite images taken 
at 30 metre, 10 metre, and 1 metre resolutions. [details] 
The diagram illustrates that the shape of an object will 
be more accurately represented as the resolution of a 
satellite image increases. 

Use AI as a starting point 

AI has rapidly improved in describing 
images, particularly the structure of 
complex images and extracting text from 
images. Edit AI generated descriptions for 
accuracy and clarity. Read more about 
using AI to generate alt text. 

 

Moving forward… 
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Understand that alternative text is so fundamental to 
accessibility it is the first Web Content Accessibility 
Guideline (1.1.1). Writing alt text is somewhat of an art. 
Including adjacent text equivalents and reinforcing 
visual information with text is an excellent way to reach 
everyone. Remember to try your best, ask for help, and 
try to be as inclusive as possible. 
For more information on Alt Text, move to the next 
page. 

64  |  Alternative Text Quick Start Guide

https://www.w3.org/WAI/WCAG21/Understanding/non-text-content.html
https://www.w3.org/WAI/WCAG21/Understanding/non-text-content.html


Alternative Text 

Alternative text (alt text) is a 
description of visual content. 
Descriptions can be provided by 
adjacent text, an image caption, or 
the alt text field. Alt text is code 
that is read by screen reader 
software to blind and low vision 
readers. Alt text allows all users to understand the context, 
purpose and meaning of visual content by relaying critical 
visual information in text format. 

Alt text is essential to digital accessibility. According to WCAG 
2.0 Guideline 1.1.1 : “All non-text content that is presented to the 
user has a text alternative that serves the equivalent purpose.” 

On this page: 
Where to Include Alt Text  Decorative Images  Writing Alt 

Text  Common Platform Guides  View Content Without 
Images  Further Reading 

Provide alt text because it is 

Essential for 

Screen reader users to understand non-text content 
such as images, diagrams, and other graphics. 
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But also benefits 

• Users with low bandwidth or inconsistent 
connection. 

• Users with content blockers that could prevent 
images from being displayed. 

◦ Alt text provides context, purpose, and 
information of the image if it does not load. 

• Creators by providing clues for moved or missing 
image source. 

• Creators by incorporating a review of why an 
image is being included. Is it decorative? Does it 
contribute useful information? If not, is it 
necessary? 

Images and diagrams are excellent compliments to text and 
vice-versa. Including visuals can break up large block of texts 
and increase understanding. However, do not overly rely on any 
single format alone. 

Where to Include Alt Text 

Add alt text to visual elements that contain information. This is 
essential to provide a text equivalent of visuals, including: 

• Images and graphics 
• Diagrams and charts 
• Images of text 
• Important logos 
• Linked images 
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• Buttons styled with a graphic 

Use this tool to determine when to use alt text (including some 
tips for writing alt text based on image type) or when to mark 
an image as decorative. 

An interactive H5P element has been excluded 

from this version of the text. You can view it online 

here: 

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=48#h5p-73 

Decorative Images 

Useful alt text is important. 
Knowing when to mark a 
graphic as decorative is 
equally important. Visual 
elements that are included 
purely for aesthetic purposes 
and do not contribute any 
meaningful information 
should be marked as 
decorative. Additionally, a 
graphic should be marked as decorative if the information in 
the visual element is available in another format such as a 
figure caption or adjacent text. Use images and text to support 
and reinforce each other to make content more accessible and 
easier for all to understand. 
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Mark decorative images with built-in tools (often a checkbox 
labelled “mark image as decorative” or similar) or with alt=“” in 
HTML markup. 

If in doubt, err on the side of adding alt text. It is 
better someone consume content twice than miss 
out altogether. 

Image Attribution 

When adding an image attribution (copyright license etc.) to 
a decorative image, ensure the caption is also marked as 
decorative. If it is not, assistive technology would not announce 
the image, but would read the succeeding attribution text. This 
would lead the reader to believe they may have missed an 
important image. 

To add a caption to a decorative image in: 
Word 

1. Right-click on an image and select Insert Caption… 
2. Or select the image, move to the References tab and 

select Insert Caption. 
3. Enter your caption and select Ok. 
4. Right-click the image and choose Edit Alt Text… 
5. Check Mark as decorative. 

PowerPoint 

1. Move to Insert and select Insert Textbox. 
2. Place the textbox under the image and type your caption. 
3. Control (Command on macOS) and click, or click and drag 

over, the image and the textbox. 
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4. Right-click the image and select Group > Group. 
5. Or, on the Home tab, select Arrange > Group > Group. 
6. Select your new group and copy (right-click 

> Copy or Control [Command on macOS] and c). 
7. On the Home tab, choose Paste > Paste Special. 
8. Choose Picture (PNG) and select Ok. 
9. Right-click on newly grouped image and select Edit Alt 

Text… 
10. Check Mark as decorative. 
11. Remove old image and textbox. 

PDF 

The image caption should be marked as an artifact along with 
the image. 
Webpage 

1. Use <figure> for proper formatting to include a caption 
via <figcaption> 

2. Enter an alt attribute of alt=”” for the image. 
3. Use aria-hidden="true" to ensure a screen reader will not 

read the <figcaption> tag. 

Wrap the <figcaption> in a <div>, for example: 
<figure> 
<img 

src="example.png" alt="" width="500" height="600"> 
<div aria-hidden="true"> 
<figcaption>Image caption to be hidden from screen 

readers</figcaption> 
</div> 
</figure> 
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Writing Alt Text 

Before writing alt text, consider the context (information 
around image in content), purpose (what the image 
contributes), and meaning (the message the image conveys). 

Understand that graphics can be informative, functional, or 
decorative. An informative graphic includes information and 
must be accompanied by a text description. A functional image 
performs an action like a link or button; the alt text must 
indicate what the action will be when the graphic is activated. 
A decorative image is purely for aesthetic purposes such as 
a border or background. Note, when accompanied by alt text 
or a figure caption, informative images can be marked as 
decorative. 

To begin writing alt text, consider how you would describe 
the image to someone over the phone. 

Caroline Desrosiers offers a formula to write alt text: 

1. Identify the image type (if not a photo) 
1. Indicate if an image is a diagram, map, symbol, gif, 

drawing, cartoon, etc. The added context will orient 
users and aid their understanding. 

2. Describe the focus of the image 
1. What is the most important information in the image. 

3. Add relevant details 
1. Add details that contribute information or meaning 

but are not the focus. 

Let’s consider this example: 
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Type = graphic 
Focus = north pole 

centered globe 
Details = surrounded by 

olive branches. This is the 
United Nations logo. 

So, that provides us with alt 
text that would read “Graphic 
of north pole centered globe 
surrounded by olive 

branches. This is the United Nations logo.” 

Alt text should be succinct and accurate, including 
punctuation and grammar. There is no limit to the length of 
alternative text but aim for a sentence or two at most to provide 
a pleasant reading experience. 

Other types of images might be suited to a different formula. 
Object – Action – Context (Chen, 2020) is a method similar to 
type, focus, detail mentioned above. 

Object = Line graph 
Action = graph shows the 

amount of alt text written 
and the difficulty 
encountered in writing alt 
text over time. 

Context = The difficulty in 
writing alt text rises briefly before quickly declining over time 
as the amount of alt text written increases consistently after an 
initial dip. 

This method provides us with the alt text “A line graph that 
shows the amount of alt text written and the difficulty in 
writing alt text over time. The difficulty in writing alt text rises 
briefly before quickly declining over time as the amount of alt 
text written increases consistently after an initial dip.” 
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Use Relational Terms 

Describe the relative size and scale of elements in the graphic. 
Describe elements relative to the subject, one another, or to a 
common object. 

Describe the directional and positional information of objects 
in the graphic relative to the frame, such as “on the right” or 
“near the top left corner.” 

Depending on context, terms like “partial view,” “bird’s-eye 
view,” or “close-up” can be crucial. 

Materials, mediums, and textures can be identified by name 
where possible. 

For an image of a recognizable person or place, name them 
directly but also describe any relevant details. 

What to Avoid 

If a photo, do not include “photo of…” or “image of…” 

• However, “Screenshot of…”, “diagram…”, “map of…”, “cartoon 
drawing…” are useful information to orient users. 

Do not include: 

• Copyright information or attribution. 
◦ Copyright information should be included in a caption 

below the image or in a list of references. 
• Emoticons. 
• Hashtags. 
• SEO keywords. 
• Promotional material. 
• Links. 

Do not repeat information contained in adjacent text or 
included in a visible caption. 

• If the relevant information of an image is include in a 
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caption or adjacent text, you can mark the image as 
decorative. 

• If graphic element has a descriptive caption and is labelled 
with “Figure 1” for example, alt text could read “Figure 1, 
image caption contains description.” 

• Image captions are useful for copyright, attribution, more 
information, or links. 

Do not editorialize or include your own feelings or bias. Only 
include the important information to provide an accurate 
description. 

Do not make any assumptions about gender or ethnicity. 
Prefer “they,” “them,” or “person” unless details are verifiable. 

AI has improved the accuracy of machine-generated 
alternative text. Keep in mind that even an accurate description 
will provide no context or purpose. AI generated alt text may be 
useful as a starting point to be edited by a human. 

Common Platform Guides 

Introductory resources on adding alt text in common 
platforms: 
Microsoft Office 

To add alt text in Word and PowerPoint: 

1. Right click on an image and select Edit Alt Text… (View 
Alt Text… on macOS, Edit Picture Alt Text on Office 365) 

2. Or, use the Picture Format Tab and select Alt Text 
3. Type an image description 

Read more about adding alt text in Word and PowerPoint. 
Brightspace 
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To add alt text to images in Brightspace: 

1. When adding an image, you will be prompted to add 
alternative text or mark the image as decorative 

2. To add alt text to existing images: 
1. Select the image 
2. Choose Image Options 
3. Enter alternative text or check Image is decorative 
4. Choose Save 

Review the Brightspace Alternative Text chapter later in this 
guide and consult D2L guides on Alt Text for Brightspace Web 
Page Images. 
H5P 

To add alternative text to H5P images, enter a description in the 
Alternative text field or check Decorative only. 

Read more about adding alt text in H5P. 
WordPress 

To add alternative text in WordPress or Pressbooks: 
When uploading an image to WordPress, complete the Alt 
Text field in Media Library. 
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You can also add alt text in the Text/HTML editor in 
WordPress with alt=”description of image”. 

Or, select an image and choose Edit, complete the 
alternative text field and choose Update. 

Consult the Pressbooks chapter and WordPress chapter of 
this guide for more information. 

Read more about alternative text for images from WordPress 
support documents. 
PDF 

To add alt text to PDFs: 

1. Open Reading Order pane 
2. Open Reading Order Panel 
3. Right click on an image and choose Edit Alternate text 
4. Enter your description and choose Ok 
5. For a decorative image, select the image and choose 

Background/artifact 

HTML 

Alt text is entered in the <img> alt attribute. Decorative images 
must be marked alt=”” 

In WordPress and Pressbooks alt text is added to the 
Alternative Text field in the Media Library. 
Other platforms 

Google Docs and Sheets support alt text. 
Twitter supports alt text for images you post. 
Facebook allows users to add alt text on Facebook photos. 
Instagram adds automatic alt text to images. Note that 

automatic alt text is rarely accurate and should be checked and 
edited. 

Later platform-specific chapters will cover how to provide 
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equivalent text, add captions, and populate the alt text field in 
greater detail. 

View Content Without Images 

If you are not sure about an image, try viewing your content 
without the image. If no information is lost, you can mark the 
image as decorative. 
To view web content without images: 

In Google Chrome: 

1. Select View site information (padlock icon on left side of 
address bar). 

2. Select Site settings. 
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3. Beside Images, choose Block. 

4. Move back to the website tab and click Reload or refresh 
the page. 
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5. The page will load without images. Verify that no 
information is lost when images are removed. 

To restore images: 

1. Click on image icon with red x in the address bar and 
select Always allow [website] to show images. 

2. Click Done. 
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Or 
3. Select View site information (padlock icon on left side of 

address bar) and toggle Images on or click Reset 
permission. 

Nothing New 

Describing an image in text is not a new concept. Consider this 
postcard by Al Harvey from the mid-1970s: 
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On the reverse, note the description: 
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VANCOUVE
R, B.C., 
Canada 
Aerial view 
of 
Downtown 
Vancouver, 
Burrard 
Inlet and 
the North 
Shore 
Mountains. 
This aerial 
view 
showing 
Granville 
Street 
Bridge in 
the 
foreground 
is a clear 
testimonial 
to the 
exciting 
skyline and 
surroundin
g beauty of 
this seaport 
city. The 
residential 
areas of 
West and 
North 
Vancouver 
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are seen in 
the 
backgroun
d. 
Photo by Al 
Harvey 

The inclusion of this description (while not 
necessarily perfect for alt text) is an excellent 
example of a figure caption that describes the 
content of an image. While it is important to 
always include a text equivalent of an image, this 

postcard exemplifies why that practice is valuable beyond 
accessibility considerations and has been common practice for 
decades. 

Further Reading 

Tips for alt text by type of image from W3C Web 
Accessibility Initiative. 
W3 Web Accessibility Initiative’s alt text decision tree is 
useful for narrowing down what your alt text should 
convey. 
WebAIM offers a comprehensive resource on alt text. 
Write helpful Alt Text to describe images. 

Works Cited 

Chen, Alex. “How to write an image description.” UX Collective – 
Medium, 2020. 
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Alt Text for Complex 
Images 

Describing complex visual content, such 
as flowcharts and diagrams, can be 
difficult. 

When using complex visuals, ensure all 
users: 

• Are aware there is an image with 
information 

• Understand the nature and purpose of the image 
• Are informed that the image is complex 
• Know how and where to get more information (if 

appropriate) 

On this page: 
Complex Visual Workflow  Beyond Alt Text  Further 

Reading 

Complex Visual Workflow: 

The following is adapted from Recommendations – Describing 
complex images 

Use the following prompts to determine the best way to 
provide a text alternative to complex images: 

Can the essential information be described in a few brief 
sentences? 

1. If yes, type a description of the image using the [type] + 
[focus] + [details] outlined in the previous chapter. 
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2. If no, ask: 

Does nearby text include the information in the image? 

1. If yes, mark the image as decorative or use alt text to direct 
users to text description. 

2. If no, consider: 

Is the information in the image available in other resources? 

1. If yes, use figure caption to link to resource. 
2. If no, consider using AI to generate an effective 

description. 
1. Use Ian Linkletter’s Alt Text Assistant to create 

descriptive text. 
2. Or, use CoPilot to generate a description. Consider 

asking CoPilot to “outline the information in the 
image” or “describe the image in detail.” 

3. Google Gemini can also describe images and may be 
useful. 

4. AI generated descriptions are improving, but must be 
verified for accuracy. Read the AI Generated Alt Text 
chapter in this guide for more information. 

If the description (AI assisted or not) is more than a few 
sentences, format the output with paragraphs, headings, and 
lists. Include the long description in adjacent text or an 
appendix. Make reference to the long description in the alt text 
or include a link in the figure caption. 

If no useful description can be created and/or it is not feasible 
to link to additional information, use the complex alt text 
formula (explained below) to direct readers to a support 
contact for further details. 
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Attribution: 
Kandasam
y S and 
Nagender 
Nath B – 
via 
Wikimedia 
Commons. 

Complex Alt Text Formula 

While the [Type] + [Focus] + [Details] alt text formula from the 
previous chapter is an excellent starting point, it may not be 
suitable for complex images. The World Wide Consortium has 
developed an expanded version: 

“[Image type] illustrating [data type] showing [reason for 
including image]. This is a complex image and may require 
specific support for blind and low vision students – please 
contact [Name of designated person] if required.” 

As an example, consider this model of the global carbon 
cycle: 

To completely describe the information in this image would be 
impossible within the constraints of alt text. However, applying 
the complex image formula may be helpful: 

“[3D landscape model] illustrating [global carbon stores 
(Petagrams) and fluxes (Petagrams/year)] showing [the 
complexity of the cycle and the main impacts of human 
interference]. This is a complex image and may require specific 
support for blind and low vision students – please contact [your 
name] if required”. (Note: remove [ ] before including complex 
image formula as alt text). 
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Beyond Alt Text 

As mentioned in the prior chapter, alt text should be brief. 
For a complex image, it may not be feasible to describe the 
image in 1 or 2 sentences. Additionally, alt text does not support 
lists or headings. Structured text is essential to make long text 
digestible for screenreader users. That is one of the reasons 
why alt text should be brief. 

Additionally, alt text cannot contain links. Links could be used 
to direct screenreader users to additional information about an 
image. However, links can be placed in figure captions. 

When alt text may not be sufficient due to length, 
formatting, or other concerns use: 

Adjacent text is the most accessible and inclusive practice. 
Adjacent text has no length limit and supports any desired 
structure, formatting, and styling. Providing text and images 
together is an effective method to reinforce important 
information and emphasize key points. Note, if an equivalent 
description is available in adjacent text there is no need to 
populate the alt text field. 

If adding a text description adjacent to the image is not 
feasible, provide the long description at the bottom of the page 
or in an appendix. Make reference to the location of the 
description in the alt text or provide a link to the description in 
the figure caption. 

Figure captions are a text label associated with a visual. 
Figure captions are usually below or beside the graphic. Figure 
captions benefit all users by clearly identifying the image, its 
purpose, and its relation to the rest of the material. Figure 
captions can include citations, photo attribution, cultural 
context, historical or scientific information about the subject, 
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complex data from charts, etc. Unlike alternative text, figure 
captions have no length limit. 

Equivalent Data for data visualizations is one of the few ways 
to provide chart or diagram data. Include table data or long text 
description in an appendix, note, or footer. Use figure caption 
to link to said data or include reference to available data in alt 
text field, for example “Refer to table 3 at the end of this chapter 
for more information about this chart”. 

A best educational practice is to use images to reinforce 
information. Try to present information in text and add images 
to supplement and highlight key points and processes. By 
doing that, you may not need to describe complex images as 
the information is already provided in text format. 

Further Reading 

Diagram Center advanced alt text guidelines are 
helpful and has an e-book of alt text samples organized 
by graphic type. Additionally, Diagram Center’s training 
tool helps to better understand how to write alt text. 
W3C Complex images – making sense for accessibility 
Portland Community College has an excellent 
presentation on alt text for complex images. 
Read more about alt text for data visualization. 
Consider textBOX Digital’s Focus|LOCUS method for 
writing alt text that emphasizes context, scene setting, 
and storytelling. 
Read more about describing complex images. 
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AI Generated Image 
Descriptions 

Generative AI chatbots have rapidly 
improved their ability to recognize and 
describe images. CoPilot, ChatGPT, and 
Gemini have shown to be useful at 
describing images and provide a 
starting point for writing text 
equivalents, figure captions, and alt 
text. For an introduction to alt text, consult the Alternative Text 
Quick Guide hosted earlier in this book. 

When creating alt text consider the context and purpose of 
the image. When writing alt text focus on the type, the focus of 
the image, and the important details. 

On this page: 
AI Chatbots  Alt Text Assistant  Image Accessibility Creator 

AI Chatbots 

For generating alt text and image descriptions using chatbots 
such as CoPilot or Gemini: 
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Select the Add an image button to upload a file. 

Options may look different depending on tool used. 
Using specific prompting produces useful image 

descriptions: 

Copy and paste the following as your prompt: 

Using the uploaded image, act as a post-secondary 
instructor writing a title, image description, and 
alternative text for college and university level learning 
material. 
Please provide: 

1. Title: A concise, descriptive title (5-10 words) 
2. Image description: Provide a general overview 

of what the image portrays before providing 
details. The image description should be 
objective, concise, and descriptive. Descriptions 
should be straight forward and factual, avoiding 
interpretations. For complex images, the detailed 
description may be one or more paragraphs and 
must describe the image in great detail. However, 
not everything needs to be described if it is not 
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important in the context of the image. The 
detailed description should be easily scannable 
and use headings, paragraph breaks, and lists as 
appropriate. Descriptions may utilize vivid 
terminology to describe various features like 
composition, shapes, size, texture, and color but 
always provide this information in a separate 
paragraph. 

3. Alternative text: The alternative text output 
should be less than 150 characters, grammatically 
correct, while describing the essential visual 
elements of the image. Good alt text should 
identify the image type (when not a photo, such 
as a chart, map, painting, etc.), describe the most 
important information, and add details that 
contribute information or meaning. 

4. Text: If the image or graphic contains text, add a 
section and transcribe all the text in the image. 

Output the above 4 sections using headings, 
subheadings, and lists as appropriate. For number 3, 
Alternative Text add “If this description is sufficient, use 
it in the alt text field. If it is not, explore alternate means 
to provide the long description above.” 

Adapted from Image Accessibility Generator – Teach 
Online 

Interacting with a chatbot like CoPilot is an iterative process 
of prompt, response, re-prompt. When the chatbot provides 
an image description, indicate what was incorrect or ask the 
chatbot to focus more on a specific element. Asking to make 
a long description shorter often crops, rather than condenses, 
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the text to the requested length. Keep in mind, this may result 
in essential information being excluded. Always include a 
length parameter in your initial prompt if desired. Remember, 
use AI as a starting point to understand the main information 
and visual structure of an image and then edit the output for 
accuracy, clarity, and brevity. Read more about AI Prompting. 

Note: Depending on your license, Microsoft products 
like PowerPoint and Word may not have CoPilot’s 
ability to describe images. The AI generated image 
descriptions in those platforms are poor quality and 
should not be relied on. 

 Alt Text Assistant 

Alt Text Assistant is a custom interface for ChatGPT with 
predefined parameters to help write alt text and image 
descriptions. 

Navigate to Alt Text Assistant: 

1. Select Can you help me create alt text? or Can you help 
me create descriptive text? 

Alt text is best for basic images. Descriptive text is 
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necessary for complex images. 
2. Select the paper clip icon to upload an image. 
3. Select your image file. 
4. Press Enter or click Send Message (up arrow icon) button 

on the right of the text field. 

For further information on using CoPilot, Gemini, and ChatGPT 
consult the National Centre for AI Empowering Educators 
series. 

Image Accessibility Creator 

Consider the Image Accessibility Creator to generate alt text. 
Upload an image and select Create image details to generate 
alt text. This tool allows users to add specific details about the 
image to ensure specifics are included or emphasized. 

Remember… 

Always verify AI output for accuracy. Using AI to 
generate alt text and image descriptions is a great 
starting point but requires you, as the content creator 
and expert, to double check and refine what AI 
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generates. The intention is to use AI to reduce your 
workload without creating junk descriptions that will 
create additional work and confusion for users. 

There are privacy concerns with AI platforms. We 
recommend using caution when inputting – or 
having your students input – private, personal, or 
sensitive information (e.g. resumes or other 
identifying data). AI relies on large language models 
that are incomplete and biased. To generate 
content, chatbots use predictive text and any output 
should be verified for accuracy. 
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Use closed captions 

Closed captions are a text file 
attached to a video, allowing 
viewers to toggle on or off the 
captions. Open captions, or 
subtitles, are burned into the 
video and not user choice. Use 
subtitles for additional 
languages in a video. 

Leverage AI 

Advances in AI have greatly 
improved transcription of 
audio to text. Use AI to 

Closed 
Captioning 
Quick Start 

Guide 

Adding closed captions to your video helps all 
viewers but is essential for deaf and hard of 
hearing people. 

Getting started with captioning: 
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generate captions, then edit for 
accuracy. 

Use OneDrive 

Videos uploaded to OneDrive 
will have captions 
automatically generated. 
Review and edit the captions 
for accuracy. 

Use Kaltura 
Mediaspace 

Media uploaded to Kaltura 
Mediaspace/My Media in 

Brightspace
1
 automatically create machine-generated 

captions. Review and edit captions for accuracy. 

1. Media uploaded after October 2022 only 
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Live captions 

In Teams: 

When moving a video 
file between 
platforms, such as 
uploading an MP4 file 
to Brightspace, the 
captions exist as a 
separate file which 
needs to be uploaded 
alongside the video 
file. For that, and 
other reasons, we 
recommend using 
Kaltura. Once a 
Kaltura video is 
captioned it is always 
captioned when 
embeded, linked to, or 
otherwise shared. This 
eliminates the need to 
keep track of multiple 
files. 

Moving forward… 

Add and edit captions 
for your videos. Prefer 
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In Zoom: 

Note that automatic captions 
will not be accurate enough to 
meet accessibility standards, so 
plan to hire live transcribers 
and/or interpreters. 

captioned videos. A 
video is not finished 
until it is accurately 
captioned. 
For more information 
on captions and 
transcripts, move to the 
next page. 
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Prefer videos with 
captions 

When choosing existing videos 
to distribute or show, choose 
videos that have captions. 
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Closed Captions 

Captions provide a text 
equivalent of all audio 
elements in a video, presented 
visually in time with the video. 
Closed captions can be 
toggled on or off by the viewer. 
Open captions are ‘burned’ 
into the video and cannot be turned off. 

Traditionally, we think of captions as an accommodation for 
viewers who cannot hear the audio in a video due to hearing 
loss. Statistics suggest 4-5% of the general population 
experience some form of hearing loss. That number increases 
to around 20% for people over age 60. However, 80% of 18 
to 25-year-olds regularly use captions when watching video 
(Youngs, 2021). 

On this page: 
Captioning Best Practices  Kaltura  H5P  Further 

Resources 

Captions are essential for: 

• D/deaf and hard of hearing viewers 
• Viewers experiencing a temporary barrier such 

as an ear infection 
• Viewers experiencing a situational barrier such 

as being in a loud environment 
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Captions also benefit: 

• All viewers, regardless of access means because: 
◦ Captions aid comprehension, focus, and 

memory (Gernsbacher, 2015). 
◦ 90 percent of all students who use closed 

captions find them helpful for learning (Dello 
Stritto and Linder, 2017) 

◦ Captions ensure names and terminology 
are communicated exactly as they are 
spelled. 

• Viewers watching a video with accents other 
than their own. 

• User experience by allowing viewers to choose to 
turn on or off the captions. 

• Creators by allowing them to index and search 
video via subtitle timestamps. 

• SEO. 
• Creators to easily locate a specific topic and 

create video chapters. 
• Creators to convert audio content to text form 

Best Practices 

Writing captions can be an intensive process. Consider the 
following best practices to write accurate captions: 
Closed Captions 

• Use closed captions as they can be toggled on an off by 
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the viewer. 
• Open captions are embedded into the video and cannot 

be “turned off”. Avoid open captions. 

Accuracy 

Captions should be 99% accurate 

• Machine-generated captions are often ~80% accurate 
• Use machine-generated captions as a starting point and 

then manually edit 

Speaker Labels 

• Establish identity of all speakers (whether on-screen or off-
screen) by name or meaningful identifier 
◦ Use (Name) or (Speaker/narrator/identifier of some 

kind etc.) to identify different speakers. 
◦ By default, Kaltura uses [Speaker:] which that is 

acceptable as well. 
• If speakers change off screen, use “-” to indicate the 

change in speaker 
• Double check spelling of names via graphics in the video, 

the video description, or own research. 

Readability 

Captions should have proper sentence case for readability. All 
uppercase can be used for screaming or shouting. Use proper 
syntax, punctuation, and capitalization (for proper nouns and 
names). 

• Caption lines should end at natural linguistic breaks, such 
as a natural pause mid-sentence of the end of the 
sentence to create understandable, logical segments of 
speech. 

• Keep subjects, phrases, and key terms in a single caption, 
where possible. 

• If a complete sentence fits within one caption, it should. 
Extend the timing of the caption to match. 
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• Start a new caption with each new sentence. 
◦ Two very short sentences can be displayed in a single 

caption. 

Timing 

Each caption should display at the same time the first word of 
the line is spoken. 

• If there is an extremely quick sequence of information, fast 
dialogue, and/or large blocks of jargon and terminology, 
start the caption slightly before the speaker is heard. 

• Captions should appear for at least 1 second but less than 
10 seconds. 

• Captions for non-speech audio and music should appear 
for a maximum of 5 seconds. 

• Do not display more than 2 lines per caption frame. 

Sound Effects and Music 

• Sound effects, music, and other audio should be 
mentioned in enclosed brackets. 
◦ Sound effects are any meaningful audio content that 

is not spoken. 
◦ Standard practice is to describe the sound in [sound]. 

▪ [doorbell ringing] 
▪ [dog barking] 
▪ [ambient street sounds] 

◦ If music is known, provide [title by artist]. 
▪ For unknown instrumentals, describe briefly, for 

example: “[soft piano music]”. 
◦ Music with lyrics, introduce the song with [title by 

artist] and then transcribe lyrics in sync with the video 
within a symbol, for example: “#song lyrics to a song#”. 

Content 

• You may ignore “um” “ah” “uh-huh” etc. 
• A relevant pause can be noted with “…”. 
• A notable change in thought can be marked by “–”. 
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• Do not censor or edit the audio content. Transcribe it as is. 
• Mark inaudible or muffled audio with “[Inaudible]” or 

“[Unclear]”. 
• Include proper punctuation and syntax. 

Numbers 

• Transcribe “four and a half kilometers” as “4.5km”, “9 
o’clock” as “9PM”, “three dollars” as “$3”, etc. 

• Numbers one to ten can be written as words (one, two, 
etc.) except when used in units of measurement or 
currency. 
◦ Numbers above 11 should be written as digits. 
◦ Numbers over one million should be captioned as “1 

million”, “3 billion” etc. 
• Use % in place of “percent”. 
• Dates: 

◦ A speaker saying “the second of June twenty fourteen” 
should be captioned as “2 June, 2014”. 

◦ A speaker saying “June the second twenty fourteen” 
should be captioned as “June 2 2014”. 

Kaltura Guide 

Ordering Captions 

1. Navigate to your media on Langara College MediaSpace or 
in Brightspace via My Tools > My Media. 

2. Select Actions > Caption & Enrich. 
3. Click Submit button. 
4. Within 30 minutes, the machine-generated captions 

should be completed, which then need to be edited for 
accuracy. 

Closed Captions  |  103

https://mediaspace.langara.ca/


One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=30#oembed-1 

Editing Captions 

1. Navigate to your media on Langara College MediaSpace or 
in Brightspace via My Tools > My Media. 

2. Select Actions > Edit. 
3. Select the Captions tab. 
4. Click Edit Captions button. 
5. Edit captions for accuracy. 
6. Click Save. 
7. Adjust the caption accuracy slider. 
8. Click Save. 

https://mediaspace.langara.ca/media/t/0_k6w1w799 

Upload Captions 

1. Navigate to your media on Langara College MediaSpace or 
in Brightspace via My Tools > My Media. 

2. Select Actions > Edit. 
3. Select the Captions tab. 
4. Click Upload captions file button. 
5. Select file and complete required fields. 
6. Click Save. 
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One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=30#oembed-2 

Downsub.com allows you to copy subtitles from a video on 
YouTube and upload them to Kaltura. Simply paste the 
YouTube URL on Downsub and then upload the .SRT file to 
Kaltura as outlined above. 

Learn more about Kaltura 

Kaltura offers support for uploading caption or 
transcript files, manual captioning, and automatic 
captions. 
Editing Kaltura captions. 
Kaltura instructions for uploading a caption file to a 
video. 
Kaltura instructions for managing and editing captions. 
Information on Kaltura’s captions & enrichment 
services. 
Langara Education Technology step-by-step 
instructions on captioning Kaltura videos. 
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H5P 

H5P requires .VTT caption files. The below guide shows how to 
generate .VTT files and add them to H5P video elements. 

An interactive H5P element has been excluded 

from this version of the text. You can view it online 

here: 

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=30#h5p-155 

Further Resources 

Toronto Metropolitan University’s guide to captioning 
and description. 
WebAIM guide to captions, transcripts, and audio 
descriptions. 
Described and Captioned Media Program’s guidelines 
and best practices for captioning educational video. 
BBC Subtitle Guidelines (the most extensive resource 
for captioning guidelines on the web). 
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Captioning and 
Transcription Tools 

On this page: 
Captioning on Common Video Platforms  Find Captioned 

Videos on YouTube  Social Media Captions  Create Caption 
Files  Transcripts 

Captioning on Common Video 
Platforms 

OneDrive and SharePoint 

1. Open a video file in OneDrive/SharePoint 
2. Select Video settings in right hand toolbar 
3. Select Transcript and captions 
4. Click Generate 
5. Select Spoken language 
6. Click Generate 
7. Once captions have been generated, select Transcript in 

right hand toolbar 
8. Click Edit beside any caption that requires changes 

To download subtitles: 

1. Click Download in the Transcript panel 
2. Select Download as .VTT 

Zoom 

Zoom supports live captioning and automatic transcription. 
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Transcription can be provided by a live transcriber in the 
meeting, a third-party service, or Zoom’s automatic live 
transcription. If your Zoom meeting is recorded, you can 
upload the video file and add captioning just like you would to 
any other video. 
Teams 

Microsoft Teams meetings support automatic transcription 
with speaker attribution. 

1. Select the … More actions button 
2. Choose Start Transcription 

Consider this guide for information on live transcription in 
Teams. 
YouTube 

YouTube supports manual captioning, automatic captioning, 
and uploading a transcript or caption file. 

Add subtitles and captions to YouTube content. 
Manually add captions to YouTube content. 
Edit or remove captions from YouTube content. 
YouTube guide to automatic captioning. Note: YouTube auto 

captions are particularly inaccurate. 
Screenpal/Screencast-o-matic 

Deluxe/Premier accounts can automatically generate captions 
and all accounts can manually add captions. Read Screencast-
o-matic’s guide to accessible video. 
Camtasia 

Camtasia offers automatic captioning. Read this guide from 
Camtasia on the available captioning methods. 
Vimeo 

Vimeo has support for uploading caption and subtitle files. 
Enterprise members have access to automatic captioning. 
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Vimeo captions and subtitles overview 
Dailymotion 

Dailymotion offers support for adding .SRT subtitle files to 
videos. 
HTML 5 

To add closed captioning to an HTML5 video player <video>: 

1. Acquire or make a WebVTT caption file (.VTT). 
1. Use the auto captioning services available and edit to 

approach 99% accuracy. 
2. You can often download .VTT files from some media 

hosts. 
3. If not, use 3playmedia or happyscribe to convert the 

more common .SRT caption type to .VTT file. 
2. Upload .VTT file to same folder as video. 
3. Add a <track> element within your <video> tag. 

1. src – URL location of the .VTT file on server. 
2. label – title of the track as it displays in player (i.e. 

English). 
3. kind – captions, subtitles, descriptions are possible 

options. 
4. srclang – language of file. 
5. default – indicates which file is to be the default. 

Mozilla’s in-depth article on WebVTT is an excellent resource. 
3playmedia code examples on HTML5 video captions is a 

good starting point. 

Find Captioned Videos on 
YouTube 

An excellent way to ensure you are providing accessible videos 
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to learners is to choose sources that already have captions. On 
YouTube, you can filter search results to only display videos with 
captions. To do so: 

1. After entering your search term, select the Filters button. 
2. Select Subtitles/CC. 
3. Double check that results display Subtitles. 
4. Beware of videos with “English (auto-generated)” captions 

as auto-generated captions are less accurate with human-
edited captions. 

An interactive H5P element has been excluded 

from this version of the text. You can view it online 

here: 

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=7677#h5p-157 

Social Media 

Instagram supports captions on Stories and IGTV. 
Captions can be added to stories using a sticker. 
IGTV captions must be turned on in settings. 
TikTok offers support for automatic captioning. 
Twitter offers support for adding .SRT files to videos. 
Facebook supports adding captions to Facebook video. 
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Creating Caption Files 

Caption files can be created using a text editor (like Notepad 
for Windows or TextEdit on MacOS) to create or edit .SRT files 
(.SRT and .VTT are the most common file formats for subtitles). 

How to: 
Create .SRT File 

1. Open Notepad or TextEdit (macOS) 
2. Type “1” 
3. Press Enter to a new line 
4. Enter beginning and end timecode, using this format 

1. hours:minutes:second,milliseconds 
–> hours:minutes:second,milliseconds 

2. Example: 00:00:00,00 –> 00:00:05,443 
5. Press Enter 
6. Type your captions 

1. Limit to 2 lines of text per caption sequence 
7. Press Enter twice to leave a blank line, indicating a new 

caption sequence 
8. Type “2” 
9. Press Enter 

10. Entering beginning and end timecode 
11. Press Enter 
12. Type captions 
13. Repeat 
14. When complete, save your file using .SRT as the file 

extension. 

Create .VTT File 

1. Open Notepad or TextEdit (macOS) 
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2. Type “WEBVTT” 
3. Press Enter twice 
4. Enter beginning and end timecode, using this format 

1. hours:minutes:second.milliseconds 
–> hours:minutes:second.milliseconds 

2. Example: 00:00:00.000 –> 00:00:05.443 
5. Press Enter 
6. Type captions 

1. Limit to 2 lines of text per caption sequence 
7. Press Enter twice to leave a blank line, indicating a new 

caption sequence 
8. Repeat above 

1. You can number your caption sequences (by adding a 
number on the line above the timecode), but it is not 
required. 

9. When complete, save file with .VTT file extension 

Here is an example of the proper formatting of an .SRT file in 
TextEdit: 

Consider this guide for manually creating and editing .SRT files. 
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Use HappyScribe’s convert SRT to VTT tool or 3Play Media’s 
caption converter tool if you need a different file format. 

For instructions to upload caption files, consult the platform 
guides earlier in this chapter. 

Transcripts 

Transcripts are a text document containing all the audio 
content in media, including videos, podcasts, and audio 
recordings. Transcripts may also include additional information 
regarding visual elements and actions such as descriptions of 
what is on screen. Unlike captions, transcripts are not 
timestamped or synced with the media. A transcript is 
particularly useful to text to speech and screen reader users 
because many users set their software to read at a rate much 
faster than natural human speech. Transcripts can also be 
searched for words, names, and terminology. 

Use Kaltura to generate a transcript of audio or video: 

1. Upload media to Kaltura 
2. Edit machine-generated captions 
3. Navigate to media 
4. Select Attachments 

5. Choose the Download icon for the .txt file attached to the 
video
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6. The .txt file downloaded will be a text equivalent of the 
closed captions but without timestamps. 

OneDrive 

If you generate transcripts using OneDrive, follow the 
instructions earlier in this chapter to create captions. Then, 
download the generated .VTT and use Microsoft VTT Cleaner to 
remove timestamps and other code. 

Other Captioning and Transcription Tools 

Use Word to transcribe either by recording directly in Word or 
uploading an audio file. 

Transcribe audio to text using Dragon Naturally Speaking. 
Audapolis is an open source transcript editor that 

automatically transcribes audio to text. 
Mac OS supports dictation that could be used to develop a 

transcript. 
Google Docs allows dictation that could be used to write a 

transcript. 
Google Chrome now offers live captioning on any video. This 
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feature does not absolve content creators/providers from 
adding captions to video content, however, if encountering a 
video without captions on the wild web, this feature can be 
invaluable. This tool relies on the built-in captioning settings on 
your computer. To view or change these settings: 

• Use subtitles and closed captioning on Mac 
• Change Windows caption settings 
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Tools 

Use built-in tools and 
features to make your 
content accessible. Many 
platforms and software 
(Microsoft Office, 
Brightspace, WordPress, 
Pressbooks) include 
straightforward tools to 
make accessible content. 
Remember to: 

• Use built-in tools for tables, lists, links, and styles 
• Use templates 
• Use accessibility checkers 

By using tools, templates, and checkers and the best practices 
and tools introduced in this guide, you can create accessible 
content that includes everyone at the same time. 

The following chapters will focus on specific softwares and 
content management systems, expanding on the core 
principles of accessibility while providing platform specific 
instructions. 
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Ask: 

Is the content 
written with the 
audience in mind? 
Does the content 
work on multiple 
devices and without 
using a mouse? 

Best practices: 

1. Avoid PDFS. 
2. Use readability scores to 

gauge reading level. 
3. Use a read aloud tool like 

Word Read Aloud or 
TextAid to ensure content 
is read as intended. 

FAST Accessibility 
Check 

When creating or updating content consider these questions. 

Function 
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Ask: 

Is the font easy to 
read? 
If I printed this in 
black and white, 
would content retain 
meaning? 

Best Practices: 

1. Use sans-serif or basic serif 
fonts, of at least 11 point in 
documents, 16 point on 
webpages, and 18 in 
presentations. 

2. Ensure colour contrast 
ratio of at least 4.5:1. 

3. Information cannot be 
conveyed by colour alone. 

Ask: 

Appearance 

Structure 
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Were lists, headings, 
and columns 
created using built-
in tools? 
Are tables only used 
for data? 

Best practices: 

1. Ensure headings are both 
visual (larger, bolded font) 
and coded (Heading 1, 
Heading 2, etc.). 

2. Use numbered lists are 
used for steps in a process 
and bulleted lists for 
groupings of items. 

3. Tables must have a header 
row or column. 

4. Tables should not be used 
for layout. 

Ask: 

Text Equivalents 
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If someone cannot 
see or hear content, 
would they perceive 
all essential 
information? 

Best Practices 

1. Use descriptive link text, 
not bare URLs. 

2. Add alternative text and/or 
image captions. 

3. Include accurate closed 
captions on videos. 

4. Provide accurate 
transcripts of audio. 

Moving forward… 

Focus on creation and revision, not remediation. When 
you create new content or update existing material, 
focus on incorporating accessibility best practices. Do 
not worry about ‘fixing’ each one of your old 
documents. Aim to improve as you move forward. 
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BRIGHTSPACE 
ACCESSIBILITY 

Brightspace Accessibility  |  123
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Use templates 

Brightspace templates include 
accessible colour, structure, 
and interactive elements. 
Choose an appropriate 
template in the Select a 
Document Template menu. 

Brightspace 
Accessibility 
Quick Start 

Guide 

Use Brightspace features and tools to increase 
the accessibility of your content and work to 
ensure an inclusive and equitable experience for 
all learners. 

Best practices to maximize Brightspace accessibility: 
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Write descriptive 
linked text 

Use linked text not bare URLs. 
Write a description of the link 
destination, highlight the 
relevant text, and use 
the Insert Quicklink button to 
add a link. 

Use tools for 
structure 

Use built-in tools for 
headings, lists, and tables. 
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Include alternative 
text 

Add descriptions to the 
Alternative Text field of images 
that present information. 

Mark decorative images 
using This image is decorative. 

Caption and 
transcribe media 

Ensure videos have accurate 
closed captions and include 
transcripts of audio recordings. 

Run the Accessibility Checker 

Use the Accessibility Checker to flag accessibility issues. 
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Consider Accessibility Across Your Course 

To make your course as accessible as possible, ensure you: 

• Communicate clearly 
• Have deliberate, consistent organization 
• Choose the most appropriate file types 
• Ensure any uploaded documents are accessible 

For more information, read General Course Accessibility later in 
this book and consider the following video introduction: 

https://mediaspace.langara.ca/media/t/0_epcdfyfy 

Moving forward… 

Focus on creation and revision, not remediation. The 
next time you create a page or update an existing one, 
use the practices in this guide. Don’t focus on going 
back and fixing every page you have. Focus on making 
your new content more inclusive and accessible. 
Move to the next page for step-by-step guides to 
making accessible Brightspace content. 
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Templates, Font, and 
Colour 

On this page: 
Templates  Font  Colour Contrast 

Templates 

Create great-looking, responsive, and accessible content topic 
pages using the page layouts provided in the template 
package. The layouts are designed to be edited using the HTML 
Editor in the Learning Environment. 

To access the templates, Create a File and then click on 
Select a Document Template menu next to the title text box. 

Choose the appropriate nnn_x_v3 template. 
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Be consistent: use the introductory template for all 
introductory pages, the video page for videos, etc. 

Each Brightspace content page requires a title. Give each 
page a descriptive, unique title. 

Existing Content 

If you have existing content you would like to convert into a 
Brightspace webpage, you can copy and paste directly from a 
Word document. Select Remove formatting when prompted. 

If you encounter formatting errors when copy and pasted 
content into Brightspace, consider using HTML Cleaner to 
eleminate excess code while retaining look and layout. Copy 
and paste the HTML Cleaner results into the Source Code view 
in the Brightspace editor. 

Font 

Use the built-in editor tools to change font. All font options 
are available on the Brightspace editor toolbar.

Prefer sans-serif fonts. Use a minimum font size of 16 pixels. 
The Appearance chapter of this handbook has additional 

information on using accessible font. 
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 Colour Contrast 

Contrast must be at least 
4.5:1 for normal text (11-12 
point) and 3:1 for large text (18 
point +). Use the 
Accessibility Checker to 
verify. 

To select font colours: 

1. Highlight the text 
2. Select the Select Color

button in the toolbar 
3. In the Select a 

Color dialogue, use the 
sliders to change your 
colour until the contrast 
is at least 4.5:1 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=2704#oembed-1 

 
Remember the accessible colour best practices covered 

earlier in this handbook. Do not use colour alone to convey 
meaning or emphasis. 
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Structure 

On this page: 
Headings  Lists  Tables 

Headings 

Headings create structure to help users understand 
connections and topics. The Brightspace Editor offers tools to 
build proper heading hierarchies. Highlight text and choose 
the appropriate heading level. 

Consider Heading 1 as the title, Heading 2 as section headings, 
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Heading 3 as sub-section headings, etc. As the heading level 
increases, the focus of content narrows. 

Headings must be in sequential order. Do not skip a heading 
level when increasing, e.g., do not go from a heading 2 to a 
heading 4. Heading levels can be skipped when decreasing, for 
example when a subsection of a heading level 4 concludes, you 
can skip back to a heading level 2 to introduce a new section. 
Any type of content can follow any heading level. 

If the heading levels are not in order, the Accessibility 
Checker will report Heading order must be sequential. 

Lists 

• Use bullet lists for unorganized lists. 
• Lists where the sequence is not important. 

1. Use numbered lists for items where sequence is 
important. 

2. Such as steps in a process. 

Review list best practices. 
To make a properly formatted list in Brightspace: 

Do not manually insert symbols or use the Tab key to create 

1 Highlight text to add to list 

2 Open the List 
menu 

3 Select Bulleted List or 

Numbered List 
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indents. The Accessibility Checker may note improperly 
formatted lists 

Tables 

Properly formatted tables are accessible to text-to-speech and 
screen reader software. 

Use the built-in tool to create a table. 

Here are some common errors the Accessibility checker will 
flag in table formatting: 

1. Tables must have captions. 
How to fix: set a brief descriptive text to indicate the 
content of the table. The simplest way is via the 
Accessibility checker tool which will prompt for a caption. 
This will add <caption> to within the <table> element. 
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2. Tables must have at least one header. 
How to fix: the simplest way is via the Accessibility checker 
tool which will prompt you to choose table header to 
“Header Row” or “Header Column”, which will change the 
selected data cells <td> to header cells <th>. 

3. Table headers must be associated with cells. 
How to fix: Set header scope to “Row” or “Column” for 
simple table header, which will add scope attribute (<th 
scope=”row”> or <th scope=”col”) to associate header cells 
and data cells. 

The Brightspace accessibility checker will flag table errors and 
provides detailed instructions to make tables accessible. 
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Alternative Text, Closed 
Captions, Hyperlinks 
and External Content 

On this page: 
Alternative Text  Closed Captions  Hyperlinks  Uploaded 

Content 

Alternative Text 

Alternative text is a text description of visual information. 
To add an image, select the Image tool on the Brightspace 

Editor toolbar.

When adding an image, you will be prompted to add 
alternative text: 

Enter a concise 
description in the 
Alternative Text: field. Mark 
images that do not convey 
information may be marked 
as decorative by checking 
This image is decorative
and screen reader software 
will ignore the image. Note: 
this method limits alt text to 

200 characters. 
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If you have an existing image 
without alt text, right-click on 
the image and select Image: 

Enter alt text in Alternative 
description field and 
click Save: 

Use images and text to reinforce and support 
each other. Presenting information in multiple 
formats is an excellent way to present material. As 
well, if visual information is presented in text, the 
image can be marked as decorative. 
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Note: adding alt text using this 
method does not impose a 
character limit. 

The Accessibility Checker 
will display “Images must 
have alternative text” if alt 
text is not added. Alt text 
can also be added from 
inside the accessibility 
report panel. 

Consider why each image 
has been included. Some 
images may be a useful way 
to break up blocks of text 
and reinforce information. 
However, avoid adding 

numerous decorative images as this will unnecessarily clutter 
the content pages. 

Read more about alternative text. 

Image Titles 

Expand to learn about image titles 

By default, Brightspace will create an image title from the 
alternative text.

1
 The title appears in a tooltip box when the 

1. The authors do not believe this to be best practice and have asked 
Brightspace to address this unexpected behaviour. 
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mouse cursor hovers over an image in Brightspace: 

To modify the title of an image, and in turn the tooltip: 

1. Select the image and open the Other Insert Options 
menu on the Brightspace Editor toolbar. 

2. Select Attributes. 
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3. In the Attributes window, 
type a title in the Title field and click Create. 

Figure Captions 

Brightspace supports adding figure captions to images. The 
most straightforward method to add figure captions is to copy 
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from the Images template. For more, consult these 
instructions on using image templates in Brightspace. 

Closed Captions 

Embedded or linked videos must be close captioned. Audio 
recordings should have a transcript attached. Ensure media 
does not automatically play. Use Kaltura instead of 
Brightspace’s built-in video player for easier captioning, 
sharing, and versioning. 
Captioning uploaded video files (not recommended) 

For easier captioning, sharing, and versioning consider hosting 
video files on Kaltura Mediaspace. Should you require 
assistance captioning a video file, Kaltura Mediaspace is the 
preferred platform as caption editors will not be able to access 
video files inside Brightspace. 

However, to caption videos uploaded to Brightspace: 

1. Navigate to the video file and select Edit Video. 
2. Scroll down and select Advanced Editing. 
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3. Move to the Closed Captions tab and choose Auto-
Generate. 

4. Once captions are generated, edit for accuracy and select 
Finish. Wait for the changes to process and then close the 
dialog window by selecting the Close this dialog x in the 
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top right. Select Submit to finalize any changes . 

For more information, consult the closed captioning chapters 
earlier in this handbook. 

Descriptive Hyperlinks 

When linking to a website, use meaningful hyperlink text. 
Linked text should be descriptive, concise, unique and visually 
distinct. Do not use bare URLs. To learn more about writing link 
text, consult the accessible links chapter of this guide. 

Use default styling of blue font and underlined text for links. 
Consider the accessibility of the resource you are linking to. 

Also, indicate that you are linking to a video, file, or interactive 
element. 

Adding Hyperlinks in Brightspace 

1. Highlight your descriptive text. 
2. Select the link icon (looks like a small chain). 
3. Or, press Control (Command on macOS) and K. 
4. Paste the URL in the dialog that appears. 
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Additionally, you can insert a link via the format toolbar: 

1. Choose the Insert Quicklink button and select URL. 
2. Paste the URL in the appropriate field and add your 

descriptive text in the Title field. 
3. Select Insert. 

Before linking to external content, consider the accessibility 
of the resource. Try to choose the most accessible resource 
available. The University of Washington Disabilities, 
Opportunities, Internetworking, and Technology centre 
suggests avoiding PDFs and providing PDFs only as a 
secondary source of information. 

Uploaded Content 

Uploaded documents (Word, PowerPoint, etc.) must be 
checked for accessibility. 
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◦ @ (the at symbol) 
◦ & (ampersand) 
◦ / (slash) 
◦ © (copyright) 
◦ ® (registered) 
◦ ™ (trademark) 
◦ ¶ (paragraph) 
◦ • (bullet) 

◦ $ (dollar) 
◦ € (Euro) 
◦ £ (British pound) 
◦ ¥ (Yen) 
◦ % (percent) 
◦ ½ (one half) 
◦ ¼ (one fourth) 
◦ ¾ (three fourths) 
◦ ° (degrees) 

Formatting and Styles 
to Avoid 

The following formatting and object types are not 
communicated to assistive technology or present significant 
barriers to some users and should be avoided: 

• Strikethrough 
• Highlighting 
• Dropcap 
• Word Art, Smart Art, text effects 
• Ungrouped related shapes 
• Watermarks 

• Symbols, except for the following safe characters: 
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Accessibility Checker 

The accessibility checker may catch common accessibility 
issues in your content and offer suggestions to help you fix the 
issues. The accessibility checker is available on the HTML editor 
toolbar in Brightspace. 

To use the accessibility checker: 

1. Open your Brightspace page and select Edit HTML. 
1. Click the three dots More Actions button if you do not 

see a second row on the editor toolbar. 
2. Open the Accessibility Checker. 
3. Follow the checker prompts to make changes. 

1. There may be options or additional information 
depending on type of issue. 

Consider this video demonstration: 
https://mediaspace.langara.ca/media/t/0_6t32l7q7 
 

Accessibility Review 

Consider the following manual and automated checks to 
maximize the accessibility of your Brightspace content: 
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Accessibility Consideration Best Practices 

Prefer HTML, Word 
documents, and PowerPoint 
files. Use accessibility 
checkers in Brightspace, 
Word, and PowerPoint. 
Avoid PDFs as they are 
exceedingly difficult and 
time-consuming to make 
accessible. 

• Use Upload/Create > 
Create a File to create 
HTML pages. 

• Use Upload/Create > 
Upload Files to add 
Word and PowerPoint 
documents. 

Use font size 16 minimum 
and prefer sans-serif fonts. Use the provided templates. 

Use headings. 

Add headings using the 
Styles menu. Apply headings 
in sequential order without 
skipping a heading level. 

Use numbered lists for steps 
in a process and bulleted 
lists for groupings of items. 

Use the List menu in the 
Brightspace editor. 

Provide meaningful text 
descriptions of links 
destinations. Do not include 
bare URLs or unclear link 
text such as “click here” or 
“read more.” 

1. Type a description of the 
link destination 

2. Highlight the text 
3. Select Insert Quicklink

in the Brightspace editor 
4. Select URL and paste the 

URL in the URL* field 
5. Click Insert 

Ensure adequate colour 
contrast and do not use 
colour alone to differentiate 
or emphasize. 

• The Brightspace 
accessibility checker will 
flag inaccessible colour 
contrast. 

• Use colour and a symbol 
or text based cue to 
differentiate information. 
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Accessibility Consideration Best Practices 

Provide alternative text. 

• Add a description of the 
image when adding 
images to HTML pages. 

• Check This image is 
decorative for images 
that are not necessary to 
understand information 
or present the same 
information that is 
already available in text 
format. 

Tables are only used to 
represent data. 

• Do not use an invisible 
table for alignment or 
layout purposes. 

• Tables must have header 
rows and/or columns. 
Avoid blank, merged, 
and split cells. 

Math content must be 
accessible. 

Use EquatIO or the 
Brightspace Equation Editor 
to create accessible math 
and notation. 

Caption videos and 
transcribe audio. 

• Use MediaSpace to host 
video content. Edit 
automatically generated 
captions and use Insert 
Stuff > My Media to add 
video content. 

• Use Word’s transcription 
tools to provide a text 
equivalent of audio 
content. 

Any external learning tools 
and activities are accessible. 

Look for accessibility 
information on the platform 
or vendor’s webpage. 
Prepare an alternative 
activity or assessment in the 
event of an inaccessibility. 
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Checker Results 

The accessibility checker tool checks for a number of issues. 
Below is a summary of what is checked and how well the 
Brightspace checker does in flagging issues: 
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Element 
checked Effectiveness of check 

Colour 
contrast 

Strong 
Can recognize contrast errors (both for 
regular and large size text) and provides 
shortcut to improve contrast. 
Cannot determine if colour is used as sole 
indication of importance or emphasis. 

Accessible 
links 

Weak 
Does not check for bare URLS or descriptive 
link text. 
Notes adjacent links directed to the same 
URL with a shortcut to repair. 

Alternative 
text 

Moderate 
Marks images that do not have alt text nor 
are marked as decorative. 
Cannot identify whether the Alt text is 
appropriate or even meaningful. 

Accessible 
headings 

Strong 
Recognizes text that has been formatted to 
appear as a header but is not tagged as such 
(“This paragraph looks like a heading. If it is a 
heading, please select a heading level”). 
Flags headings out of sequential order 
(“Headings must be applied in sequential 
order. For example: Heading 1 should be 
followed by Heading 2, not Heading 3”). 

Accessible 
lists 

Strong 
The checker notes text that appears to be a 
list but is not properly coded as a list, such as 
a list created manually using symbols and 
suggests creating a semantic list. 

Accessible 
Tables 

Strong 
Notes lack of table caption. 
Asks for table summary on complex tables. 
Notes when tables to do not have header 
cell(s). 
Does not flag merged or split cells as these 
can be made accessible in HTML. 

Note that the Brightspace Accessibility Checker does not check 
for captioned media. 
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Read more about the Brightspace Accessibility Checker. 

Preview Tool 

Select the Preview tool on the second row of the editor toolbar 
to view how the page will appear to students. Use this as a 
last step to ensure that on top of being accessible, your page 
appears as you want. 
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General Course 
Accessibility 

The Accessibility Checker can identify common issues in 
Brightspace files, announcements, and descriptions. However, 
it is equally important to ensure uploaded files are accessible 
and that your online course is designed to be accessible and 
usable. 

Well-designed online course material: 
Communicates effectively  Is well-organized with 

deliberate structure  Uses appropriate file types 

Making intentional choices with your online course material 
enhances the learner experience by promoting efficiency, 
fostering independence, reducing anxiety and confusion, and 
improving communication. 

Consider the following best practices for accessible and user-
friendly online course design: 

Communication 

Make communications easy to find. Display communications 
prominently on the course home page, in module descriptions, 
and activity instructions. Ensure instructions come before an 
interaction, not after it. 

Include clear, concise instructions about activities to help 
learners ensure they have completed all necessary steps. Clear, 
direct language assists learners to complete activities with 
maximum independence. 

Use consistent language in instructions. For example, always 
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use the same date format and the same terms for the same 
basic actions, such as “move to the next page.” 

Clear communication, particularly instructions, help learners 
work through material and activities without having to 
repeatedly ask for clarification. Remember, your course may be 
only one of several a student is in. Unclear, vague, or otherwise 
confusing communications will only lead to additional 
overwhelm and less time for learning. Open SUNY Course 
Quality Review offers additional information about instructions. 

Descriptions 

Use topic and module descriptions to provide learners with 
instructions and overviews at the start of each module. 
Consider including: 

• What will be covered in that module. 
• How the material connects to prior learning and the 

overall course. 
• Any deliverables or activities due. 

Descriptions allow you to introduce material the same way you 
would explain a handout distributed in a physical classroom. 
Descriptions reduce confusion, helps reinforce expectations, 
and helps with time management. 

Click on Add a description…, add your content in the editor 
window and select Update to post. 
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Signposts 

Think of signposts as the ‘You are here’ indicators on a map. 
They help learners orient themselves in your course. 

Signposts can be: 

• Clear, descriptive labels for links, pages, and files. 
• Cues to guide learners where to click next. 
• Announcements and reminders about dates and 

deadlines. 

To add an Accouncement: 

1. Open the Communication menu and select 
Announcements.

2. Select New Announcement. 
3. Provide a brief, descriptive title in the Headline field and 

add your message and information in the content field. 
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The content field allows for rich text formatting including 
lists, images, links, and videos. 

4. When you are done crafting your message, run the 
Accessibility Checker and select Publish. Your message 
will now appear on the course homepage. 

For more information, consult Brightspace’s announcements 
documentation. 

Links and Multiple Ways 

Multiple ways to navigate provides learners the opportunity to 
move between material and activities seamlessly. Consider this 
example: 

‘Please review the EdTech contact information.’ Without a 
link to clarification about where to find the information, 
learners won’t be able to follow your instruction. As better 
practice, add links, such as: ‘please review the EdTech contact 
information.’ 

When you mention something like a resource, reading, 
activity, assessment, etc. in an announcement, description, or 
content page, provide a link to that content. That saves learners 
time searching for what you mentioned. Don’t turn your course 
into a scavenger hunt. 

To provide multiple ways: 
Create Activities at the Module level 

At the module level open the Upload / Create menu to create 
new Assignments, Discussions, Quizzes, and other activities. 

Activities created this way 
automatically place activities 

in the flow of learning. 
Add Existing Activities 

At the module level, use the Existing Activities menu to add 
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an existing Assignment, Discussion, Quiz, or other Brightspace 
activity. 

Adding activities to the 
flow of content means 

learners don’t have to search for them. 
Provide links in content 

Within an Announcement, Description, or Brightspace web 
page use the Insert Quicklink button to provide multiple ways. 

Internal links are excellent 
navigational waypoints to 

help learners find content and engage with relevant material. 
Use the Insert Quicklink tool to link to activities and content 
within a Brightspace course. 

Use Insert Quicklink to 
create links to: 

• Activities such as 
Assignments, 
Discussions, and 
Quizzes. 

• Content such as other 
Brightspace webpages 
and media 

• External content such as 
websites, library 
resources, and 
databases. 

Ensure the linked text is concise, unique, and descriptive. 

For external links: 

1. Paste the URL in the Link field. 
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2. Write a brief description in Text field. 
1. General practice suggests having links open in a New 

window for external links. 

Do not modify the default appearance of links. Only use 
underlined text for links. 
Include Reminders 

In addition to providing links, consider including reminders 
about how to find tools and activities in Brightspace. For 
example, for submitting an assignment remind learners to 
“open the Assessments menu and choose Assignments then 
select the appropriate assignment. Follow the instructions in 
the assignment to submit.” 

Naming Convention 

Use a consistent naming convention. All content such as links, 
files, activities, and pages should have easy-to-understand, self-
describing, unique, and meaningful names. Be consistent 
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when naming material, such as using the prefix “Topic n” for 
each module. 
Weekly 

Use a sequential structure to match the weeks of the 
semester. A weekly module structure creates a predictable 
rhythm students can count on and helps them match the 
course calendar to their personal calendars. 

However, don’t just label modules Week 1, Week 2, etc. Why? 
Well, if your class is on Tuesday, but the first day of the semester 
is a Wednesday, the first time your class meets is in Week 2. 
That’s going to get confusing. 

To create a strong weekly structure, consider the formula: 
Sequence + Title + Timeframe. 
For example, “1: Introduction to naming conventions 

(September 9-13)”, “2: Renaming Brightspace files (September 
16-20)”, etc. 
Topic 

If your Modules are not associated with a specific week of the 
semester, drop the date range from the above example. But, to 
ensure progress and flow are explicitly indicated, use: 

Sequence + Title 
For example, “1: Introduction to naming conventions”, “2: 

Renaming Brightspace files”, etc. 
Deliverables 

For courses build around major projects or assessments, create 
modules to group content related to each major artifact 
produced. Name Modules with: 

Type + Sequence + Due Date 
For example, “Project 1: Research Proposal (Sept 30)”, “Project 

2: Literature Review (Oct 15)”, “Project 3: Final Report (Dec 6).” 
Assessments 

Consistently naming assessments helps you stay organized 
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and reduces confusion by guiding students. Consider naming 
assessments with: 

Type of assessment (i.e. Quiz, Essay, Presentation, etc.) 
+ sequence i.e. 1, 2, 3m etc. (where applicable) 
+ informative name, title, or theme. 

For example, “Reflection 1: First Impression”, “Reflection 2: 
Careful Exploration”, etc. 

When learners can find information and activities easily, 
learners can spend more time learning the material, not 
finding it. Easy to find material means you will receive less 
questions about where things can be found. 
Content 

To effectively name content such as documents, web pages, 
links, and other media consider: 

Title, theme, or topic + (file format). 
For example: 

• “Accessibility Handbook for Teaching and Learning 
(Ebook)“ 

• “Course Outline: Basket Weaving Spring 2025 (PDF)” 
• “World’s blankiest blank 7 (Video, 3:43)” 

(You might consider adding a prefix of “Require reading” or 
“Suggested viewing.”) 

Naming content with informative titles informs students of 
what to expect, draws connections between material, and 
offers an invitation to open the content. 

Organization 

The organization of your content is essential to student 
success. Making deliberate efforts to improve the organization 
of your Brightspace content will help your learners: 
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1. Find what they need. 
2. Understand what they find. 
3. Use what they learn. 

Well-organized content allows learners to focus on the material 
you want them to learn, not spending excess time locating 
information or interpreting what they are supposed to do. 
Better organization is key to an accessible, inclusive, and useful 
online experience. 

Structure 

A Brightspace course is 
typically organized into 
modules. Modules are like 
folders. The modules may be 
organized by weeks or topics 
covered in the course. 

Submodules are 
subfolders of modules; each 
submodule is nested inside a 

module. Modules and submodules are populated with material 
such as Brightspace content pages, links to external resources, 
media, or documents. 

Avoid submodules as they 
interrupt the flow of content. 
Try viewing your course as a 
student and use the Next and Previous buttons to 
navigate through your course. Consider how 
submodules affect flow of information. Keep your 
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module structure as flat as possible by avoiding 
submodules. Where necessary, include clear 
instructions that additional material is located in a 
submodule. 

Use clear and consistent navigation, including navigational 
cues such as announcements and links, to guide students. 
Make it easy for learners to find and engage with the materials 
you want them to focus on. 

Consistency is essential to create an effective Brightspace 
course. Consistent layout and patterns: 

• Helps students develop efficient, predictable routines to 
find material and activities. 

• Reduces cognitive load through familiarity. 
• Builds trust in your course as reliable. 
• Allows learners to focus on learning the material, not 

constantly relearning the interface. 

For example, post all your readings in the same location, such 
as the relevant module, every week. 

Organize content in a logical sequence that scaffolds 
understanding. 

Chunk content using 

• Headings 
• Lists 
• Different pages or documents for different topics 

Reduce visual distractions such as decorative images, coloured 
backgrounds, and unnecessary graphics. While aesthetic 
design is important, excessive decoration will only distract 
learners from material. 
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File Types 

Brightspace can host material in a variety of formats. Consider 
the following best practices: 

Limit uploading documents that would function more 
efficiently as a web page. 

• Create web pages using the Upload / Create menu and 
select Create a File. 

• Word Documents and PowerPoint Presentations can be 
added to Brightspace via the Upload / Create menu and 
the Upload a File option. 

Avoid PDFs. 

• PDFs are not designed to be read on screen. 
• PDFs have significant accessibility and user experience 

concerns. 
• The University of Washington Disabilities, Opportunities, 

Internetworking, and Technology Centre suggests 
avoiding PDFs and providing PDFs only as a secondary 
source of information. 

Avoid uploading video and audio directly into modules. 

• Host content on Kaltura MediaSpace and embed media in 
Brightspace web pages. 

• Ensure videos have closed captions and audio files have 
text transcripts. 

No matter the content type, ensure files have unique, 
descriptive titles. 
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Expertise 

You don’t need to be an expert in accessibility or using 
Brightspace. When you have a question, ask. Search the 
web for resources and engage with your educational 
technology or teaching and learning centers. 
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Additional Resources 
D2L article on using the Brightspace Accessibility Checker. 

Meeting web content accessibility standards. 
Accessible courses and course material. 
UW DOIT Center tips for accessible courses. 
SUNY Online Course Quality Review Rubric. 
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Write descriptive 
linked text 

Insert descriptive links instead 

Word 
Accessibility 
Quick Start 

Guide 

Word tools and features were designed to create 
accessible documents by default. When used as 
intended, Word creates documents that are 
accessible with no additional steps, hacks, or 
workarounds required. 

Top tips for Word accessibility: 

Use tools for structure 

Use built-in tools for headings, lists, and tables. 
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of bare URLs. 

Choose readable fonts 

Use sans-serif or plain serifs, 
size 12 or larger. 

Provide alternative 
text 

Add descriptions to the Alt Text 
field of images that present 
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information. 

Check Mark as decorative for 
images that do not contain 
information. 

Write in plain 
language 

Use Word’s Editor Document 
Stats to measure language 

Use the Accessibility 
Assistant 

On the Review tab, select 
Check Accessibility to flag 
accessibility issues. 
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complexity. 

Moving forward… 

Focus on creation and revision, not remediation. The 
next time you create a document or update an existing 
one, use the practices in this guide. Don’t focus on 
going back and fixing every document you have. Focus 
on making your new documents better. 
Move to the next page to continue reading about 
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Word accessibility and learn how to make accessible 
Word documents. 
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Document Properties, 
Plain Language, and 
Fonts 

A few initial steps to Word accessibility include using plain 
language, choosing accessible fonts, and setting document 
properties. 

On this page: 
Accessible Font  Plain Language  Document Properties 

Accessible Font 

Choose readable fonts to aid people with low vision, dyslexia, 
and other processing disorders to read content. 

Best practices for fonts: 

• Use sans-serif fonts like Aptos, Arial, Calibri, Helvetica, or 
Montserrat. 

• Use simple serif fonts, such as Cambria, Sitka, and Times 
New Roman. 
◦ Avoid exaggerated serifs, scripts, and novelty fonts. 

• Use size 12 or greater 
◦ Size 9 is acceptable for foot/endnotes or figure 
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captions. 
• Left-align text for languages that read left to right. 
• Use at least 1.5 line spacing. 

The Appearance chapter of this handbook has additional 
information on using accessible font. 

Font Colour 

For readers that have colour vision deficiency or low vision, 
ensure text has sufficient contrast. Good contrast makes text 
easier to read for everyone. Font must have a contrast ratio of at 
least 4.5:1 against the background. For example, black text on a 
white background has a contrast ratio of 21:1. Langara Orange 
(#F15A22) has a contrast ratio of 3.37:1, well below the accepted 
minimum. 

To set font colour: 

1. Navigate to the Home tab. 
2. Select Font Colour. 
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1. Select an appropriate colour or click Automatic. 
2. Toggle on High-contrast only to only display colours 

with sufficient contrast. 
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Visit the accessible colour chapter of this Pressbook for more 
information. 

Text Alignment 

To set text alignment: 

• Set alignment in the Paragraph tools on the Home tab. 
• Avoid justified alignment as it can create excessive blocks 

of white space when zoomed and can create ‘rivers of 
white space’ which are gaps that appear to run through a 
paragraph due to coincidental alignment of spaces. 

Text Spacing 

To set spacing: 

• Do not use Tab, Enter, or Space to change spacing 
between paragraphs or layout of bullet points: 
◦ Navigate to Home > Line and Paragraph 

Spacing > Line Spacing Options 
▪ The Paragraph dialogue has spacing options on 

the Indents and Spacing tab 
• Use Insert > Page Break to create page breaks 

◦ Do not create manual spacing using Return or 
Space keys 

• Do not use Tab, Space, or text boxes to create columns 
◦ Go to Layout tab > Columns. Additional options are 

available by selecting More Columns… 

Using Visual Style to Convey Meaning 

Do not use visual style alone to convey information. Visual style 
could include: 
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Word Readability Statistics 
window 

• Italics 
• Bold 
• Underline 
• Spatial positioning or text spacing 
• Colours 

Please use visual styling but include at least a second indicator, 
such as written instructions. Review the use of colour 
recommendations discussed earlier in this book. 

Plain Language 

Use the Editor tool to check 
reading level. Navigate 
to Home > Editor and 
select Document Stats. Aim 
for a Flesch-Kincaid Grade 
Level of 7-9 for general 
content. Learn more about 
plain language. 

Document Properties 

The document title is announced to assistive technology and 
is more informative (and pleasant to hear) than the file name. 
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Adding a plain language title to the metadata allows continued 
adherence file naming conventions. Ensure the language code 
matches the language of the presentation. Other fields are 
useful but not required. 

Document Title 

Setting a title in a document’s metadata means screen reader 
software will read that title in place of a potentially unclear file 
name. If you use a file naming convention, some filenames 
could be quite cumbersome and unpleasant when read aloud. 
Best practice is to use the document’s heading as a title. 

To add a document title: 

1. Navigate to File > info. 
1. On MacOS: File > Properties > Summary tab. 

2. Enter a descriptive title in the Title field. 

This cannot be done in Office Online. 

Document Language 

To set document language to match content: 

1. Click language on Status Bar at bottom of document 
screen or via Tools > Language 

2. You can set a different language for different parts of your 
document: 

1. Select desired text. 
2. Via Review tab, select Language. 
3. Select appropriate language. 
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Structure 

Content that relies solely on visual styling to communicate 
purpose or function may exclude users of assistive technology. 
Assistive technology such as screen readers and text-to-speech 
tools require specific markup to convey meaning. For example, 
a proper heading should include larger, bolded font to stand 
out to sighted readers, but must be properly created to provide 
the equivalent meaning to all readers. Ensure headings, lists, 
and tables are created using the proper tools. 

On this page: 
Headings  Tables  Columns  Text boxes  Lists 

Headings 

Structured documents are essential for assistive technology, 
but helps all readers navigate documents efficiently and 
understand relationships between topics. Brief but descriptive 
headings help all users navigate quickly to information they 
need, understand the purpose of various sections, and break 
up large blocks of text to increase readability. 

Use the Word Styles gallery to set headings. 

Press Control Alt (Command Option on macOS) 1, 2, or 3 to set 
heading 1, 2, or 3. 

Begin with a heading 1 as the broadest, most important level, 
such as a title. Heading level 2 should be for major sections and 
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Verify heading structure via 
View > Navigation. 

Click and drag headings to 
move heading and all text 
under that heading in the 

heading level 3 as subsections of the preceding heading 2 and 
so on. 

Headings must be in sequential order. Do not skip a heading 
level when increasing, e.g., do not go from a heading 2 to a 
heading 4. Heading levels can be skipped when decreasing, for 
example when a subsection of a heading level 4 concludes, you 
can skip back to a heading level 2 to introduce a new section. 
Any type of content can follow any heading level. 

*Note, in Word the Title style should not be used as it only 
visual styling and does not convey meaning to assistive 
technology. Use a heading 1 for your title. 
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document. 

To modify the appearance of 
headings, right-click on a style 
and click Modify Style. 

Modify the formatting of the 
style. Select New documents 
based on this template to set 
the new style for all new 
documents. Learn more about 
customizing or creating new 
styles in Word. 

Word allows for multiple 
visual styles for the same 
heading level. 
Multiple Heading Styles 

Use the same visual style for 
all headings of the same 
level. For example, all 
heading level 2s should 
have the same distinct style 
and all heading level 3s 
should have a distinct style 
and so on. However, there 
may be unique 
circumstances where a 
document will need 
multiple styles for the same 
heading level. For example, 
a sidebar with a coloured 
background may require a 
heading level 3 to have a 
different font colour than a 
heading level 3 that 
appears in the main body of 

a document. In Word, it is possible to create multiple headings 
of the same level with distinct visual styling. 

To create multiple visual heading styles: 

1. Open the Styles gallery and click on Create a Style. 
2. Name the new style. 
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3. Click Modify… 

4. In the Create New Style from Formatting window 
open Style based on: and choose existing equivalent 
heading level.
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5. Modify the style by setting font, size, and colour. 
6. Click Ok. 

Do not drastically change the style as visual readers benefit 
from similar visual styles to understand hierarchy and 
document structure. 

Learn more about customizing or creating new styles in 
Word. 

Table of Contents 

If your document is more than 8 pages, include a table of 
contents to provide an overview and assist users to skip to 
specific parts of a document. 

Navigate to the References tab and select Table of Contents.
Word will use the document’s heading structure to 
automatically generate a table of contents. Each section in the 
table of contents links to the relevant part of the document. 

Tables 

Tables are useful for organizing data (data can be numbers or 
text). A table Properly built and formatted tables are accessible. 

To insert a table in Word: 

1. Move to the Insert tab. 
2. In the Table group, choose Insert Table. 
3. Indicate number of columns and rows and press Ok. 

1. You can add columns and rows later. 

Set a header row/column: 
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1. Click anywhere in your table. 
2. Select Table > Table Design tab > click Header Row (and/

or First Column, if column is a header) checkbox. 
3. Select Banded Rows or Banded Columns for a landscape 

document. 
4. Select the header row then navigate to Table Layout, 

select Repeat Header Rows to repeat headers across page 
breaks. 

5. Accessible tables in Word can only have one header 
row, one header column, or both. 

Right-click on table and select Table Properties for advanced 
table options via the table properties dialogue. 

In some instances it may make sense to add alt text to a table 
as a summary. To do so: 

1. Navigate to Table Properties 
2. Select the Alt Text tab 
3. Add a Title and a Description 
4. Click Ok 

Table Best Practices 

• Tables must have a header and/or column row. 
• A concise, descriptive table title helps with context and 

organization 
• Do not use nested, merged, split, or unnecessary blank 

cells 
• Ensure cells have adequate padding and margins 
• Do not use coloured cells or text alone to indicate 

meaning 
• Do not use tables with invisible borders to format layout 
• Office accessibility checker does not note table errors 

◦ Click in the top left cell, then use the Tab key to see 
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ensure your table reading order is logical and 
consistent 

Learn more about creating accessible tables in Word. 

Tables are for data, not structure 

A table is a systematic arrangement of numbers, words, 
other data organized into sets of rows and columns. 
Tables are used to show relationships between data. 
Tables should never be used to create a desired layout, 
such as using an invisible table to create columns. 
Word has a built-in tool to create columns. 

Columns 

Use the Columns tool to create column layouts in 
Word. Type content in Word and navigate to Layout 
and select Columns. 

Choose the desired 
number of columns. It is 
recommended to create 
and format content 
before applying column 
layouts to avoid excess 
work and potential 
issues. Word will 
automatically apply 

columns breaks, but it is possible to manually insert 
column breaks. 
To learn more about columns in Word, read columns 
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dialog box and adjusting column widths on the 
Microsoft Support website. 
Do not use invisible (without cell borders) tables to 
create columns. These will be read as tables to assistive 
technology and confuse users. 

Text boxes 

Do not use single cell 
tables to create a text 
box; tables are for data, 
not layout. To create an 
accessible text box, use 
border tools. Select the 
text and on the Home 
tab, select Borders and 
choose Outside 
Borders. Choose Borders 
and Shading to 
customize the 
appearance of the text 
box, including shading, 
shadows, colours, and 
line style. 
Word’s Insert > Text box 
can be used to create 

textboxes provided it is anchored to a paragraph. This 
means that wherever the anchor is placed the text box 
will be read before that paragraph. Word for Windows 
has predefined text box styles, but text boxes can be 
customized in appearance and location. Ensure you 
select Fix Position on Page in the Shape Format > 
Wrap Text menu. 
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To place the anchor: 

1. Click and drag the anchor icon and place it 
beside the paragraph the text box is to be read 
before.

2. Place the anchor as the absolute last step in the 
process to ensure proper reading order. 

3. Verify reading order by navigating to 
the Review tab and opening Immersive 
Reader. In this view, verify the textbox appears in 
the desired sequence. 

Lists 

Use the list tools to create lists. Creating lists using asterisks or 
dashes will not inform assistive technology that the content is 
part of a list. Lists are useful for steps in a process or grouping 
items. It is important that everyone is made aware of the 
presence of a list. 

• Use bullet lists for unorganized lists 
• Lists where the sequence is not important 

1. Use numbered lists for items where sequence is important 
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2. Such as steps in a process 

To create a list in Word: 

1. On the Home tab. 
2. Select Bullets, Numbering, or Multilevel List. 

The dropdowns accompanying each style offer more list 
options and customization. 

3. To verify a list has been properly created: Press Enter after 
a list item and a new bullet or number should 
automatically appear on the next line. 

Additional Structure 

To ensure accessible structure avoid repeated tabs, 
spaces, or returns. Instead: 

• Change spacing before and after paragraphs 
via Home > Line Spacing Options. 

• Manually create a line break by 
pressing Shift and Enter. 

• Of repeatedly pressing Enter, use Insert > Page 
Break. 

• Of repeatedly pressing Tab or Spacebar, navigate 
to Home > Increase/Decrease Indent or use the 
indent markers on the horizontal ruler (View > 
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Ruler). 
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Right-click on the image select 
Insert Caption… 

Alt text, Images, and 
Links 

Include text alternatives for visual elements such as images 
and use hyperlinks in place of bare URLs. 

On this page: 
Text Equivalents  Captions and Transcripts  Hyperlink Text 

Text Equivalents 

As discussed in the alternative text chapter of this guide, visual 
information needs a text equivalent. In Word, the text 
equivalent of visual information can be included in: 

• Text adjacent to an image. Presenting text with visuals 
that reinforce and support one another is a great practice 
and ensures everyone can access the information. 

• Figure captions. 
• The alt text field of a graphic. 

Figure caption 

If equivalent information is not presented in text adjacent to a 
graphic, add a figure caption. Figure captions are accessible to 
all readers of a document. 

To add a figure caption to an image: 
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Type a caption and set options. 
Click Ok. 
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The figure caption will 
appear below the image. In 
the Alt Text pane for the 
image, check Mark as 
Decorative. Read more 
about how to insert a caption 
for a picture from Microsoft 
support. 

Alt Text 

In instances where a figure caption is not preferred, use the alt 
text field to add a description of the information present in a 
graphic. The alt text field is only read by screen reader software 
to provide visual information in accessible format. 

To add alt text in Office 
programs: 

1. Right click on an image 
and select View Alt 
Text… 

2. Enter a description in 
the dialogue box. 

3. If a graphic is purely 
decorative, check Mark 
as Decorative. 
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To add alt text in Office online programs: 

1. Select the image 
2. Navigate to the Picture tab 
3. Select Alt Text and enter your description in the 

Description field. 
4. If the image is purely decorative, leave the Description

field blank. 

The Office Accessibility Checker will flag images that do not 
have alternative text. In the Accessibility pane, Missing object 
description will appear as an error. Do not rely on the 
automatically generated alt text, it is rarely useful. 

Add alternative text to simple charts but also include table 
data for complex charts and data sets. Best practice is to 
include table data adjacent to the chart, but linking to the data 
elsewhere in the document is also an effective method. The alt 
text field does not support links, but a link can be added to a 
figure caption. Ensure the link text explains the destination. 

Grouped Shapes 

A group of shapes, such as the stars in the demonstration 
below, must be grouped to provide meaningful alt text. To 
group images in Word: 

1. Select the first object. 
2. Hold Control (Command on macOS) and click on the 

remaining objects. 
3. On the Shape Format tab select Group > Group. 
4. Add Alt Text to the grouped shape. 
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Animation 
demonstrat
ing how to 
group 
shapes in 
Word 

Read more about how to group or ungroup shapes, pictures, or 
other objects. 

Review this Pressbooks’ alternative text chapter and read 
Microsoft guides for adding alt text to images, SmartArt, 
shapes, and charts and how to make Word documents 
accessible. 

Graphs and Charts 

Do not include photos of charts or graphs, insert them properly 
via Insert tab > Chart dropdown. 

A concise and meaningful title or caption helps all readers. 
Add alt text to graphs and charts but also include table data for 
complex charts and data sets. Best practice is to include table 
data adjacent to the chart, but linking to the data elsewhere in 
the document is also an effective method. Ensure the link text 
explains the destination. 

Do not rely on colour alone to distinguish data. Use symbols 
or different line styles. Include a legend. 

Apply data and axis labels by selecting your graph or chart 
and navigating to Chart Design tab and selecting Add Chart 
Element dropdown. 
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Provide alternative formats, such as a table of data plotted via 
chart 

• For a chart or graph, provide data in table form beside the 
element. If size and spacing is a concern, place the data in 
another sheet and provide a link near the floating 
element. 

Visuals must use In line with text wrapping style to 
be accessible. Click on your image and 
choose Picture tab or the Layout Options button 
and choose In line with text. Microsoft offers 
detailed instructions on text wrapping. 

Videos and Audio Recordings 

Ensure embedded media has text equivalents. Videos must 
have closed captions and audio must have a transcript. 

Hyperlinks 

When linking to a website, document or other part of a 
document, use meaningful hyperlink text. Linked text should 
be descriptive, concise, unique and visually distinct. Do not use 
bare URLs. To learn more about writing link text, consult the 
accessible links chapter of this guide. 

Use Word’s default styling of blue, underlined text for links. 

194  |  Alt text, Images, and Links

https://support.microsoft.com/en-us/office/wrap-text-around-a-picture-in-word-bdbbe1fe-c089-4b5c-b85c-43997da64a12#ID0EAAAABAAA=Windows
https://support.microsoft.com/en-us/office/wrap-text-around-a-picture-in-word-bdbbe1fe-c089-4b5c-b85c-43997da64a12#ID0EAAAABAAA=Windows
https://support.microsoft.com/en-us/office/video-create-accessible-links-in-word-28305cc8-3be2-417c-a313-dc22082d1ee0


To add a link in Word: 

1. Select the text you want to link 
2. Right-click and select Hyperlink or press Control

(Command on macOS) and k 
3. Verify the Text to Display text 
4. Paste the destination URL in the Address box 

You may have existing documents that contain bare URLs. To 
update existing, bare URLS to accessible links: 

1. Right-click on the bare URL 
2. Select Edit Hyperlink… 
3. In the Text to display field, type a brief description of link 

destination. 
4. Click Ok. 

Read more about hyperlink text in Word. 
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◦ @ (the at symbol) 
◦ & (ampersand) 
◦ / (slash) 
◦ © (copyright) 
◦ ® (registered) 
◦ ™ (trademark) 
◦ ¶ (paragraph) 
◦ • (bullet) 

◦ $ (dollar) 
◦ € (Euro) 
◦ £ (British pound) 
◦ ¥ (Yen) 
◦ % (percent) 
◦ ½ (one half) 
◦ ¼ (one fourth) 
◦ ¾ (three fourths) 
◦ ° (degrees) 

Formatting and Styles 
to Avoid 

The following formatting and object types are not 
communicated to assistive technology or present significant 
barriers to some users and should be avoided: 

• Strikethrough 
• Highlighting 
• Dropcap 
• Word Art, Smart Art, text effects 
• Ungrouped related shapes 
• Watermarks 

• Symbols, except for the following safe characters: 
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Accessibility Assistant 

Use Word’s Accessibility Assistant, a built-in accessibility 
checker to check for common issues. Note, these tools may not 
catch all possible accessibility issues. 

Navigate to the Review tab and click Check Accessibility. 

1. Select Review tab 
2. Choose Check Accessibility button 
3.  The Accessibility Assistant panel will open and show 

issues 
1. Select each issue to see it highlighted in the 

document 
2. Select the arrow next to each warning to see further 

information 

To see real time accessibility status: 

1. At the bottom of the Accessibility Assistant panel select 
the Settings button. 

2. In the Settings window, check the Show accessibility 
status for the Accessibility Assistant in the Status 
Bar checkbox. 

3. Click Accessibility: Investigate in the status bar at the 
bottom of the window to open the Accessibility Assistant 
pane. Accessibility: Good to go indicates no violations of 
the automated checker’s rules. 
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One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=2491#oembed-1 

In the Accessibility settings 
window, check Show 
accessibility status inline 
with the document to 
toggle on a real-time, inline 
accessibility checker. When 
content is added to Word 
that violates accessibility checker rules, a small human form 
icon will appear on the line of the offending content. 

Checker Results 

Like any automated tool, Word’s Accessibility Assistant will not 
catch all accessibility issues. Here is a summary of what it does 
look for and how well it catches those issues: 
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Element checked Effectiveness of check 

Hard-to-read text 
contrast 

Strong 
Evaluates the contrast ratio 
between font and background 
and offers suggestions to ensure 
sufficient contrast. 

Missing alt text 

Moderate 
Flags images that do not have alt 
text or where the alt text is the 
image file name. 
Cannot identify if alt text is 
appropriate or meaningful. 
The built-in image description 
generator is poor and should not 
be used. 

Image or object not 
inline 

Strong 
Flags images that are not inline. 
Offers shortcut to place object in 
line or mark image as decorative. 

No headings in 
document 

Weak 
Flags documents over 10 pages 
that have no headings, however 
almost all documents regardless 
of length benefit from headings. 
Tool does not consider proper 
heading hierarchy. 

Missing table header 

Strong 
Flags tables that do not have 
properly marked up table header 
cells. 

Use of merged or split 
cells 

Strong 
Flags tables that include merged 
or split cells. 
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Additional elements not 
automatically checked: 

The Word Accessibility Assistant does not assess links, font size 
and style, proper use of lists, or if media has captions or 
transcripts. 

Read more about checking for accessibility issues with the 
Office Accessibility Checker and learn about Office Accessibility 
Checker rules and messages. 
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Sharing and Exporting 

On this page: 
Sharing  Export to PDF 

Best practice is to share material in advance of a presentation, 
meeting, or class. 

• Sharing allows users to check for barriers beforehand and 
customize their experience. 

• All users can take additional, in-depth notes and 
understand terminology and names with greater 
comprehension. 

Sharing 

Upload your document to Brightspace, share via OneDrive, or 
email a copy. Avoid exporting your Word document to PDF as 
there is additional and precise work required to make a PDF 
accessible. 

Sharing a Word document allows users to customize the 
appearance (font size, background colour) and easily have the 
document read aloud to them without changing the content 
of the document. 

There are a number of options for sharing a Word document: 

Share for collaboration via OneDrive/SharePoint. 

Learn how to share a Word document. 
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Share a copy via Brightspace. 

Upload a document to 
Brightspace Content via Upload/
Create > Upload Files. 

Content from a Word document can be copied and pasted into 
a Brightspace HTML page. To create a Brightspace HTML page: 

1. Select Upload / Create. 
2. Choose Create a File. 
3. Provide a brief, descriptive title. 
4. If using templates, open Select a Document Template 

and choose 000_Blank_v3. 
5. Copy your entire Word document (Control or Command 

on macOS and c). 
6. Paste content in Brightspace editor and choose Remove 

formatting. 
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If you are not using Template styles, or want to mimic the 
styles of your Word document, choose Keep formatting. 
Note that some fonts and styles may not copy over exactly 
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and may require manual adjustments. 
7. Verify your content and select Save and Close. 

Share with Always Open Read-Only enabled. 

Select File > Info > Protect 
Document and 
choose Always Open Read-
Only. 

Selecting Always Open Read-Only will prompt users to opt-in 
to editing the document: 

Learn more about making a document read only. 

Mark as Final 

A document can be marked as final to inform readers the 
document is in a complete form and is not to be edited. 

1. Select File  and choose Info. 
2. Open the Protect Document menu and select Mark as 

Final. 
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3. Documents will indicate to users the document has been 
MARKED AS FINAL

Read Only 

To completely lock a document, use Restrict Editing. 

Note, this method will prohibit screen reader users 
from being able to read your document. 

1. Go to the Review tab. 
2. In the Protect group, choose Restrict Editing. 
3. The Restrict Editing pane will open. 

1. Select the Allow only this type of editing in the 
document: 

2. Choose No Changes (Read only) from the menu. 
1. You may also allow comments, tracked changes, 

or filling form fields 
3. Set any exceptions for specific users 
4. Click Yes, Start Enforcing Protection 
5. You will be prompted for a password or User 

authentication. 
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To make changes or turn off editing restrictions: 

1. Navigate to the Review tab. 
2. Select Restrict Editing. 
3. In the Restrict Editing pane, click Stop Protection. 
4. Enter password if prompted. 

Learn more about protected documents and watch the 
following video demonstration: 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=2493#oembed-1 

Export to PDF 

The best way to use PDFs is sparingly. 

The knowledge and time needed to make accessible PDFS 
rarely justifies the use of PDFs. PDFs require significant coding 
to make accessible, do not reflow content to fit different size 
monitors, and should be used only when necessary. 

Do not use File > Print > Save as PDF as that method does 
not retain any document structure and requires significant 
time and expertise to make an accessible file. 
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If you absolutely must create a PDF and have Acrobat 
installed: 

1. Open File > Save as Adobe PDF 
2. In the save dialogue, select Options and ensure the 

following are checked: 
1. Enable Accessibility and Reflow with tagged Adobe 

PDF 
2. Create Bookmarks 
3. Convert Word Headings to Bookmarks 

3. Click Ok and then Save. 

Without Acrobat installed: 

1. Open File > Save as or Export. 
2. Enter file name and select save location. 

1. (Windows) Select PDF in Save as type list. 
1. Choose Options and select Document structure 

tags for accessibility check box. 
2. Select Ok. 

2. (MacOS) Select PDF from File format drop down. 
1. Select Best for electronic distribution and 

accessibility (uses Microsoft online service) radio 
button. 

2. Select Save. 

For more information about PDFs, read The People v. PDF. 
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Additional Resources 
Use this Word Accessibility Checklist (PDF, 206 KB) to check 
your documents. 

Microsoft outlines best practices to make documents 
accessible. 

WebAIM guide to creating accessible documents in Word. 
Contact assistivetech@langara.ca for further information or 

assistance. 
Better practice is to build your documents with accessibility 

in mind. Incorporating the methods in this chapter will ensure 
your documents are more accessible to everyone with no extra 
work for you. 

208  |  Additional Resources

https://pressbooks.bccampus.ca/accessibilityhandbook/wp-content/uploads/sites/1155/2023/01/Word-AccessibilityChecklist_Handout.pdf
https://support.microsoft.com/en-us/office/make-your-word-documents-accessible-to-people-with-disabilities-d9bf3683-87ac-47ea-b91a-78dcacb3c66d#PickTab=Mac
https://support.microsoft.com/en-us/office/make-your-word-documents-accessible-to-people-with-disabilities-d9bf3683-87ac-47ea-b91a-78dcacb3c66d#PickTab=Mac
https://webaim.org/techniques/word/
mailto:assistivetech@langara.ca


POWERPOINT 
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Verify reading order. 

Ensure slides have titles. 

PowerPoint 
Accessibility 
Quick Start 

Guide 

PowerPoint tools and features were designed to 
create accessible presentations by default. When 
used as intended, PowerPoint creates 
presentations that are accessible with no 
additional steps, hacks, or workarounds required. 

Top tips for PowerPoint accessibility: 

Use structure and layouts 
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Use layouts with content 
placeholders. 

Choose accessible 
fonts 

• Use simple serifs or sans-
serifs in size 18 or larger. 

• Use black text on a light 
backgrounds (or vice-
versa). 
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Write descriptive 
linked text 

Create descriptive links 
instead of bare URLs. 

Provide alternative 
text 

Add descriptions to the Alt Text 
field of images that present 
information.

Check Accessibility 

On the Review tab select 
Check Accessibility to flag and 
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fix accessibility issues. PowerPoints ≠ PDFs 

Share your PowerPoint via 
Brightspace, OneDrive, or 
email. Exporting to PDF will 
undo much of the work 

done to make the presentation accessible. Additionally, PDFs 
are not designed to reflow to fit user screen dimensions, are no 
more secure than other document types, and present 
significant challenges regarding currency and versioning. 

Moving forward… 

Focus on creation and revision, not remediation. The 
next time you create a presentation or update an 
existing one, use the practices in this guide. Don’t focus 
on going back and fixing every presentation you have. 
Focus on making your new presentations better. 
Move to the next page to continue reading about 
PowerPoint accessibility and learn how to make 
accessible presentations. 
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Document Properties 
and Accessible Fonts 

This chapter will introduce some first steps to making 
PowerPoint presentations accessible. 

On this page: 
Accessible Font  Document Properties 

Accessible Font 

Choose accessible font 

• Use font size 18 minimum 
• Prefer sans-serif fonts. Do not sure decorative fonts. 
• Left-align text 
• Use built-in tools for spacing and alignment 

The Appearance chapter of this handbook has additional 
information on using accessible font. 

Consider this dyslexia “simulation.” More accessible font 
choices, particularly font and spacing, have a huge impact for 
readers with dyslexia. 
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Font Colour 

• Use accessible colours. 
◦ Font must have a contrast ratio of at least 4.5:1 against 

the background. 

To set font colour: 

1. Navigate to the Home tab. 
2. Select Font Colour. 
3. Choose a colour that contrasts well against the 

background, such as black text on a light background or 
white text on a black background. 

Do not use colour alone to convey meaning or importance. 

1. Select View > Greyscale to see if your information relies on 
colour alone. 

2. Select Back to colour view to return to original colour 
scheme view. 

Visit the accessible colour chapter of this Pressbook for more 
information. 
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Text Alignment 

To set text alignment: 

• Set alignment in the Paragraph tools on the Home tab. 
• Avoid justified alignment as it can create excessive blocks 

of white space when zoomed and can create ‘rivers of 
white space’ which are gaps that appear to run through a 
paragraph due to coincidental alignment of spaces. 

Document Properties 

The document title is announced to assistive technology and 
is more informative (and pleasant to hear) than the file name. 
Adding a plain language title to the metadata allows continued 
adherence file naming conventions. Ensure the language code 
matches the language of the document. Other fields are useful 
but not required. 

Document Title 

To add a document title: 

1. Navigate to File > info. 
1. On MacOS: File > Properties > Summary tab. 

2. Enter a descriptive title in the Title field. 

This cannot be done in Office Online. 

Document Language 

To set document language to match content: 
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1. Click language on Status Bar at bottom of document 
screen or via Tools > Language 

2. You can set a different language for different parts of your 
document: 

1. Select desired text. 
2. Via Review tab, select Language. 
3. Select appropriate language. 
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Structure of Slides 

On this page: 
Slide Layouts  Tables  Lists 

Slide Layouts 

Providing structure to documents is essential for assistive 
technology, but help all readers navigate your documents 
efficiently and understand relationships between topics. 

Slide Titles 

Ensure slides have a title placeholder (most default layouts do). 
Slides must have a “Click to add title” placeholder to create a 
properly coded title. Manually adding a text box and increasing 
the font size does not make a proper title. If you find many 
of your slides do not have title placeholders, review the slide 
masters and add title placeholders. 
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Ensure each slide has a descriptive, unique title. Effective 
titles help orient all users and provides structure to draw 
connections and enhance understanding. Titles allow all users 
to efficiently navigate your presentation. 

For slides that contain media, such as a full-size image, chart, 
or other graphic or video, consider “hiding” the slide title. 

To hide a slide title: 

1. Move to the Accessibility tab. 
2. Open the Slide Title menu and choose Add Hidden Slide 

Title. 
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3. Or click and drag an existing slide title out of the frame of 
the slide. 

How to title a slide from Microsoft support. 
If the information of a slide continues to a second slide, best 

practice is to name your slides “Example Title 1 of 2” and 
“Example Title 2 of 2.” 

Slide Structure 

Using textboxes as titles does not provide structure. Textboxes 
are read in the order they are added. 

To change slide layout: 

1. Select Home 
2. Click Layout 
3. Select appropriate layout and fill placeholders as needed. 
4. Layouts provide semantic structure and are pre-formatted 

with proper reading order. 

One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2533#oembed-1 

Reading Order 

The reading order of slides is essential for screen reader and 

Structure of Slides  |  221

https://support.microsoft.com/en-us/office/title-a-slide-c5286802-495a-4b47-a8ae-212fb8a7dc74


text to speech users. Ensure reading order matches visual 
order. 

Check the reading order of each slide to ensure it will be read 
logically by assistive technology. 

On Windows: 

1. Select Review tab > Check Accessibility button > Reading 
Order Pane 

2. Drag and drop elements to their proper reading order 
1. Rearranging items does not change their position on 

the slide 
3. Click through list to ensure reading order matches visual 

layout 

One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2533#oembed-2 

Avoid adding textboxes to slides for anything other than plain 
text. Instead, modify slide layouts and add proper placeholders. 

To ensure accessible structure avoid invisible tables, text 
boxes, and repeated tabs, spaces, or returns. Instead: 

• Create columns using Layout > Columns. 
• Change spacing before and after paragraphs via Home > 

Line Spacing Options. 
• Manually create a line break by pressing Shift and Enter. 
• Of repeatedly pressing Enter, use Insert > Page Break. 
• Of repeatedly pressing Tab or Spacebar, navigate to Home

> Increase/Decrease Indent or use the indent markers on 
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the horizontal ruler (View > Ruler). 

Tables 

Tables are useful for organizing data. Properly built and 
formatted tables are completely accessible. 

Table Best Practices 

• Tables must have a header and/or column row. 
• A concise, descriptive table title helps with context and 

organization 
• Do not use nested, merged, split, or unnecessary blank 

cells 
• Ensure cells have adequate padding and margins 
• Do not use coloured cells or text alone to indicate 

meaning 
• Do not use tables with invisible borders to format layout 
• Office accessibility checker does not note table errors 

◦ Click in the top left cell, then use the Tab key to see 
ensure your table reading order is logical and 
consistent 

To insert a table in PowerPoint: 

1. Insert tab 
2. Table 
3. Insert Table 
4. Indicate number of columns and rows and press Ok 

1. You can add columns and rows later 

Set a header row/column: 
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1. Click anywhere in your table. 
2. Select Table > Table Design tab > click Header 

Row (or First Column, if column is a header) checkbox. 
3. Select Banded Rows or Banded Columns for a landscape 

document. 
4. Select the header row then navigate to Table Layout, 

select Repeat Header Rows to repeat headers across page 
breaks. 

5. Accessible tables in Word can only have one header 
row, one header column, or both. 

Right-click on table and select Table Properties for advanced 
table options via the table properties dialogue. 

In some instances it may make sense to add alt text to a table 
as a summary. To do so: 

1. Navigate to Table Properties 
2. Select the Alt Text tab 
3. Add a Title and a Description 
4. Click Ok 

Lists 

Properly formatted lists organize information and makes your 
presentations accessible. 

• Use bullet lists for unorganized lists 
• Lists where the sequence is not important 

1. Use numbered lists for items where sequence is important 
2. Such as steps in a process 

To create a list in PowerPoint: 

224  |  Structure of Slides

https://support.microsoft.com/en-us/office/set-or-change-table-properties-3237de89-b287-4379-8e0c-86d94873b2e0
https://support.microsoft.com/en-us/office/set-or-change-table-properties-3237de89-b287-4379-8e0c-86d94873b2e0


1. On the Home tab 
2. Select Bullets, Numbering, or Multilevel List 

1. The dropdowns accompanying each style offer more 
options and customization. 

Lists can be converted to SmartArt. There are some additional 
steps to make SmartArt accessible. 
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Images, Media, and 
Links 

On this page: 
Text Equivalents  Images and Graphics  Closed Captions 

and Transcripts  Hyperlink Text 

Text Equivalents 

As discussed in the alternative text chapter of this guide, visual 
information needs a text equivalent. In PowerPoint, the text 
equivalent of visual information can be included in: 

• Text adjacent to an image. Presenting text with visuals 
that reinforce and support one another is a great practice 
that ensures everyone can access information. 

• The alt text field of a graphic. 
• Figure captions. 

Assistive technologies employ alternative text (alt text) 
attached to images to inform users of the context and purpose 
of images and visual elements. Alt text is a text alternative to 
visual content to ensure all users can access information. 

Alt Text 

Use the alt text field to add a description of information present 
in a graphic. The alt text field is only read by screen reader 
software to provide visual information in an accessible format. 

To add alt text in PowerPoint: 
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1. Right click on an image and select Edit Alt Text… 

2. Or, select the image, move to the Picture Format tab and 
click Alt Text 

3. Enter a description in the dialogue box. 
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4. If a graphic is purely decorative, check Mark as 
Decorative. 

To add alt text in PowerPoint online: 

1. Select the image 
2. Navigate to the Picture tab 
3. Select Alt Text and enter your description in 

the Title field.  
4. If the image is purely decorative, leave the Title field blank. 
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Figure Captions 

Bizarrely, despite being Microsoft’s primary visual presentation 
medium, PowerPoint does not support adding figure captions. 
Instead, Microsoft recommends inserting a text box and 
grouping it with the graphic. 

From Microsoft: 

1. Use Insert > Text Box to draw a box near the 
picture. (See add a text box for additional 
details.) 

Text Box button in the Text group 
2. Click inside the text box and type the text 

you want to use for a caption. 
3. Select the text. On the Home tab, use 

the Font options to style the caption as you 
want. 

4. Use Ctrl+click to select the picture and text 
box, and then on the Picture Format tab, in 
the Arrange group, select Group > Group 

On the Picture Format tab, the grouping 
options are in the Arrange section. 

Ensure textbox and graphic are in correct reading order. If a 
graphic has a descriptive caption it can be marked as 
decorative in the alt text panel. 

The Office Accessibility Checkerwill flag images that do not 
have alternative text. In the Accessibility pane, Missing object 
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description will appear as an error. You can select the drop 
down menu and choose Add a description or right-click on 
the image and choose View Alt Text… Do not rely on the 
automatically generated alt text, it is rarely useful. 

Review this Pressbooks’ chapter on Alternative Text for more 
information. 

Add alternative text to simple charts but also include table 
data for complex charts and data sets. Best practice is to 
include table data adjacent to the chart, but linking to the data 
elsewhere in the document is also an effective method. Ensure 
the link text explains the destination. 

For more information, consult the following Microsoft 
support resources: 

Add alternative text to a shape, picture, chart, SmartArt 
graphic, or other object 

Add alt text to visuals in PowerPoint 
Video: Improve image accessibility in PowerPoint 

Images and Graphics 

Apart from adding effective alt text to images, there are a few 
additional considerations for visual elements in PowerPoint 
presentations. 

Take note of groups of images: 

1. Click and drag to select the images or hold Control and 
click each image 

2. Right-click and select Group > Group 
3. Right click on grouped image and select Edit Alt Text… 
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One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2535#oembed-1 

Group or ungroup shapes, pictures, or other objects. 

Graphs and Charts in PowerPoint 

• Do not include photos of charts or graphs, insert them 
properly via Insert tab > Chart dropdown 

• A concise and meaningful title or caption helps all readers 
◦ Add alt text to graphs and charts but also include 

table data for complex charts and data sets. Best 
practice is to include table data adjacent to the chart, 
but linking to the data elsewhere in the document is 
also an effective method. Ensure the link text explains 
the destination. 

• Do not rely on colour alone to distinguish data. Use 
symbols or different line styles. Include a legend 

• Apply data and axis labels by selecting your graph or chart 
and navigating to Chart Design tab and selecting Add 
Chart Element dropdown 

• Provide alternative formats, such as a table of data plotted 
via chart 
◦ For a chart or graph, provide data in table form beside 

the element. If size and spacing is a concern, place the 
data in another slide or document and provide a link 
near the chart or graph. 
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Closed Captions and Transcripts 

Ensure embedded media has text equivalents. Videos must 
have closed captions and audio must have a transcript. 

To add captions to a video in PowerPoint they must be in .VTT 
format (3Play Media offers a free .SRT to .VTT conversion tool). 

To add a .VTT caption file: 

1. Navigate to slide with video and select the video 
2. Via the Playback tab, click Insert Captions, and select 

Insert Captions 
3. Select caption file and click Insert 

However, best practice is to embed a video or link to the video 
hosted elsewhere. This will keep the size of the PowerPoint file 
down and provide for easier, more equitable distribution. 

Review closed captions best practices. 

Hyperlink Text 

When linking to a website, use meaningful hyperlink text. 
Linked text should be descriptive, concise, unique and visually 
distinct. Do not use bare URLs. To learn more about writing link 
text, consult the accessible links chapter of this guide. 

Use PowerPoint’s default styling of blue font with underlined 
text for links. 

To add links in PowerPoint: 

1. Select the text you want to link 
2. Right-click and select Hyperlink or press Control
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(Command on macOS) and K 
3. Change the Text to Display text if necessary 
4. Paste the destination URL in the Address box 

You may have existing presentations that contain bare URLs. To 
update existing, bare URLS to accessible links: 

1. Right-click on the bare URL 
2. SelectEdit Hyperlink… 
3. In the Text to display field, type a brief description of link 

destination. 
4. Click Ok. 

More information on hyperlink text in PowerPoint can be found 
here. 
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◦ @ (the at symbol) 
◦ & (ampersand) 
◦ / (slash) 
◦ © (copyright) 
◦ ® (registered) 
◦ ™ (trademark) 
◦ ¶ (paragraph) 
◦ • (bullet) 

◦ $ (dollar) 
◦ € (Euro) 
◦ £ (British pound) 
◦ ¥ (Yen) 
◦ % (percent) 
◦ ½ (one half) 
◦ ¼ (one fourth) 
◦ ¾ (three fourths) 
◦ ° (degrees) 

Formatting and Styles 
to Avoid 

The following formatting and object types are not 
communicated to assistive technology or present significant 
barriers to some users and should be avoided: 

• Strikethrough 
• Highlighting 
• Dropcap 
• Word Art, Smart Art, text effects 
• Ungrouped related shapes 
• Watermarks 

• Symbols, except for the following safe characters: 
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Additional PowerPoint 
Tools 

Consider the following tools in PowerPoint to enhance the 
accessibility of your presentations. 

On this page: 
Templates  Slide Numbers  Live Subtitles  Transitions and 

Animations  Decorative Image Attribution  Notes 
SmartArt 

Templates 

Templates have pre-formatted fields such as “title” or “body” 
which are conveyed to assistive technology to provide context 
and structure. 

Microsoft guide to finding accessible templates for Office 
products. 

Do not insert additional text boxes. Change slide format 
using built-in tools. Navigate to Home > New Slide > Select new 
slide based on required style and format. 

To create a custom layout, use Insert Placeholder via View
> Slide Master > Insert Placeholder and selecting the 
appropriate content type. 

Consider this Microsoft guide to customize slider masters for 
more information. 

Slide Numbers 
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Accessible slide numbers are useful navigational aids for all 
users. 

1. Navigate to Insert 
2. Choose Slide Numbers 
3. Follow prompts and select Apply or Apply to All. 

You can also add slide numbers to a Slide Master. To avoid 
possible reading order issues, add slide numbers as a last step. 

Presentation Subtitles 

PowerPoint has options for captioning your presentation. Read 
the Microsoft guide to presenting with automatic captions in 
PowerPoint (note that automatic captions are not accurate 
enough to fulfill a required accommodation). Use this method 
for an in-person presentation: 

1. Navigate to Slide Show tab and choose Subtitle Settings 
2. Set Spoken Language and Subtitle Language 
3. Leave subtitle position as Below Slide 

If recording your screen, do not enable subtitles. 
These subtitles will be recorded as part of your video 
and cannot be edited or turned off by viewers. 

Slide Transitions and Animations 
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• Avoid automatic slide transitions 
◦ Use simple transitions in place of complex transitions 

• Use simple animations 
• Ensure content does not blink or flash more than 3 times 

per second 
◦ Flashing and blinking content can cause seizures 

Decorative Image Attribution 

When adding an image attribution (copyright license etc.) to 
a decorative image, ensure the caption is also marked as 
decorative. If it is not, assistive technology would not announce 
the image, but would read the succeeding attribution text. This 
would lead the reader to believe they may have missed an 
important image. 

To add a caption to a decorative image in PowerPoint: 

1. Move to Insert and select Insert Textbox. 
2. Place the textbox under the image and type your caption. 
3. Control (Command on macOS) and click, or click and drag 

over, the image and the textbox. 
4. Right-click the image and select Group > Group. 
5. Or, on the Home tab, select Arrange > Group > Group. 
6. Select your new group and copy (right-click 

> Copy or Control [Command on macOS] and c). 
7. On the Home tab, choose Paste > Paste Special. 
8. Choose Picture (PNG) and select Ok. 
9. Right-click on newly grouped image and select Edit Alt 

Text… 
10. Check Mark as decorative. 
11. Remove old image and textbox. 
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Notes 

Notes can be accessible and provide additional information or 
context. 

Notes is the best location for a transcript of your entire 
presentation (if applicable). 

Notes can also be used to include extended descriptions of 
images and graphics. 

If you are using the Notes field for speaker notes and do not 
wish to share your notes remove all notes before sharing. 

SmartArt 

SmartArt can be an effective tool to make lists more visually 
appealing. To make SmartArt accessible, one additional step is 
required. 

1. Once you have created SmartArt, navigate to the 
SmartArt Design tab. 

2. Select Convert. 
3. Choose Convert to Shapes.

4. Select the Shape Format tab. 
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5. Choose Group > Ungroup.

6. This makes the objects independent and machine 
readable. 

7. Add alt text (the exact text included in the graphic) to each 
item. 

1. Note, some SmartArt will include an arrow or other 
shape behind the objects. Select such objects, right-
click and choose Edit Alt Text… and chose Mark as 
decorative. 

There is an additional method to make SmartArt accessible by 
providing a text alternative. Begin by making a list in plain text: 

1. Copy list content with right-click > Copy or 
press Control (Command on macOS) c. 

2. On the Home tab click Convert to Smart Art and choose 
your desired SmartArt design. 

3. Move to the Insert tab and select Textbox. 
4. Paste your plain text list from step 1 into the textbox. 
5. Move the textbox outside the slide frame. 
6. Verify textbox is read immediately after SmartArt in 

the Selection Pane (via Arrange on the Home tab). 
7. Right-click the SmartArt, select View alt text… and 

check Mark as decorative. 
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Accessibility Assistant 

Use PowerPoint’s Accessibility Assistant, a built-in accessibility 
checker to check for common issues. Note, these tools may not 
catch all possible accessibility issues. 

To use the Accessibility Assistant: 

1. Select Review tab. 
2. Choose Check Accessibility button. 

1. The Accessibility Assistant panel will open and show 
issues. 

3. Select each issue to see it highlighted in the document. 
1. Select the arrow next to each warning to see further 

information (Windows only). 

One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2540#oembed-1 

To see real time accessibility status: 

1. At the bottom of the Accessibility Assistant panel select 
the Settings button. 
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2. In the Settings window, check the Show accessibility 
status for the Accessibility Assistant in the Status 
Bar checkbox. 

3. Click Accessibility: Investigate in the status bar at the 
bottom of the window to open the Accessibility Assistant 
pane. Accessibility: Good to go indicates no violations of 
the automated checker’s rules. 

4. Additionally, check Show accessibility status for each 
slide to toggle on a real-time, inline accessibility checker. 
When content is added that violates the PowerPoint 
accessibility checker rules, a small human form icon will 
appear beside the slide thumbnail. 
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Checker Results 

Like any automated tool, PowerPoint’s Accessibility Assistant 
will not catch all accessibility issues. Here is a summary of what 
it does look for and how well it catches those issues: 
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Element checked Effectiveness of check 

Check reading order 

Strong 
Evaluates the order of all objects 
on each slide to ensure correct 
reading order for assistive 
technology. Possible false 
positives based on rigid Z pattern 
(top-left, top-right, bottom-left, 
bottom, right) assumption. 

Missing alt text 

Moderate 
Flags images that do not have alt 
text or where the alt text is the 
image file name. 
Cannot identify if alt text is 
appropriate or meaningful. 
The built-in image description 
generator is poor and should not 
be used. 

Hard-to-read text 
contrast 

Moderate 
Can evaluate the contrast of text 
against the background inside 
shapes or shaded textboxes 
(including tables), but not text 
against slide background. 

Missing audio or video 
subtitles 

Moderate 
Evaluates inserted video files for 
attached caption file. May 
produce false positive as the tool 
is unable to check if embedded 
or linked videos have captions. 

Missing slide title/
Duplicate slide title 

Strong 
Automatically flags slides that do 
not have properly coded titles. 
Assists users to convert uncoded 
titles. 
Flags slides with duplicate titles. 

Missing table header 

Strong 
Flags tables that do not have 
properly marked up table header 
cells. 

Use of merged or split 
cells 

Strong 
Flags tables that include merged 
or split cells. 
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Element checked Effectiveness of check 

Default section name 

Strong 
Flags sections named “Default” 
and includes a shortcut to 
rename Sections. 

Duplicate section 
names 

Strong 
Flags sections with duplicate 
names and includes a shortcut to 
rename Sections. 

Additional elements not 
automatically checked: 

The PowerPoint Accessibility Assistant does not assess links, 
font size and style, or proper use of lists and SmartArt. 

Read more about checking for accessibility issues with the 
Office Accessibility Checker and learn about Office Accessibility 
Checker rules and messages. 
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Sharing and Exporting 

On this page: 
Read-Only and Restrict Editing  Remove Speaker Notes 
Export to Video  Export to PDF 

Best practice is to share material in advance of a meeting, 
presentation, or class. 

• Sharing allows users to check for barriers beforehand and 
customize their experience. 

• All users can take additional, in-depth notes and 
understand terminology and names with greater 
comprehension. 

Avoid preset slide timings that advance slides automatically so 
that viewers can choose how much time to spend on material. 

Read-Only and Restrict Editing 

Read-Only and Marked as Final 

You may wish to share your document as Read-Only or Final. 
To do so: 

1. Navigate to File > Info 
2. Open the Protect Presentation menu 
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3. Select Always Open Read-Only to prompt users to opt-in 
to editing or Mark as Final to display a message 
reminding users the presentation is not to be edited. 

Restrict Editing 

If you are concerned about the content of your PowerPoint 
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being changed, you can restrict editing so other users can only 
access the file as read-only. 

1. Select File > Save As and click Browse 

2. Choose a local save location and open the Tools menu and 
open General Tools… 

3. Set a password in the Password to modify: field, click 
OK and confirm the password. 
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4. Click Save. 
5. Distribute your PowerPoint. Users will be notified that they 

can only open a read-only version of the file. 

Remove Speaker Notes 

Windows 

To remove your speaker notes before distribution, first make a 
copy of your PowerPoint for distribution, then: 

1. Select File > Info. 
2. Click Check for Issues button beside Inspect Presentation 
3. Select Inspect Document
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4. Click Inspect in the new window. 
5. Once the operation is complete, click Remove All 

beside Presentation Notes. 
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6. Click Close when done. 
7. Save and distribute this note-free copy. 

macOS 

To remove your speaker notes before distribution, first make a 
copy of your PowerPoint for distribution, then: 

1. Open the Tools menu. 
2. Select Macros and then Visual Basic Editor. 
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3. Select Insert Module. 

4. In the new window that appears, paste: 
Sub Zap() 
Dim osld As Slide 
For Each osld In ActivePresentation.Slides 
With osld.NotesPage.Shapes(2) 
If .HasTextFrame Then 
.TextFrame.DeleteText 
End If 
End With 
Next osld 
End Sub 
Then click the red X to close the window. 

Sharing and Exporting  |  251



5. Close the Microsoft Visual Basic window. 
6. Open the Tools menu. 
7. Choose Macro and then Macros…

8. In the new window, choose Zap and click Run. 
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Any content in the Notes field will be removed. This process 
cannot be undone, except if restoring from a previous save. 

Export as a Video 

One often overlooked method to share a PowerPoint is as a 
video. One common educational use case is adding an audio 
recording over slides (e.g., lecture material). This can be done 1 
of 2 ways: 

Record Audio 

Another method is to record or insert audio for specific slides. 
To record audio for a slide: 
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1. Navigate to the slide. 
2. Move to the Record tab and select Audio. 

3. Record your audio, click stop, and then Ok to add the 
audio to the slide. 

Alternatively, you can insert an existing audio recording to a 
slide: 

1. Navigate to the slide. 
2. Move to the Insert tab and select Audio.

3. Choose Audio on my PC and select the appropriate file 
(.MP3, .M4A, .WAV) 

Recording or adding an audio file to a PowerPoint slide adds 
a speaker icon to the slide which contains the audio player 
controls. Select the speaker icon and move to the Playback tab. 
For video export purposes, ensure Start is set to Automatically 
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and check Hide During Show to hide the icon on the slide. 

To export to video, open the File menu: 

1. Choose Export. 
2. Choose Create a Video. 
3. Click the Create Video button. 

4. Choose file location and select Save. 

Record Slide Show 

To record the entirety of your slide show including animations, 
transitions, audio, and timing use PowerPoint’s Record feature. 

Via the Slide Show tab, choose Record. 
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Once setup, click record and when finished recording click 
stop. Then follow the prompts to export your video. 

Video Hosting 

Best practice is to host the video online using Kaltura 
Mediaspace. For more information, refer to the Kaltura 
Mediaspace/My Media guide. 

Export to PDF 

The best way to use PDFs is sparingly. 

The knowledge and time needed to make accessible PDFS 
rarely justifies the use of PDFs. PDFs require significant coding 
to make accessible, do not reflow content to fit different size 
monitors, and should be used only when necessary. 

Do not use File > Print > Save as PDF as that method does 
not retain any document structure and requires significant 
time and expertise to make an accessible file. 

If you absolutely must create a PDF and have Acrobat 
installed: 
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1. Open File > Save as Adobe PDF 
2. In the save dialogue, select Options and eEnsure the 

following are checked: 
1. Enable Accessibility and Reflow with tagged Adobe 

PDF 
2. Create Bookmarks 
3. Convert Word Headings to Bookmarks 

3. Click Ok and then Save. 

Without Acrobat installed: 

1. Open File > Save as or Export. 
2. Enter file name and select save location. 

1. (Windows) Select PDF in Save as type list. 
1. Choose Options and select Document structure 

tags for accessibility check box. 
2. Select Ok. 

2. (MacOS) Select PDF from File format drop down. 
1. Select Best for electronic distribution and 

accessibility (uses Microsoft online service) radio 
button. 

2. Select Save. 

For more information about PDFs, read The People v. PDF. 
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Additional Resources 
Microsoft Support website guide to making PowerPoint 
accessible. 

WebAIM guide to PowerPoint accessibility techniques. 
Read Understanding PowerPoint Accessibility, University of 

Colorado Boulder 
Microsoft Support video on accessible colours and styles in 

PowerPoint. 
Download the Accessible PowerPoint Template sampler to 

start with accessible templates. 
Microsoft outlines best practices to make documents 

accessible. 
Once you have an accessible presentation, learn more about 

inclusive content delivery. 
Present from PowerPoint Live in Microsoft Teams 
Present Live: Engage your audience with Live Presentations 
Contact assistivetech@langara.ca for further information or 

assistance. 
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VIDEO ACCESSIBILITY 
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Video Accessibility 

When recording a video ensure everyone 
can engage and understand with the 
content. Plan for accessibility from the start 
because it requires more time and effort to 
fix things later. 

On this page: 
Plan and Script  Audio Descriptions  Recording Setup 
Captions and Transcripts  Accessible Video Players 

Plan and Script 

Always begin a video project with a plan and a script. Even a 
brief video or screencast will be easier to create from a script. 
Consider the purpose of the video, subject, length, and 
resources required. Write a simple script including the actions 
you will take and what you plan to say. This script does not 
need to be followed rigidly but will be a helpful guide. Try to use 
plain language. Explain complex terms, jargon, abbreviations, 
and acronyms. Write for the intended audience. 

To significantly enhance the accessibility of your video 
content, consider adding integrated descriptions to your 
script. By incorporating audio descriptions of visual 
information, all viewers are included. 

Audio Descriptions 

To enhance accessibility for all viewers, important visual 
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Key principles of described 
video Include: 

• Describing what is on 
screen 

• Prioritizing essential 
information 

• Using the present tense 
• Remaining consistent with 

names of speakers and 
places 

Descriptions should not: 

• Explain or elaborate 
beyond what is visually 
apparent 

• Interpret 
• Add opinion 
• Censor 
• Summarize 

elements in your video must be included in the audio. One 
method to achieve this is called audio description: an 
additional audio track narrating visuals and actions. Often 
included are descriptions of surroundings, speakers’ 
appearance, body language, and any other non-audio 
information. The description is added during pauses in 
dialogue and included as an optional audio track. Audio 
description is usually indicated with an AD or D))) logo or icon. 
Audio description requires a separate script and recorded 
audio track and some video players do not support multiple 
audio tracks. 

At this time, described 
video is rare and not legally 
required. 

Integrated 
Description 

Integrated description is an 
intentional practice to 
describe visuals aloud as 
part of the video’s natural 
flow. This accessibility-
focused practice benefits 
not only blind and low 
vision viewers and viewers 
with cognitive disabilities 
impacting their ability to 
read, but all viewers. The 
audience might be 
watching on their phone, 
while multitasking, or 

watching on a lower bandwidth. Integrated description helps 
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Size, position, or unique 
characteristics 

• “The bookshelf is about six 
feet high, and is 75% full of 
books.” 

• “I’m going to click on the 
close button in the top 
right of the window.” 

Navigational features 

• Regions (sidebar, 
navigation menu, footer, 
etc.) 

• Navigational way points 
like breadcrumbs or 
pagination 

Labels 

• Slide numbers 
• Figure labels 
• Question numbers 
• Buttons 
• Menus 

all viewers follow along, particularly if a video includes 
demonstrations or instructions. As well, integrated description 
may help reduce audience members’ cognitive load as it 
reduces the need to split their attention between visual and 
audio elements. With integrated description, each mode 
reinforces the other. By describing visual material, you ensure 
the entire audience can understand your content. 

To include integrated descriptions in your script, consider the 
following best practices. 

Be specific by referring to: 
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• Links 
• Headings 

Learn the specific names of 
common components. 

Relative terms 
Once a specific location is 
identified, use relative terms. 
For example: 

• “To the left of the search 
box” 

• “Under the Personas 
heading” 

• “Below figure 1.” 

Work on the assumption that 
readers and assistive 
technology read in a Z pattern 
starting at the top left. 

Describe actions 
Deliberately announce 

actions, such as: 

• “open the format menu” 
• “click the Save button” 
• “select checkbox” 
• “highlight the text” 

Identify yourself and other 
speakers by name 

Avoid: 

• Sensory-only instructions 
that rely on sight or colour. 

• Vague references like 
“here” or “there” as most 
users will not know where 
you are referring to. By 
being specific and direct 
you will become a more 
thorough and precise 
speaker, enhancing your 
authority and audience 
satisfaction. 

Briefly summarize or 
explain visual elements, 
including long blocks of 
text. Avoid reading text 
word for word, instead aim 
to summarize 
withoutextraneous detail to 
ensure all important 
information is conveyed in 
audio format. 

• Write descriptions and 
practice reading them to 
maintain the flow of your 
presentation. 

• Include relevant 
information about the 
relationships and hierarchy 

of information. 

When relevant, spell names and complex words out letter by 
letter. 
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A great accessibility practices audio descriptions can also 
provide additional detail, context, and information for all 
viewers that will lead to greater engagement and 
understanding. Don’t wait until you think you have someone 
with a disability in your audience. Add integrated description to 
videos and presentations today. 

Aim to be concise and direct while including all 
relevant information. Specificity aids accessibility 
and viewer understanding. In addition, precise 
language enhances the audience’s sense of the 
speaker as an authority on the subject. Most 
importantly, incorporate integrated description into 
your script from the start. 

Recording Settings 

When recording audio, such as narration or voiceover: 

• Ensure there is no background noise. 
• Use a dedicated microphone (not a built-in laptop 

microphone) when possible. 
• Not only will this improve audio clarity for viewers, but will 

also improve the machine-generated first draft of your 
captions. 

For camera recordings: 

• Record in at least 720p resolution. 
• Use a neutral, consistent background. 
• Ensure adequate lighting. 
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◦ Avoid shadows and backlighting 

When recording your screen: 

• Remove clutter. 
• Silence notifications. 
• Record only main content. 

If screencasting or filming a whiteboard, remember to: 

• Avoid using colour alone to convey meaning. 
• Use sufficient colour contrast. 

Avoid flashing content 

• Avoid content that flashes more than 3 times per second. 
Flashing content can cause seizures. 

• If flashing content is essential, provide a warning at the 
start of the video. 

Captions and Transcripts 

Captions are a text equivalent of a video’s audio displayed 
synchronously with the video content. Rely on automatic 
captioning tools to create a draft of captions. Edit captions with 
proper grammar, ensuring names and terminology are correct. 
Verify that captions are synced with the audio. 

Closed captions can be toggled on and off by each viewer. 
Open captions are part of the video file and cannot be toggled 
on and off. Prefer closed captions except for foreign language 
subtitling. Refer to the closed captioning resources in this book 
for more information. 

A transcript is a text version of multimedia content. Some 
platforms automatically generate transcripts alongside 
captions. Transcripts can include additional information such 
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as descriptions of action, setting, and other visuals in the video. 
Integrated description, as discussed above, deliberately 
includes this information and eliminates the need for 
additional work when creating a transcript. 

By thoroughly and accurately planning and 
scripting your video you will already have a 
transcript. Any edits needed to a machine-
generated caption file will also be made easier by 
referring to the script. 

Accessible Players 

An accessible video player supports closed captions, 
transcripts, is keyboard accessible, and does not autoplay. 
Support for an additional audio description track is a bonus, 
but not required. Kaltura, H5P, and Brightspace all have 
accessible media players. 

Further Reading 

Consider AMI guides to described video for advanced 
techniques. 
W3 provides a brief guide to integrated description. 
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Deque’s blog on accessible speaking best practices 
covers presenting more broadly. 
Providing Spoken Descriptions of Visual Content. 

268  |  Video Accessibility

https://www.deque.com/blog/accessible-speaking-best-practices/
https://www.colorado.edu/digital-accessibility/visual-description


Kaltura MediaSpace 
Quick Start Guide 

Kaltura MediaSpace is an online media hosting/
streaming service similar to YouTube. You can use 
MediaSpace to upload, edit, and share your media 
with other users, and for inserting media into your 
Brightspace courses. 

Kaltura can be accessed either from within your Brightspace 
course under My Tools > My Media, or by visiting the Langara 
MediaSpace website. 

Using MediaSpace 

1. Navigate to mediaspace.langara.ca and select Login. 
2. Use your Langara email and password.
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3. Select Add New.

4. Choose appropriate type: 
1. Media Upload allows you to upload a file, like an 

.mp4 or .mov 
2. Web Recorder is a browser based tool allowing 

you to record audio, webcam, and screen 
3. YouTube allows you to copy public videos from 

YouTube to Kaltura MediaSpace 
4. Kaltura Capture is a desktop (Windows and 

macOS) software that records audio, webcam, and 
screen 

5. Video Quiz allows users to take an existing video 
and add interactive elements 

For more information on using MediaSpace, visit How to 
Use MediaSpace – Help with Student Learning Tools. 
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Brightspace My Media 

To add Kaltura media in Brightspace: 

1. Select Insert Stuff

2. Select an existing video (adding to MediaSpace or My 
Media) by click Embed.

3. Or, create a new video using Add New.
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4. The Add New options in My Media are the same in 
MediaSpace. 

1. Refer to add new options list. 

For more information on captions, consult Closed Captioning 
Quick Start Guide. 

Videos are not finished until they are accurately 
captioned. New uploads to MediaSpace will 
automatically trigger a request for machine-
generated captions. Verify spelling, terminology, and 
accuracy of those captions. 
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Adding YouTube to 
MediaSpace 

Quick Start Guide 

Kaltura MediaSpace allows users to copy public 
YouTube videos for educational purposes. 
Uncaptioned YouTube videos must be copied to 
Kaltura MediaSpace to be captioned. 

Step 1: Login to MediaSpace 

1. Navigate to MediaSpace at mediaspace.langara.ca 
2. Login using your Langara email and password
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Step 2: Add new media 

1. Click + Add New and choose YouTube

2. Paste the YouTube URL in the textbox and click Preview.
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3. Once the page refreshes, scroll down to verify the 
information. 

4. Select Unlisted or Published to trigger a request for 
machine-generated captions. Leaving a YouTube import 
as Private will not trigger a caption request. 

5. Click Save.

For more information on captions, consult Closed Captioning 
Quick Start Guide. 
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Videos are not finished until they are accurately 
captioned. New uploads to MediaSpace will 
automatically trigger a request for machine-
generated captions. Verify spelling, terminology, and 
accuracy of those captions. 
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Captioning Kaltura 
Videos 

Quick Start Guide 

Videos uploaded to MediaSpace after October 
2022 will have machine-generated captions 
automatically added. For videos uploaded before 
that date, you can manually order machine-
generated captions. All machine-generated 
captions must be edited for accuracy. 

On this page: 
Ordering Captions  Editing Captions  Editing Captions in 

Word 

Captions are a synchronous text equivalent of the audio 
content in a video. Closed captions are toggled on or off by the 
viewer in the video player interface. 

Closed captions are an accessibility requirement and 
essential for viewers that are deaf or hard of hearing. In 
addition, closed captions benefits:  

• Viewers for whom the video’s language is an additional 
language 
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• Viewers in noisy or loud locations where they cannot listen 
uninterrupted or at a comfortable volume 

• Viewers new to the subject matter who are unfamiliar with 
the unique terminology, jargon, or important names 

• Neurodivergent users who have trouble focusing or 
following along 

Captions help learners with: 

• Accuracy when taking notes on a video 
• Greater information retention and comprehension 

through both listening and reading 
• Better engagement with content 

Statistics indicate that around 5% of the general population 
has some form of hearing loss. However, studies suggest that 
80% of 18 to 24-year-olds regularly watch videos with captions 
turned on. Captions are not simply an accessibility 
requirement; they are an excellent learning tool. 

To order captions 

1. Navigate to your media on Langara College MediaSpaceor 
in Brightspace go to My Tools> My Media 

2. Open the Actions menu 
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3. Select Caption & Enrich 
4. Click Order and then Submit
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Editing Captions 

1. Navigate to your media on Langara College MediaSpaceor 
in Brightspace go to My Tools> My Media 

2. Open the Actions menu and select Edit
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3. Navigate to the Captions tab and select Edit Captions or 
Edit beside the desired caption file

4. Edit captions for accuracy, especially focusing on spelling 
of names and terminology 
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5. Click Save 
6. Adjust the caption accuracy slider 

7. Click Save 

Edit Captions in Word 

As an alternative method for editing captions, consider 
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exporting the captions file, making changes in a word 
processor, and uploading the edited file. To do so: 

1. Navigate to your media on Langara College MediaSpaceor 
in Brightspace go to My Tools> My Media 

2. Open the Actions menu and select Edit

3. Select the Captions tab

4. On the Captions tab, select Download

Captioning Kaltura Videos  |  283

https://mediaspace.langara.ca/


5. A file will be downloaded to your computer in either .SRT 
or .VTT 

6. By default the file should be opened in Notepad on 
Windows and TextEdit on macOS. However, if it does not, 
right-click on the field and select Open with and choose 
the appropriate text editor 

7. Press Control a or Command a on macOS to select 
everything in the file. Press Control c or Command c on 
macOS to copy all of the content 

8. Open a new Word document and press Control 
v or Command v on macOS to paste all of the content 

9. Use Word’s spellchecker, find and replace, and other 
editing tools to ensure the text matches the audio of the 
video 

10. In Word press Control a or Command a on macOS to 
select everything in the file. Press Control c or Command 
c on macOS to copy all of the content 

11. Move back to the .SRT or .VTT downloaded from Kaltura 
and press Control a or Command a on macOS to select 
everything in the file. Press Control v or Command v on 
macOS to paste the edited text 

12. Save the .SRT or .VTT file 
13. Navigate to the Captions tab and select Upload captions 

file
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14. Select your edited .SRT or .VTT file, complete the required 
fields, and click Save 

For more information on captions, consult Closed Captioning 
Quick Start Guide. 

The Kaltura player allows viewers to customize the 
appearance of captions. 

Videos are not finished until they are accurately 
captioned. New uploads to MediaSpace will 
automatically trigger a request for machine-
generated captions. Verify spelling, terminology, and 
accuracy of those captions. 
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MediaSpace 
Collaboration 

Quick Start Guide 

Content in MediaSpace can be shared between 
multiple collaborators. This allows a video owner to 
share a video to be captioned or edited. 

Adding Collaborator 

1. Find your media on Langara College MediaSpace or in 
Brightspace go to My Tools > My Media 

2. Open the Actions menu and select Edit 
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3. Move to the Collaboration tab and select Add 
Collaborator

4. Type in the name of the person you wish to add as a 
collaborator, set permission type, and click Add
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Permissions Types 

• Co-Editors can add and edit captions. 
• Co-Publishers can also change the video from 

private to unlisted or published to a channel. 
• Co-Viewers can watch an unlisted video. 

Videos are not finished until they are accurately 
captioned. New uploads to MediaSpace will 
automatically trigger a request for machine-
generated captions. Verify spelling, terminology, and 
accuracy of those captions. 

288  |  Kaltura Collaborators



PDF ACCESSIBILITY 
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Creating Accessible 
PDFs 

In addition to adhering to best practices 
for plain language, font, colour, and other 
accessibility essentials, an accessible PDF is 
tagged. PDF tags are code that provides 
structure for assistive technology. 

To create accessible PDFs, ensure you 
have Acrobat Pro DC installed on your 
device. Acrobat Reader lacks the necessary features to make 
PDFs accessible. PDFs can be generated in software such as 
Adobe Acrobat, but the most common method is to take an 
existing Word document or PowerPoint presentation and 
export it to PDF. Ensure that you start with an accessible 
document before exporting to PDF. 

PDFs are popular but may not always be the best choice of 
file. PDFs are an antiquated format that are extremely time 
consuming to make accessible. Consider providing HTML, 
Word, or PowerPoint (most documents can have editing 
restricted) first. If readers prefer PDF, they can convert your file 
to PDF. 

The best way to use PDFs is sparingly. 
On this page: 

PDF Source Documents  Making Accessible PDFs  Reading 
Order  Check Accessibility  Further Reading 

PDF Source Documents 

The majority of PDF documents will be converted from a Word 
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or PowerPoint document. Refer to previous chapters for best 
practices to create accessible documents in those formats and 
ensure you properly export the file to PDF. 

Office Software with Acrobat Installed 

In Word or PowerPoint: 

1. Select the Acrobat tab 
2. Choose Create PDF 

1. Select Options 
1. Ensure the following are checked: 

1. Enable Accessibility and Reflow with tagged 
Adobe PDF 

2. Create Bookmarks 
3. Convert Word Headings to Bookmarks 

2. Click Ok 
3. Save file. 

Office Software without Acrobat Installed 

1. Click File > Save As and enter file name and select save 
location. 

1. (Windows) Select PDF in Save as type list. 
1. Choose Options and select Document structure 

tags for accessibility check box. 
2. Select Ok. 

2. (MacOS) Select PDF from File format drop down. 
1. Select Best for electronic distribution and 

accessibility (uses Microsoft online service) radio 
button. 

2. Select Save. 
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Do not use Print > Save as PDF as that will not retain any 
document structure and will make you repeat your efforts to 
make your PDF accessible. 

Using Adobe Acrobat 

1. File > Create > PDF from File… 
2. Select file from dialog. 

1. On Mac: Check Use Adobe Create PDF cloud service. 
3. Select Open. 

Adobe guide to creating PDFs from multiple formats. 

Scanned PDFs 

PDFs are a common output format for scanned documents. A 
scanned document will be a ‘flat’ PDF—essentially an image 
of the scan. PDFs creating this way are untagged and not 
accessible. 

Before scanning a document or book, consider looking for 
an existing accessible electronic version of your resource. 
However, when scanning a document to PDF: 

• Set scanner settings to at least 300 DPI (dots per inch). 
◦ Higher number is better but increases the size of the 

scanned file. 
• Scan in black and white or 24-bit colour. 

◦ Consider that information should not be conveyed by 
colour alone. 

• Some scanners have built-in Optical Character 
Recognition. 
◦ You can tell if your scanner has this feature if you see 

terms like “Searchable PDF” or “Text PDF” in the 
scanner file output settings. 
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• Push the spine of a book as flat as possible to eliminate 
gutter distortion and missing text. 

• Keep each scanned page to its own electronic page. 
◦ Do not scan two pages of a book at once. 

Ensure scans are free from: 

• Cut off text. 
• Crooked pages. 
• Shadows from the curvature of a book’s spine, dark 

gutters between pages. 
• Poor contrast. 
• Pages rotated 90 degrees or upside down. 
• Handwriting, highlighting, underlining, watermarks or 

stains. 
• Blurring. 

Use Optical Character Recognition: 
Run OCR on scanned documents as a first step toward 

creating accessible PDFs. To do so in Acrobat Pro: 

1. Open scanned PDF in Acrobat. 
2. Select Scan & OCR from Tools. 
3. Select Enhance Text. 
4. Select Recognize Text to amend the document or repair 

any text not automatically detected. 
1. Select Tools > Edit PDF. 
2. Select text elements and edit text as appropriate. 

From Webpage 

When wanting to save a permanent copy of a 
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website, do not use Print to PDF or Print > Save to 
PDF. 

To save a permanent copy of a webpage, use SingleFile to save 
complete webpages (including styles and images) as a single 
HTML file. Download the SingleFile Firefox Add-on, SingleFile 
extension for Chrome and Edge, or Safari extension. Anyone 
can open the saved file in any web browser. 

Another alternative to saving a PDF of a webpage is to use 
the Internet Archive’s Wayback Machine or Archive Today to 
create permanent copies of a webpage as it appears at the 
time of saving. Zotero also saves a permanent copy of 
webpages when possible and allows for sharing, although 
readers need Zotero installed on their device. 

If you absolutely must save a copy of a webpage as a PDF, 
use PrintFriendly as it creates tagged PDF files when exporting 
a webpage to PDF. To use PrintFriendly, install the browser 
extension or paste the URL in the PrintFriendly web interface, 
then select PDF. This will download a PDF copy of the webpage 
to your device. The PDF copy will still need to be evaluated and 
remediated to ensure it is accessible. 

Making Accessible PDFs 

Use the following resources to make PDFs accessible. 

One or more interactive elements has been 

excluded from this version of the text. You can 
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view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=37#oembed-1 

1. If starting from a scanned document, use the Scan and 
OCR tool. 

1. Select Recognize text and choose in this file. 
2. Open the File menu, choose Properties. 

1. Navigate to the Description tab. 
2. Enter a descriptive title. 
3. Move to the initial view tab and select Document title

in the Show menu. 
4. In the Advanced tab, choose a language for the 

document. 
3. Open the Tags pane and arrow through the tags tree. 
4. Select the Reading order pane to show an overlay number 

on each object. 
5. Select the Page thumbnails pane, select all pages, right 

click and select Page properties. 
1. Ensure Use document structure is selected under tab 

order. Click OK. 
6. Place your cursor at the beginning of the document and 

press Tab to verify tab order. 
7. Run the Accessibility checker. 

An interactive H5P element has been excluded from 
this version of the text. You can view it online here: 

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=37#h5p-163 

Remediating PDFs can be difficult and time-consuming. Some 
people do this work full-time and still encounter difficulty. 
Please contact assistivetech@langara.ca for more information 
about remediating PDFs. 
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Reading Order 

One of the most important elements requiring manual checks 
is the reading order of your document. 

Save your file before making any changes to the Order, 
Content, or Tags panes. Verify changes to the Order pane 
visually and on the Tags pane. Be aware that when changing 
the reading order of items in the Order pane, some content 
may “disappear” (YouTube video, opens in new tab) behind 
other content. 

To solve this issue: 

1. Open the Content Pane (View > Show/Hide > Navigation 
Panes > Content). 

2. The top of the list is the bottom visual layer of the 
document. 

3. Selecting an element in the Content pane highlights the 
item in the document. 

1. So, if text disappears behind a textbox for example, 
locate both the text and textbox. 

2. Click and drag–or cut and paste–the offending item to 
the top of the list. 

3. This should return the visual order to normal. 

Verify Reading Order: 

1. Open the Tags Pane (View > Show/Hide > Navigation 
Panes > Tags). 

2. Select the first tag at the top of the list. 
1. Use the down arrow to move through the list. 

1. You will see a visual highlight in the document 
when selecting each tag. 
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2. If you need to re-order the reading order, cut and 
paste the tag (we find clicking and dragging can be 
difficult in longer documents). 

3. Navigate to the Order Pane. 
1. Select Options. 
2. Select Show Reading Order Panel. 

1. This displays a number on each page element 
representing it’s reading order. 

3. Open the Content Pane. 
1. Arrow from top to bottom of content list. 
2. Verify that the visual order matches the reading 

order. 

Reading Order determines the order of items when 
the document is read aloud by assistive technology. 
Reading Order also affects how the document will 
reflow, such as when zoomed or viewed on a mobile 
device. Changing the reading order may affect the 
Content hierarchy and Tags order. Any changes to 
reading order must be checked in Content and 
Tags panes. 
The Content pane is a hierarchical view of the visual 
items within a PDF. Changing the order of content 
can alter the visual appearance of the document as 
well as the reading order of content. 
The Tags tree is a hierarchical view of the code that 
determines the structure of the document. The 
order of tags affects the reading order for assistive 
technology, such as screen readers. But can also 
influence the order in which users tab through links 
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or form fields. Changing the order of tags does not 
alter visual appearance of document. 
These additional concerns contribute significantly to 
the amount of time and expertise needed to make 
full accessible PDFs. 

Check Accessibility 

After you remediate your PDF, run the Accessibility Check tool 
again: 

1. Open PDF in Adobe Acrobat Pro DC 
2. Expand the Tools Pane 

1. If you do not see the Tools Pane, select View > Show/
Hide and click Tools Pane 

3. Click Accessibility 
1. If you do not see Accessibility, select More Tools, scroll 

down and select Accessibility 
1. Recommend to open menu and select Add 

Shortcut for future use 
2. You can also search for tools at the top of the Tools 

Pane 
4. Click Accessibility Check 

1. Click Start Checking 
1. The Accessibility Pane will open and show 

accessibility issues. Right-click to see further 
explanation and/or fix the issue directly 

Video demo: 
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One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=37#oembed-2 

Use Reflow or Export to Text export to verify accessible reading 
order. 

1. Select View > Zoom > Reflow, 
1. As you zoom in, content should reflow into a vertical 

column with no need for horizontal scrolling, 
2. Many PDFs will not reflow. Check the order of text via File 

(Acrobat on macOS) menu and select Export To > Text 
(Accessible). Save the file and view what text content is 
exported and how it is ordered. That is what and how 
assistive technology will read to a user (absent any 
interactives such as forms and image alternate text). 

Use Preflight tools to correct remaining tagging issues: 

1. Navigate to Tools > Print Production > Preflight, 
2. Select PDF Profiles, 
3. Expand PDF/UA, 
4. Select Fix problems in PDF tagging structure, 
5. Click Analyze and Fix, 
6. Save new copy. 

For advanced accessibility checks, use PAVE (online) or PAC 
2021 (Windows only). 
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Further Reading 

CreativePro’s 10 steps to accessible PDFs. 
Adobe guide to making accessible PDFs in Acrobat Pro. 
Adobe guide to Acrobat Pro Accessibility Check. 
List of Adobe Acrobat DC accessibility training guides. 
Adobe guide to OCR and editing scanned PDFs. 
Microsoft guide to exporting documents to PDF. 
Microsoft video guides to PDF accessibility. 
Web Accessibility in Mind Guide to PDF Accessibility. 
George Brown College in-depth videos of Adobe 
accessibility. 
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PDF Forms 

PDFs are a common format for fillable forms. PDF is likely the 
best choice for a form that needs to be digitally signed or 
printed off for analog entry. For forms that do not require 
signing or are not to be printed, consider using MSForms. 

On this page: 
Best Practices  Acrobat Prepare Form  Initial Accessibility 

Checks  Automated Accessibility Check 

Best Practices 

1. Ensure form has clear instructions. 
2. Create meaningful visual labels for all fields, place labels 

adjacent to corresponding fields. 
3. Use tooltips. 
4. Include meaningful group labels where appropriate. 
5. Indicate required fields and field constraints (such as 

specific date format). 
6. Provide help and hints. 

How to create a PDF form in Acrobat. 
For additional information, consider WebAIM’s guide to form 

tags. 

Acrobat Prepare Form 

Create form layout in Word or InDesign and export as an 
accessible PDF document. Open in Acrobat Pro DC. 
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1. Select Tools tab and find the Forms & Signatures section. 
2. Select Prepare Form tool and click Add or Add Shortcut. 
3. The Prepare Form tool will appear in the right side tools 

pane. 

Prepare Form Tool 

To add form fields: 

1. Click Prepare Form tool 
1. Uncheck/leave uncheck This document requires 

signatures. Add signature lines within the form if 
needed. 

2. Ensure Form field auto detection is ON. 
3. Select Start. 

1. The document is in Forms Editing Mode until 
the Close button in the top right is selected. 

To delete a form field: 

1. With Prepare Form tool open: 
2. Right-click form field to be deleted 
3. Select Delete 

Manually Create Forms 

1. Open Prepare Form tool 
2. Select form field type from top centre toolbar 
3. Click in document where you want to place form field 
4. Type a meaningful, unique name 

1. This is not a name that will display in the document, 
that remains the text created in the document beside 
the field. Unique field names are required because 
Acrobat will apply the same Tooltip (discussed below) 
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to all fields with the same name. This will lead to 
confusion and inaccessibility 

5. Check Required if applicable 
1. Note: checking required only adds a red outline 

around the field. A better practice would be to add the 
“(Required)” to the visible form label (the text in the 
original document) and add “(Required)” to the tooltip 
wording 

6. Select All Properties 
1. This dialog presents all the options for each field 
2. Options include: border, font style and size, position, 

alignment, relationship to other fields (such as a 
group of radio buttons), data restrictions such value 
range or format requirements 

7. On the General tab the Tooltip field is required for full 
accessibility as the Tooltip is read to screen readers. 
Without a useful, unique tooltip such as “type your age”, 
screen reader users would hear something like “type a 
text” or “text input” and it may not be clear which field 
they are completing 

8. You can also access the Properties dialog by right-
clicking a field and selecting Properties 

1. Or when a field is selected press CTRL (CMD on 
macOS)and i 

Add Tags 

Form fields need to be tagged: 

1. Open the Tags pane 
2. Select Options button 
3. Choose Find 
4. In the Find Element dialog, choose Unmarked 

Annotations 
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5. In Type: select Search Document 
6. Click the Tag Element button 
7. Select Form in Type: dropdown and click Ok 
8. Advance to next field 

Verify Tab Order 

1. With Prepare Form tool open 
2. Select More beside the tool icon and select Show Tab 

Numbers 
1. A number appears in the top left of each field 

indicating its tab order 
3. Examine the Fields in the right hand pane, this order 

reflects the tab order 
4. Drag and drop fields to reorder 

Begin at the top of your form and press Tab to move between 
fields and verify proper order. 

Once you have added your form fields, mark placeholders 
(such as a blank line for a signature) as artifacts. 

Acrobat will likely group your placeholder text (such as 
options for checkboxes) as one paragraph. This will disrupt 
reading order. To avoid this, open the Tags pane, highlight text 
individually, open the menu in the Tags pane and 
choose Create Tag from Selection… and 
choose Paragraph. This is a simple way to split text and place 
your form fields in between. 

Initial Accessibility Checks 

To assess the accessibility and usability of your form, check: 

PDF Forms  |  305



Manually 

1. Use the Tab key to move around the form. 
1. Radio buttons should be grouped, meaning you can 

Tab to the first radio button and then use the arrow 
keys to navigate around that group. 

2. Checkboxes cannot be grouped but should have a 
consistent tooltip (tooltips provide directions for the 
required input of the field to assistive technology) to 
give indication of their grouping. 

3. Text fields should be in the same order they visually 
appear. 

Tooltips 

1. Navigate to Tools (On main tab bar, via View > Show/
Hide > Tools Pane and then select More Tools at the 
bottom of the Tools Pane) 

1. Select Accessibility. 
2. Select Identify Form Fields OR Navigate to Tools and 

select Prepare Form. 
1. An overlay of the tooltip associated with each field 

appears. 
2. Additionally, the FIELDS pane lists all fillable fields. 

1. Use the FIELDS pane to reorganize the Tab 
order of the form. 

Text Fields 

1. Right click or double click on a fillable field. 
2. Select Properties > General. 

1. Each field must have a descriptive Name. 
2. A useful Tooltip field includes the title and short 
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instructions to complete the field. 
1. Tooltip is what is read out loud by a screen reader 

so it is very important. 
3. Repeat for each fillable field. 

Radio Buttons 

1. Click and drag over all radio buttons in a group to 
highlight them. 

2. Properties > General. 
3. Enter a name for the buttons in the Group Name field. 
4. Select each radio button individually. 
5. Properties > Options. 
6. Enter a description in the Radio Button Choice field. 

Check Boxes 

1. Select each check box individually. 
2. Properties > General. 
3. Enter the Name field with the question. 
4. Enter a short description followed by the text of the 

textbox as it appears on the document in the Tooltip field. 
1. Because Check boxes cannot be grouped like radio 

buttons, try to be consistent with your ToolTips such as 
“favourite food: cookies”, “favourite food: fish”, 
“favourite food: pizza”, etc. 

Tab Order 

1. Open Prepare Form tool. 
1. Click dropdown menu beside FIELDS list. 
2. Select Show Tab Number. 
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3. Rearrange tab order by clicking and dragging to 
correct order. 

1. This does not move the items on the document, 
only ensures screen readers will read the fields in 
the order you intended. 

Nesting 

<Form> tags should be nested within the text tag that the form 
field is associated with. 

Navigate to the Tags pane and cut and paste or click and 
drag appropriate form fields to ensure proper nesting. 

Missing Form Field 

You can add a single form field if you discover one missing 
during your checks: 

1. Navigate to Order. 
2. Open the Reading Order Panel. 
3. Click and drag to highlight over the desire form field area 

and select Form Field. 

Note, you will still need to ensure the reading order, tags, and 
tooltip for the field. 

Automated Accessibility Check 

1. Select Tools 
1. Accessibility > Accessibility Check or Full Check 
2. Right click on various errors for explanation and tips 
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for fixing the error. 
2. Read Out Loud will give an idea of how a screen reader or 

text-to-speech software will read your document 
1. Select View > Read Out Loud > Activate Read Out 

Loud 

A PDF with form fields will not reflow (by design), so do not use 
the Zoom > Reflow tool. 

Tab through your form once more to be sure. 
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Advanced PDF 

Ensure you have Acrobat Pro DC installed on 
your device as Acrobat Reader lacks the 
necessary features to make PDFs accessible. 
Save after every change made following the 
instructions below as Acrobat cannot undo 
many actions. 

On this page: 
Manual Tags  Types of Tags  Artifacts  Tables  Javascript 

Manual Tags 

View unmarked content: 

1. Open Tags pane. 
2. Open Options menu. 
3. Select Find. 
4. Select Unmarked Content from drop down menu. 
5. Select Search Document or Search Page. 
6. Select Find. 
7. Unmarked content will be highlighted in the document 

with a pink border. 
8. Tag content as needed. 
9. Select Next in dialog to move to next unmarked content. 

Delete empty tags: 

1. Open Tags pane. 
2. Open Options menu. 
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3. Select Delete Empty Tags. 

If your document has no tags, you must first generate a Tags 
Root 

1. Open Tags pane. 
2. Select Options menu. 
3. Select Create Tags Root. 

Create tag from selection: 

1. Open Tags pane. 
2. Choose Selection tool. 
3. Click and drag over the desired content. 
4. Select the Options menu in the Tags pane. 
5. Choose Create Tag from Selection. 
6. Select tag Type from drop down and select Ok. 

Edit tag type 

1. Open Tags pane. 
2. Right-click on tag. 
3. Select Properties. 
4. On Tag tab, choose appropriate tag in Type:  menu. 

To locate a tag in the document, select the tag in 
the Tags pane. A pink outline will appear around the content in 
the document. 

To locate a tag in the Tags pane: 

1. Choose the Selection tool. 
2. Highlight the content in the document. 
3. Select the Options menu in the Tags pane. 
4. Choose Find Tag from Selection. 
5. The tags tree will expand to show the highlighted tag. 
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Types of Tags 

Container elements are the highest level elements used to 
provide hierarchical grouping and structure of other elements. 

In a PDF, the containers are: 

• <Document> the root element is the highest level 
container. 

• <Part> can be used for a chapter or page to group other 
elements. 

• <Div> is a generic element to group others. 
• <Art> is the article element used to group a distinct 

section within a larger element. 
• <Sect> is the section element used to group elements 

within a larger element. 

To add heading tags: 

1. Open the Tags pane. 
2. Use the Selection tool to highlight the heading in the 

document. 
3. Open the Options menu in the Tags pane and 

select Create Tag from Selection. 
4. Select the appropriate tag from the drop down menu 

(Heading Level 1 through 6) and select Ok. 
1. Remember to use a nested, hierarchical heading 

structure without skipping any heading levels. 

<P> should be used for all regular text that is not a heading. 
To create a <P> tag: 

1. Choose the Selection Tool. 
2. Highlight the paragraph. 

312  |  Advanced PDF



3. Select the Options menu in the Tags pane. 
4. Select Create Tag from Selection. 
5. Select Paragraph from the drop down and choose Ok. 

PDF lists have the following tags: 

• <L> List 
• <LI> List item 
• <Lbody> List Body 
• <Lbl> Label 

To tag a list: 

1. Open Tags menu. 
2. Highlight the number or bullet (not the list item text, just 

the number or bullet point). 
3. Open the Options menu and select Create Tag from 

Selection. 
4. Select Label from drop down and press Ok. 
5. Select the contents of the first list item (not the number or 

bullet, just the text of the item). 
6. Open Options menu and select Create Tag from 

Selection. 
7. Select List Item Body from drop down and press Ok. 
8. In the Tags pane, right-click the Tags Root and select New 

Tag. 
9. Select List Item from the drop down menu and press Ok. 

10. Drag and drop the Label and List Item Body tags as 
children of newly created List Item tag. 

11. Repeat steps 2 through 10 for remaining list items. 
12. Right-click Tags Root and select New Tag. 
13. Choose List from drop down menu and select Ok. 
14. Hold CTRL(CMD on macOS) and click all of the List 

Item tags (created in step 10). 
15. Drag and drop as children of List tag (created in step 13). 
16. Double check the order of the tags match the visual order 
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of the document. 

To add link text: 

1. Highlight link text. 
1. Right-click and select Create Link… 
2. Choose options such as Link Action and Appearance. 
3. Choose Next. 
4. Enter URL in field and choose Ok. 

2. Open Tags menu. 
3. Open the Options menu and select Find. 
4. Choose Unmarked Links from the drop down menu. 

1. Select Search Page or Search Document radio button. 
2. Press Find. 

5. The first untagged link will be outlined in pink. 
6. Select Tag Element button. 
7. Select Link from drop down and press Ok. 
8. A <Link> tag and Link – OBJR tag appear in the tags tree. 
9. Select the Link tag in the Tags pane. 

10. Use the Selection tool to highlight the link text in the 
document. 

11. Open the Options menu in the Tags pane and 
select Create Tag from Selection. 

12. The link text and Link – OBJR should both now be tagged 
as children of the Link tag. 

To add footnotes and references: 

1. Reading Order Tool. 
2. Draw a box around the superscript or link text. 
3. Click Reference or Note button. 
4. Begin from step 2 above. 

Set the language of your PDF 
using File > Properties > Reading Options. Setting the 
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language of the document and its parts tells assistive 
technology which language to expect and speak. 

However, if the language of part of the document is in a 
different language or multiple languages you must specify the 
language of those parts. For a <Sect> or entire <P> you can set 
the language property. For something smaller than a <P> you 
will have to tag the content in <Span> and then change the 
language of that <Span> tag. 

1. Open the Tags Pane 
2. Right-click the relevant tag and select Properties 
3. In the dialog window, select the Tag tab, choose the 

appropriate Language from the dropdown and then 
select Close 

To change the language of one sentence: 

1. Within a previously tagged <P> open the Tags pane and 
then Options menu. 

2. Select New Tag… and choose Span from the drop down 
and select Ok. 

3. In the document, highlight the text with the language 
change. 

4. Right-click the newly created <Span> in the Tags pane. 
5. Select Create Tag from Selection. 
6. Drag and drop the <Span> to the correct order in the Tags 

tree. 
7. Right-click the <Span> tag and select Properties. 
8. On the Tag tab, select the Language from the drop down 

and choose Close. 

Images: 

1. Open the Order pane. 
2. Open the Options menu and select Show reading order 

panel. 
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3. Click and drag to draw a box around the image and 
select Figure in the Reading Order Panel. 

4. Open the Tags pane. 
5. Right-click on the Figure tag and select Properties. 
6. On the Tag tab, enter alt text in the Alternative Text field. 

A table of contents is exceptionally helpful for longer 
documents and is a recommended practice for any document 
longer than 5 pages. Each line of the table of contents should 
link to that point of the document. 

To create a table of contents: 

1. Highlight link text. 
1. Right-click and select Create Link… 
2. Choose Go to a page view. 
3. Choose Next. 
4. Move to document location and choose Ok. 

2. Open Tags menu. 
3. Open the Options menu and select Find. 
4. Choose Unmarked Links from the drop down menu. 

1. Select Search Page or Search Document radio button. 
2. Press Find. 

5. The first untagged link will be outlined in pink. 
6. Select Tag Element button. 
7. Select Link from drop down and press Ok. 
8. Repeat with each line of the table of contents. 
9. Create a TOCI tag for each line. 

1. Tags pane > New Tag > Table of Contents Item > Ok. 
10. Move each link and link text tag into each TOCI tag. 
11. Highlight the first table of contents line. 
12. Right-click the first link tag in the Tags pane and 

choose Create Tag from Selection. 
13. Repeat with each line move down the tags tree of link 

tags. 
14. Create an empty Table of Contents tag. 
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1. Right-click tags root > New Tag > Table of 
Contents > Ok. 

15. Hold Control and click to select all TOCI tags and drag and 
drop under TOC tag as nest children. 

1. Verify order. 
16. Set table of contents title as an H1. 

1. Highlight “Contents” or “Table of Contents” or 
whatever text precedes the table of contents. 

2. In the Tags pane, select the Options menu, 
choose Create Tag from Selection. 

3. Choose Heading Level 1 and select Ok. 
4. Place <H1> tag above the table of contents, at the 

same hierarchy level. 

Bookmarks are also essential to PDF accessibility. They do not 
require tagging. To add bookmarks: 

1. Select the Bookmarks button on the left. 
2. Move in the document to where you would like to place a 

bookmark. 
3. Use the Selection tool to select the area of the page to be 

bookmarked. 
1. For example: click an image or highlight text. 

4. Use the New bookmark button in the Bookmarks pane. 
5. Ensure bookmarks are in logical order. 

Read more about PDF bookmarks 

Artifacts 

If you want screen readers to ignore certain content, such as 
decorative images, you must mark those items as Artifacts. 

To mark objects as an artifact: 
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1. Open Reading Order Tool. 
2. Click and drag zone around element. 
3. In the Reading Order Tool select Background/Artifact 

button. 
4. This removes the item from the tags tree. 

Or use the tags pane: 

1. Open the Tags pane. 
2. Right-click the content, not the tag icon, in the tags tree. 
3. Select Change Tag to Artifact. 

To show artifact tags: 

1. Navigate to the Tags pane and select the options menu. 
2. Choose Find… 
3. Select Artifacts in dropdown (selected by default). 
4. Choose Search Page or Search Document. 
5. Select Find. 

Note: InDesign often exports excess tags. In Acrobat, use the 
Preflight tool to remove them: 

1. Under Tools, choose Print Production. 
2. Select Preflight. 
3. Select the wrench icon and under Document select Mark 

all non-structure elements as artifact. 
4. Click Fix. 

Tables 

Tables in PDFs require special attention to ensure they are 
accessible. 

PDF Tables need the following tags: 
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• <Table> 
• <TR> table row 
• <TH> table header 
• <TD> table data 

To tag a table properly, you must designate: 
Header cells: 

1. Use the Selection tool to select the first header cell. 
2. Open the Options menu in the Tags pane. 
3. Select Create Tag from Selection. 
4. Select Table Header Cell from drown down menu and 

select Ok. 
5. Repeat above steps for all header cells. 

Data cells: 

1. Use the Selection tool to select the first data cell. 
2. Open the Options menu in the Tags pane. 
3. Select Create Tag from Selection. 
4. Select Table Data Cell from the drop down menu and 

select Ok. 
5. Repeat for all other data cells. 

Row tags: 

1. Create the number of required empty row tags. There 
needs to be a <TR> table row tag for each table row, 
including header row. 

2. In the Tags pane, open the Options menu and select New 
Tag. 

3. Choose Table Row and select Ok. 
4. Hold Shift and click to select all cell tags in the first row. 
5. Drag and drop into the first Table Row tag (created in step 

13), nested as children. 
6. Repeat for all rows. 
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Table tag: 

1. Create a Table Tag. 
2. In the Tags pane, open the Options menu and select New 

Tag. 
3. Choose Table and select Ok. 
4. Hold Shift and click all the <TR> table row tags. 
5. Drag and drop into the Table tag (created in step 19), 

nested as children and in logical order. 
6. For complex tables or to add context, provide a description 

of the table in the Alternative Text field by right-clicking 
the Table tag, selecting Properties, and moving to the Tag 
tab. 

Complex Tables 

Tables with split cells, merged cells, or cells that span multiple 
rows or columns can be difficult for assistive technology to 
interpret. Best practice is to create simple tables even if you can 
create a complex table that technically adheres to accessibility 
standards. To make tables accessible: 

1. Open the Order pane. 
2. Select the menu and choose Show reading order panel. 
3. Select the table and select Table Editor button on the 

Reading Order panel. 
4. Right-click on spanned cell and select Table Cell 

Properties… 
5. If it is a header ensure Header Cell radio button is selected. 

1. Use the Scope: dropdown to select the appropriate 
designation (Row, Column, or Both). 

6. In the Attributes section enter the Row span and Column 
span to indicate the number of rows or columns spanned 
by the merged/spanned cell. 
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7. Click Ok and Yes to any warning messages. 

Javascript 

You can add Javascript to PDF. This may prove useful for certain 
forms. 

To create fillable text fields that include existing lines for 
printing and filling by hand, use one of the following methods 
to ensure accurate text entry. 

To create a multiline text field: 

1. Create a multiline text field spanning all lines on form. 
2. Right-click > Properties. 
3. Format tab. 
4. Select Custom in Select format category menu. 
5. Custom Format Script. 

1. Use Edit button to open Javascript editor. 
2. Paste: 

1. var field = event.target;if (field.value == 
field.defaultValue) {field.fillColor = 
color.transparent}else {field.fillColor = color.white} 

3. Press Ok. 
6. Press Close. 

To create a single line text field: 

1. Create a text field for each line. 
2. Select first text field. 
3. Right-click and select Properties. 
4. Move to Appearance tab and set an absolute font size 

(minimum 11). 
5. Move to Options tab and uncheck Multi-line and Scroll 
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long text. 
6. Move to Format tab. 
7. Select Custom in Select format category menu. 
8. Custom Keystroke Script. 

1. Use Edit button to open Javascript editor. 
2. Paste: 

1. if ( event.fieldFull || event.willCommit ) 
this.getField(“*name of nextfield to continue 
in*”).setFocus(); 

9. Repeat 3-8 for each subsequent field, ensuring target field 
is named correctly. 

You may also wish to include a clear fields button: 

1. Add a visible text label reading “Clear Form”. 
2. Place button in form next to “Clear Form”. 
3. Select All Properties link. 
4. On General tab type a unique name (“Clear form”) and 

tooltip (“Click to clear all form fields”). 
5. On Appearance tab set font size to 14. 
6. On Options tab navigate to Behaviour dropdown and 

choose Push. 
7. Under State options and select Up. 
8. Type “Clear form” in Label field. 
9. Navigate to the Actions tab. 

10. In the Select Trigger drop down, choose Mouse Up. 
11. In the Select Action drop down, choose Run a Javascript

and press Add button. 
12. In the Javascript editor, paste: 

1. var MyTitle = “Clear Form Confirmation”;var MyAlert = 
“Clear all form fields?\n\nThis action cannot be 
undone. Proceed?”;if (app.alert({cMsg: MyAlert, nIcon: 
1, cTitle: MyTitle, nType: 2}) == 4){this.resetForm();} 
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EPUB 

EPUB documents give extraordinary control 
and customization options to readers. 

EPUB documents allow readers to: 

• Change background colour 
• Change font style and size 
• Add bookmarks and highlights 
• Navigate by table of contents 
• Pick up where they left off 
• Change spacing and alignment 
• Use text to speech 
• Go to page using source (physical book) page numbers, 

regardless of how EPUB displays material on device 
◦ No need to convert page numbers between physical 

and digital copies of book 
• Move between chapters or sections 

EPUB documents automatically reflow, so when a reader 
zooms in (or reads a document on a small screen) there is no 
need for horizontal scrolling. Making a PDF reflow is possible 
(and results may be inconsistent) but requires additional work 
and knowledge. 

EPUB documents can contain multimedia, such as audio 
and video files and interactive elements like links. 

EPUBs are very secure. EPUB is a format for distributing a 
final version. EPUBs are not meant for documents that will 
be changed by another party; they are for consumption only. 
When applicable, prefer EPUBs over PDFs for sharing final 
versions of material. 

The simplest way to make an EPUB file is to export a Word 
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document using WordToEPUB from The DAISY Consortium. 
EPUB files can be made from InDesign as well. 

EPUB Readers 

There are a number of free EPUB readers: 

1. Google Play Books 
2. Apple Books 
3. Thorium Reader (desktop) 
4. Calibre (desktop) 
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Excel 

Microsoft Office includes built-in 
tools to assist you in making 
accessible documents. This chapter 
includes best practices and 
instructions to create accessible Excel 
spreadsheets. 

On this page: 
Document Properties  Accessible Font  Spreadsheet 

Structure  Alternative Text  Images and Graphics 
Hyperlinks  Tables  Additional Excel Features  Formats to 

Avoid  Accessibility Checker  Sharing  Further Reading 

Document Properties 

The document title is announced to assistive technology and is 
much more pleasant and informative than the file name (but 
allows you to retain your file naming conventions). Other fields 
are useful but not required. 

Document Title 

To add a document title: 

1. Navigate to File > info. 
1. On MacOS: File > Properties > Summary tab. 

2. Enter a descriptive title in the Title field. 

This cannot be done in Office Online. 
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Accessible Font 

For Excel spreadsheets: 

• Use sans-serif or simple serif font, size 11 or greater 
◦ Size 9 is acceptable for foot/endnotes or captions 

• For PowerPoint, use font size 18 minimum 
• Use an accessible colour 

◦ Font must have a contrast ratio of at least 4.5:1 against 
the background 

• Left-align text 
• Use built-in tools for spacing and alignment 

To set font colour: 

1. Navigate to the Home tab. 
2. Select Font Colour. 
3. Click Automatic. 

If your document has hard-to-read text contrast, the status bar 
will indicate Accessibility: Investigate. Go to the Review tab 
and click Check Accessibility button. Under Warnings the 
hard-to-read text will be noted with a dropdown menu to 
change the font color. 

• Older versions of Word’s Accessibility Checker will not 
catch contrast issues. 

• Consider checking your colours with WebAIM’s Contrast 
Checker if you are unsure. 

Do not use colour as the only means of communication. 
Visit the accessible colour chapter of this Pressbook for more 

information. 
To set text alignment: 
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• Use left-aligned text for languages that read to left to 
right, use right align for languages that read right to left. 
◦ Set alignment in the Paragraph tools on 

the Home tab. 
• Avoid justified alignment as it can create excessive blocks 

of white space when zoomed and can create ‘rivers of 
white space’ which are gaps that appear to run through a 
paragraph due to coincidental alignment of spaces. 

• Use at least 1.5 line spacing. 

Spreadsheet Structure 

Providing structure to spreadsheets is essential for assistive 
technology, but help all readers navigate your data efficiently 
and understand relationships between topics. 

Styles (Styles group > Headings and Titles) in Excel have no 
semantic meaning like they do in Word, they are only 
decorative. Feel free to use styles, but also include textual cues 
to indicate meaning and importance. 

Excel structure best practices: 

• Include white space around the text in the template, so it’s 
easier to read. 

• Ensure appropriate row height: Home > Format > Row 
Height. 

• Ensure appropriate column 
width: Home > Format > Column Width. 

• Use accessible colour contrast. 
• Use 12 point or larger text (Home > Font Size). 
• Include worksheet names and table titles. 

◦ Right-click on sheet and select Rename. 
◦ Give each sheet a unique, meaningful title. 
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Microsoft guide to finding accessible templates for Office 
products. 

Floating elements such as charts, graphs, or images are read 
by assistive technology in the order the element was added to 
the sheet. However, the reading order can be amended: 

1. Navigate to Home. 
2. Select Find and Select. 
3. Choose Selection Pane. 

1. The reading order is from the bottom of the list to the 
top. 

2. Click and drag items in the Selection Pane to the 
correct order. 

1. Moving items in the Selection Pane does not 
change the visual layout of items on the sheet. 

Sheet Names 

Each spreadsheet appears as a tab within an Excel workbook. 
The default name is Sheet 1. Provide sheets with descriptive 
names to aid navigation and help readers draw connections 
between information. To change a sheet’s name: 

1. Right-click the sheet’s tab. 
2. Select Rename. 
3. Type a descriptive and unique name that describes the 

sheet’s content. 

Alternative Text 

Assistive technologies employ alternative text (alt text) 
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attached to images to inform users of the context and purpose 
of images and visual elements. Alt text is a text alternative to 
non-text content to ensure all users can access information. 

When including images in Excel: 

1. Right-click the object. 
2. Select Edit Alt Text… 
3. Enter a concise text-equivalent of the image or 

select Mark as decorative. 

However, when adding a chart or graph to Excel: 

1. Right-click the object. 
2. Select Edit Alt Text… 
3. Enter a broad description of the chart or graph and make 

reference to the equivalent tabular data. 
4. Include the data table immediately following. 

Review this Pressbooks’ chapter on Alternative Text for more 
information. 

Include table data for charts. 
Ensure embedded media has text equivalents. Videos must 

have closed captions and audio must have a transcript. 

Images and Graphics 

Apart from adding effective alt text to images, there are a 
few additional considerations for visual elements in Office 
documents. 

To add a chart in Excel: 

1. Select data, go to Insert and select chart type desired. 
2. Add a descriptive, unique Chart title. 
3. Select chart, go to Design > Add Chart Element > Axis 

Titles. Select Primary Horizontal or Primary Vertical and 
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type a descriptive title for the axis. 
4. Select chart, go to Design > Add Chart Element > Data 

Labels > Select appropriate label type for clarity. 
5. Select horizontal or vertical axis, go to Format > Current 

Selection > Format Selection. From the Format Axis pane, 
adjust axis type, axis crosses, position, tick marks, label 
position, interval, and number format for maximum 
legibility. 

6. Ensure colour is not the only way to differentiate chart 
data. Consider using symbols or dots on line graphs or add 
a text legend to a bar chart, for example. Try previewing 
your document in greyscale (via print preview) to 
understand how problematic it is to rely on colour alone. 

7. Add a legend by navigating to Design > Add Chart 
Element > Legend. 

8. Ensure chart elements have sufficient contrast. Change 
chart shape or line colour by selecting the shape 
> Format Data Point > Fill and Line > Fill > Color > More 
Colors. 

9. Ensure font is sans serif, 12 point or larger, and has 
sufficient contrast (4.5:1). Home > Font, Font Size, Font 
Colour to adjust font. 

10. Ensure chart data is available in tabular form as well, 
preferably directly following the chart itself. 

1. When following this practice, Right-click the chart. 
2. Select Edit Alt Text… 
3. Mark the chart as decorative or reference location of 

table data. 
11. Learn more about creating charts and learn 

about different chart types in Office. 

Floating elements such as charts, graphs, or images are read by 
assistive technology in the order the element was added to the 
sheet. However, the reading order can be amended: 
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1. Navigate to Home. 
2. Select Find and Select. 
3. Choose Selection Pane. 

1. The reading order is from the bottom of the list to the 
top. 

2. Click and drag items in the Selection Pane to the 
correct order. 

1. Moving items in the Selection Pane does not 
change the visual layout of items on the sheet. 

For a chart or graph, provide data in table form beside the 
element. If size and spacing is a concern, place the data in 
another sheet and provide a link near the floating element. 

To link within Excel: 

1. Select the cell in which you wish to place the link. 
2. Navigate to Insert > Links group > Link or right-click the 

cell and select Link or select the cell and 
press CTRL+K (CMD+K on Mac). 

3. Select Place in This Document and enter the cell 
reference (ex. A1), ensuring you have selected the correct 
sheet. 

1. In the Text to Display field, enter descriptive text to 
explain the link’s purpose. 

4. Click Ok. 
5. Repeat the process to provide a link back to the object. 

Read more information on links in Excel. 

Hyperlinks 

Create meaningful hyperlink text. 

• Avoid vague instructions like “see” or “click here” or “read 
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more”. 
◦ Not only are those not helpful out of context, but self-

describing links may help you locate your resource if 
the URL changes. 

• Do not paste URLs as hyperlink text. 
◦ If URLs must be included, provide self-describing 

hyperlink text and format URLs as normal text with no 
link attached. 

• Use default link styling (blue, underlined text). 

Tables 

Tables are useful for organizing data. Properly built and 
formatted tables are completely accessible. 

In Word and PowerPoint, navigate to: 

1. Insert tab. 
2. Table. 
3. Insert Table. 
4. Indicate number of columns and rows and press Ok. 

1. You can add columns and rows later. 

Set a header row/column: 

1. Click anywhere in your table, 
2. Select Table > Table Design tab > click Header 

Row (or Header Column, if applicable) checkbox, 
3. Select Banded Rows or Banded Columns for a landscape 

document, 
4. Accessible tables only have one header row, one header 

column, or both. 
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Right-click on table and select Table Properties for advanced 
table options via the table properties dialogue. 

Navigate to Table Layout, select Repeat Header Rows to 
repeat headers across page breaks. 

In some instances it may make sense to add alt text to a table 
as a summary. To do so: 

1. Navigate to Table Properties. 
2. Select the Alt Text tab. 
3. Add a Title and a Description. 
4. Click Ok. 

Convert Excel data into a table: 

1. Select the data to be included in the table. 
2. Insert > Table. 
3. Double check select cells are correct and check My table 

has headers. 
4. Select Ok. 
5. Select anywhere in the table, use Design > Table Name 

and give the table a meaningful title. 

Consider putting tables on separate worksheets. If you place 
multiple tables on the same worksheet, leave a blank row 
between each table. All tables should start with a title in 
column A. 

Use accessible table designs: 

1. Select the table and go to Design. 
2. Select the features you want (Header Row, Banded Rows, 

or First Column). 
1. A Header Row or Header Column or both are required 

for an accessible table. 
3. To show all available table styles, select More or the 

dropdown arrow. 
4. Most accessible tables will be Medium styles with strong 
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contrasting colors. 

Best practices: 

• A concise, descriptive table title helps with context and 
organization. 

• Do not use nested, merged, split, or unnecessary blank 
cells. 

• Ensure cells have adequate padding and margins. 
• Do not use coloured cells or text alone to indicate 

meaning. 
• Do not use tables with invisible borders to format layout. 
• Office accessibility checker does not note table errors. 

◦ Click in the top left cell, then use the Tab key to see 
ensure your table reading order is logical and 
consistent. 

Additional Excel Features 

Best practices: 

• If you have no data to enter in cell A1, use it for a title or to 
indicate the number of sheets in a workbook. 
◦ For a workbook with many sheets, the first sheet 

should be used a summary and index with links to 
other sheets. 

• Avoid merged cells in tables. 
◦ However, an acceptable practice is to add a descriptive 

title above a data set by merging the cells and 
centering the text. 

◦ Cell A1 is the best place for a description of a sheet. 
• Avoid blank cells for formatting or alignment purposes 

(adjust column/row width and height instead). 
◦ A single blank row or column is allowed where 
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appropriate. Best practice would be to include the text 
“No data” in blank cell. 

• Ensure cell has appropriate format by number type. 
◦ Home > Number drop down > select relevant number 

formatting (date, currency, time, etc.). 
• Ensure appropriate decimal place 

from Home > Numbers group > Increase 
Decimal or Decrease Decimal. 

• Colour, such as conditional highlighting, may be used but 
should be accompanied by a text equivalent indicating 
meaning. 

• Comments are accessible and a great way to convey 
information or messages. 

Hide unused cells: 

1. Select the first column cell to be hidden. 
2. Press Shift and CTRL (CMD on Mac) and Right Arrow key. 
3. Right-click and select Hide. 
4. The process is the same to hide unused rows, by selecting 

the first row to be hidden. 
5. Press Shift and CTRL (CMD on Mac) and Down Arrow key. 
6. Right-click and select Hide. 

However, avoid hiding cells in the middle of data. If you must, 
add a comment indicating so. Excel comments are accessible 
and a great way to communicate with readers. 

An additional method would be to include an “End of Table” 
message after the last row of data. The text can be in white 
as this is only a hint to assistive technologies that the table is 
complete. 

Multiple data sets: 

• Multiple sets of data should be split into separate sheets 
• Sheet names should be meaningful and unique 
• Each sheet should follow the same accessible formatting 
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Within a worksheet, you may group data for easier navigation. 
Select the data you want include and select Formulas > Define 
Name. Enter a descriptive name and double check the selected 
cell range, then click Ok. This allows users to press CTRL + G to 
quickly jump to different groups of data. 

Cell padding: 
Ensure appropriate cell padding by adjusting column width 

and row height. 

1. Right-click on row or column label. 
1. Select Column Width… and/or Row Height… to adjust. 

2. Or in Home > Cells group > Format dropdown. 
1. Select Autofit Row Height and/or Autofit Column 

Width. 

• Text should not overflow cells. 
◦ Adjust column width or use text 

wrapping: Home > Wrap Text button. 

Named regions and header names: 
Using the Excel Names feature, it is possible to name a range 

of cells in such a way that header cells are spoken along with 
the value of the cell. This allows a person using a screen reader 
to understand the structure of a table more clearly. This is only 
necessary for more complex or lengthy sets of data. 

Formats to Avoid 
The following formatting and object types are not 

communicated to assistive technology or present significant 
barriers to some users: 

• Strikethrough 
• Highlighting 
• Dropcap 
• Word Art, Smart Art, text effects 
• Ungrouped related shapes 
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• Watermarks 
• Symbols, except for the following safe characters: 

When converting data to a table, keep in mind the contrast of 
the default styles. Only the White, Light Blue, and Blue styles 
in the Light and Medium categories have sufficient contrast 
between cell shading and font colour. All of the styles in the 
Dark category have sufficient contrast 
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Accessibility Checker 

Use Office products’ built-in accessibility checker to check for 
common issues. Note, these tools may not catch all possible 
accessibility issues. 

The Microsoft Accessibility Checker report can be used to 
find common errors like missing image ALT text, merged cells 
and other issues in an Excel document. Select Review > Check 
Accessibility. The accessibility pane will show errors, warnings, 
solutions, and tips. 

In the Accessibility pane select Keep accessibility checker 
running while I work checkbox to see a realtime accessibility 
message in the bottom status bar. Click Accessibility: 
Investigate at anytime to open the Accessibility pane. 

Like any automated tool, Office’s accessibility checker will not 
catch any and all accessibility issues. Here is a summary of what 
it does look for and how well it catches those issues: 
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Element checked Reliability of checker 

Structure and use of heading 
styles 

Poor. 

Will show if there are no 
headings on a long 
document but doesn’t flag 
issues on shorter 
documents. A single 
heading is enough to pass 
the checker even though 
the document remains 
inaccessible. It cannot test 
the logic of the heading 
structure. 

Colour 

Moderate. 

Can find poor colour 
contrast but cannot tell if 
colour has been used as a 
sole indicator for 
information. 

Use of images 

Moderate. 

Will find images that have 
neither Alt text, nor are 
marked as decorative as 
well as those where the Alt 
text is just the file name. 
But it cannot identify 
whether the Alt text is 
appropriate or even 
meaningful. It will find 
images that are not in line 
with the text. In-line images 
may not be as aesthetically 
pleasing but they are easier 
for screen readers to find. 

Links 

Poor. 

It does not check for link 
text. 
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Plain English 

Poor. 

It does not check for this, 
but you can check yourself 
by switching on the 
readability stats as 
described in the section on 
Understandable Content. 

Tables 

Fair. 

It finds whether the table 
has the Header row marked. 
It may warn if tables have 
split or merged cells. 

Miscellaneous 

Poor. 

Does not check text 
justification, videos for 
captions, or form labels. 

1 

Read more about checking for accessibility issues with the 
Office Accessibility Checker and learn about Office Accessibility 
Checker rules and messages. 

Sharing 

Best practice is to share material in advance of presentation or 
class. 

◦ This allows users to check for barriers beforehand 

1. This table is adapted from work originally developed by AHEAD and 
Alistair McNaught and is made available under a CC BY-NC-SA creative 
commons license. 
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◦ All users can take additional, in-depth notes and 
understand terminology and names with greater 
comprehension 

◦ Users that experience barriers can zoom in or adjust 
the documents to their viewing preferences 

Excel documents have various options for protecting your 
Excel workbook, sheet, or part of your spreadsheet. Choose the 
appropriate level of protection. 

Export to PDF 

Excel documents can be exported to PDF, however the amount 
of time and expertise required to create an accessible PDF 
of an Excel document means all other avenues should be 
pursued first. 

Best practice is to share the Excel file directly. You can protect 
an Excel file to prevent changes. 

Further Reading 

Microsoft outlines  best practices to make documents 
accessible. 
Make your excel Excel documents accessible. 
Contact assistivetech@langara.ca for further 
information or assistance. 
Microsoft videos on accessible Excel spreadsheets. 
General Microsoft documentation on accessible 
Excel spreadsheets. 
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Learn about creating charts using Excel. 
WebAIM’s guide to Excel is a useful guide. 
Use this online tool to convert Excel tables to HTML. 
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H5P 

H5P (HTML5 Package) is an 
open source tool to create 
interactive content. As with 
any content, follow the basic 
accessibility essentials. 

H5P has many different 
content types and this chapter will focus on general 
accessibility features and a few special cases. 

On this page: 
Best Practices  Text Formatting  Alternative Text  Closed 

Captions  Specific Elements  Further Reading 

General Accessibility Best 
Practices 

Provide all H5P elements with unique, descriptive titles. 

Check colour contrast manually using ColorZilla browser 
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extension and the WebAIM Contrast Checker. Read more 
about colour contrast. 

Write in plain language. 
Use accessible hyperlinks that describe the link destination. 

To add hyperlinks in H5P text content: 

1. Highlight text to be linked 
2. Click the Link tool or press Control (Command on macOS) 

and k 

3. Paste URL in URL field and select Ok. 
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Text Formatting 

Highlight font and use Paragraph Format menu add headings. 

Alternative Text 
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When adding an Image, enter a description in the Alternative 
text field. Or, check Decorative only for decorative images. 

When using the Collage element, select i (Image settings) and 
enter alternative text. 
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The Collage element does not support marking images as 
decorative. But, given the visual nature of the Collage element, 
all Collage images should have alternative text. 

Learn more about alternative text. 

Closed Captions 
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To add closed captions to a Video (included in Interactive Book, 
Column, or Course Presentation): 

1. Expand the Accessibility accordion. 
2. Type the language of the captions in Track label. 
3. Change Type to Captions. 
4. Click Add and upload a WebVTT file. 

To add captions to an Interactive Video: 

1. Expand the Text tracks accordion. 
2. Type language of captions in Track label. 
3. Expand Subtitles accordion. 
4. Select Add to upload a WebVTT file. 

Use happyscribe caption converter to convert .SRT caption type 
to .VTT file. 

Learn more about closed captions. 
To use other platforms to generate captions: 

An interactive H5P element has been excluded from 
this version of the text. You can view it online here: 

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2303#h5p-155 

Specific Element Considerations 

There are some H5P types that require special attention when 
used: 
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Page and Interactive Book 

The Page (formerly known as 
Column) and Interactive 
Book types have a content 
type called Row. Rows allow 
for multiple content types 
(images, text, quizzes, etc.) to 
be grouped and aligned 
horizontally. This helps with 
organization and reading 
order. Page and Interactive 
Books allow creators to add 
as many Rows as desired. A row can hold 1-4 columns. Column 
width can be set manually as a percent of 100. If not set, or in 
event of discrepancy, H5P will divide columns 50-50, 33-33-33, 
or 25-25-25-25 depending on number of columns. 
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Course Presentation 

Try to limit the number of elements presented on each slide of 
a course presentation. Content is read by assistive technology 
in the order it was added to the slide, starting with the first 
item added. Be aware when adding multiple blocks of text, 
images, or other elements to a slide as it is easy to confuse the 
reading order. 

Audio Element 

If using the Audio element, supply a text transcript in an 
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adjacent accordion element or link to a text transcript of the 
audio. 

Further Reading 

The Academic Senate for California Community 
Colleges completed extensive accessibility reviews of 
50 H5P types. 
H5P notes content type accessibility with notes on 
issues and planned improvements. 
H5P has recommended content types based on 
accessibility and current support. 
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InDesign Accessibility 

By focusing on a few key steps, 
InDesign documents can be made 
accessible at the source. Ensuring 
accessible InDesign documents will 
save time and effort when exporting 
InDesign documents to other formats 
such as EPUB or PDF. 

On this page: 
Metadata  Headings and Styles  Text Frames  Lists  Tables 
Images  Links  Table of Contents  Forms  Reading Order of 

Layers and Articles  Master Pages  Export  Import  Tools 

Metadata 

Metadata helps assistive technology announce content to 
users and know what language to expect. Add metadata to 
documents by navigating to File > Info and including a 
document title and language. Other metadata will help you 
and others in searching for files. 

Headings and Paragraph Styles 

To create accessible headings in InDesign: 

1. Under the Type menu, open the Paragraph Styles panel 
2. Select New Style 
3. Double click on the newly created style to open the Style 
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Editor 
4. Assign a name under General > Style Name 

1. Best practice would be to name it H1, H2, etc. as 
appropriate 

5. Modify the style’s visual appearance (font, font size, etc.) in 
Character format tabs. 

6. In the Export Tagging category, use PDF Tag menu to set 
as appropriate 

1. Set paragraphs to P 
2. Set headings 1-6 as H1-H6 respectively 

7. Select heading text in the document and choose newly 
created style in Paragraph Styles panel 

8. Repeat process for different heading levels, paragraph 
text, lists, quotes, notes, etc. 

1. An existing style can be duplicated in the Styles panel 
2. Set a name in Style Name and select existing style to 

be duplicated in Based On: menu. 
3. Style new style as desired. 

Do not use the text formatting toolbar.

Set all required styles in the Paragraph Styles panel. 
Read more about headings and document structure. 

Text Frames 

For text columns or text divided by other document elements, 
link text frames together for proper flow of text. To create 
columns: 

1. Create text frames 
2. Click on the small red plus icon near the lower right corner 
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of the frame 
3. Select next text frame to be linked 

Lists 

Do not create lists manually with separate blocks of text and 
images of bullets. Use built in list tools: 

1. Highlight text to made a list. 
2. Click Bulleted List or Numbered List in the control panel. 
3. Or, if you have defined a custom list style, apply 

appropriate paragraph style. 

Use bulleted lists when the order is not important. Use 
numbered lists when the order is important, such as in steps to 
a process. 

Review best practices for lists. 

Tables 

Create Tables via Table > Create Table 
Tables must have either header rows or columns. To 

designate header rows: 

1. Select the cells to be headers. 
2. Select Table > Convert Rows 
3. Select To Header 

Tables created in InDesign will need additional work to ensure 
accessibility if exported to another format, such as PDF. 
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Read more about table accessibility. 

Images 

Anchor Images in their specific place within the document: 

1. Click and hold on the blue square in the upper right area 
of the image container 

2. Drag the image to its place in the document where you 
want the alt text to be read Remember to consider 
reading order of the image’s alt text relative to the 
surrounding text 

3. Release the mouse button and the blue square becomes a 
blue anchor icon 

Add Alt Text 

Within InDesign consider “object export options” to be 
synonymous with “alt text” in other platforms. 

1. Select the image container and navigate to Object 
> Object Export Options or Right-click the container (not 
the image itself) and select Object Export Options 

1. Choose the Alt Text tab, select Custom and type in alt 
text 

2. Move to the Tagged PDF tab 
1. Select Apply Tag and choose From Structure 
2. Under Actual Text Source select Custom 
3. Type in alt text description in the text field 

To mark an image as decorative: 

358  |  InDesign Accessibility



1. Select the image container and navigate to Object 
> Object Export Options or Right-click the container (not 
the image itself) and select Object Export Options 

2. Move to the Tagged PDF tab, Apply Tag and 
choose Artifact 

Review alt text best practices. 

Images of Text 

For an image, such as a logo or decorative lettering, it may be 
better to use InDesign’s actual text feature, rather than alt text. 

1. Right-click on the object and select Object Export 
Options 

2. Select Tagged PDF tab 
3. Choose Custom from Actual Text Source menu 
4. Type the text included in the image 
5. Click Done 

Links 

1. Highlight text to be linked 
2. Right-click and select Hyperlinks > New Hyperlink 
3. Choose Link to web URLs to create a link to a webpage 
4. Choose Link to Text Anchors to create a link to a place 

within your document 
1. Select the appropriate anchor from the list 
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Anchor Links 

To create a link to somewhere else in the document, use 
anchors: 

1. Navigate to Window > Interactive > Hyperlinks 
2. Select the text to be used as an anchor 
3. In the Hyperlink panel and select Option 
4. Choose New Hyperlink Destination 
5. Add a descriptive name 
6. To link to anchor: 

1. Select text to be link 
2. Right-click and choose Hyperlinks > New Hyperlink 
3. Choose Link to Text anchor and choose anchor from 

drop down list 

Read more about accessible links. 

Table of Contents 

1. Select Layout > Table of Contents 
2. Add a title 
3. Designate paragraph styles in Other Styles box and 

use Add button to move them to Styles in Table of 
Contents column 

4. Select Create PDF Bookmarks checkbox 
5. Select Make text anchor in source paragraph checkbox to 

allow you to create links within the document to headings, 
in addition to the links generated in the table of contents 

Read more about InDesign Table of Contents. 
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Forms 

Creating form fields in InDesign will make exporting to PDF 
easier. 

To create a form: 

1. Use the Frame Tool to draw a frame the size of the form 
field 

2. Go to Window > Interactive 
3. Select Buttons and Forms to open the Buttons and 

Forms panel 
4. With the newly drawn frame selected, choose type of form 

field from Type menu in Buttons and Forms panel 
5. In the dialogue that opens, the Description field will 

become the tooltip (necessary for accessibility) when 
exported to PDF 

6. Select Ok 

Form fields created this way will be automatically tagged in 
PDF format. 

Reading Order 

Layers 

InDesign files will likely include at least three layers: Text, 
images, and background. 

To ensure logical reading order: 
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1. Navigate to Window > Layers 
2. Re-order text layers to read from bottom to top of the 

Layers list 
1. What is to be read first visually should be on the 

bottom of the list. What is to be read last should be at 
the top of the list. 

Articles 

To ensure logical reading order: 

1. Navigate to Window > Articles 
2. The Article Panel will open, blank 
3. Open the more menu and select Use for Tagging Order in 

Tagged PDF 
4. Click and drag the first item to the Article Panel and 

provide a name for the article when prompted 
5. Click and drag each item on the page to the Article Panel

in the order it is to be read 
1. The order of items in the Article Panel indicates the 

reading order for assistive technology reading from 
the top of the list to the bottom 

6. Repeat for each page of the document 

Master Pages 

Master pages can be used as a template when creating 
InDesign documents. To use Master pages, select New Master 
from the Pages panel. Select Override All Master Page Items 
before creating articles and exporting to PDF. 
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Export 

To export to PDF: 

1. Navigate to File > Export 
2. Choose Adobe PDF (Interactive) 
3. Click Save 
4. On the General tab, select: 

1. Create Tagged PDF 
2. Use Structure for Tab Order 
3. Forms and Media: Include All 
4. Embed Page Thumbnails 

5. Select Export 
6. Open PDF in Acrobat Pro to verify accessibility 

Note: InDesign often exports excess tags. In Acrobat, use the 
Preflight tool to remove them: 

1. Under Tools, choose Print Production 
2. Select Preflight 
3. Select the wrench icon and under Document select Mark 

all non-structure elements as artifact 
4. Click Fix 

To export to EPUB: 

1. Navigate to File > Export 
2. Choose EPUB (Reflowable). 
3. Click Save 

1. Add a title to Metadata 
2. Under Object settings choose CSS Size option 

of Relative to Text Flow 
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Import 

When a Word document is imported into InDesign, only the 
text will be imported by default. However, Style Mapping allows 
for an import to retain style and structure. To do so: 

1. Navigate to File > Place 
2. Under Format choose Customize Style Import 
3. Select Style Mapping 

1. If you do not have any existing styles you will need to 
map the imported styles to heading tags in InDesign 

2. If your InDesign document already has existing styles, 
match the import equivalents to the styles from the 
drop down list 

3. Click Ok 
4. Click Ok 
5. Click in the document to place the imported text 

Tools 

MadeToTag is an InDesign plug-in that adds tools to create 
InDesign documents for export as accessible PDFs. Read 
MadeToTag’s seven steps to making tagged PDFs in InDesign. 

Consider the Government of Minnesota guide to accessible 
InDesign documents. 
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Other Document 
Suites 

If you are using a document suite other than Office, find 
information for common platforms below. 

iWork 

Apple’s default document suite includes Pages, Numbers, and 
Keynote. While they can create documents, spreadsheets, and 
presentations they lack the advanced accessibility features and 
checkers of Microsoft Office. 

Apple Support guide to creating accessible documents. 
Apple Support Pages User Guide. 
If you wish to create documents using iWork, follow the listed 

accessibility best practices in this book. When 
completed, convert the files to Office formats and use the 
accessibility tools included in that suite. 

Google 

Google’s document suite includes Docs, Sheets, and Slides. 
While they can create documents, spreadsheets, and 
presentations they don’t have the advanced accessibility 
features and checkers of Microsoft Office. 

Google guide to document accessibility. 
If you wish to create documents using Google, follow the 

listed accessibility best practices in this book. When 
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completed, download the files as Office formats and use the 
accessibility tools included in that suite. 

LibreOffice and OpenOffice 

LibreOffice accessibility support. 
OpenOffice accessibility information. 
If you wish to create documents using LibreOffice or 

OpenOffice, follow the accessibility best practices in this book. 
LibreOffice and OpenOffice do not include built-in accessibility 
checkers. Convert your files to Office formats and use the 
accessibility tools included in that suite. 
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Outlook Accessibility 

Crafting accessible emails helps 
ensure communication is 
readable by all recipients. The 
instructions below are specific to 
Outlook, but the principles apply 
to all email clients. 

On this page 
Subject  Fonts and Style  Links  Alternative Text  Plain 

Language  Structure  Accessibility Checker 

Subject 

Include a descriptive, unique subject line to guide assistive 
technology and help recipients understand purpose. 

Accessible Fonts and Style 

• Use automatic colour combinations (black text on white 
background, white text on black background). 
◦ Ensure any other colours used have a contrast of at 

least 4.5:1 against the background. 
• Do not rely on colour alone to convey information. 
• Use readable fonts that are sans-serif or basic serif and at 

least 12 point size. 
• Avoid excessive use of italics, bold, or all caps. 
• Reserve underline for hyperlink text. 

Review font accessibility best practices. 
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Links 

Use meaningful hyperlink text in place of bare URLs. 

For Outlook on the web: 

1. Type descriptive, unique text for the link destination. 
2. Select the text. 
3. Select the Insert Link button on the formatting toolbar or 

press CTRL + K/CMD + K on macOS. 
4. Selected text is in the Display as field. 
5. Paste the URL in the address dialog. 

For Outlook on desktop: 

1. Type descriptive, unique text for the link destination. 
2. Select the text. 
3. Right click and select Link or press CTRL + K/CMD + K on 

macOS. 
4. The text you selected is displayed in the Text to display 

field. 
5. Paste the URL in the address dialog. 

Avoid pasting raw URLs in your emails as these are difficult for 
users of assistive technology to consume and do not provide 
meaningful information about the link destination. 

Consult accessible links chapter for more information. 

Alternative Text 
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Add alt text to images so that recipients who cannot view the 
image can determine its purpose and context. 

For Outlook on the web: 

1. Right click on an image and select Add Alternate Text. 
2. Type your description and click OK. 

For Outlook on desktop:> 

1. Right click on an image and select Edit Alt Text. 
2. Type your description in the dialog. 

Review the alt text quick start guide and subsequent chapters 
for more details about alt text. 

Plain Language 

Use clear, concise language. 

• Avoid assuming recipients’ knowledge. 
• Explain abbreviations, initialisms, and acronyms. 
• Make clear requests. 
• Provide summaries of long emails. 

Learn more about plain language. 

Structure 

While HTML emails support headings (and should be included 
in long emails that have distinct sections), when adding 
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headings consider if email is the most appropriate document 
format for such dense material. 

Use built-in tools for lists, tables, alignment, and indents. 

Accessibility Checker 

Outlook on the web includes 
an accessibility checker. 
Select the three dot icon on 
the Send/Discard toolbar 
and choose Check 
accessibility. 

The Check accessibility tool 
will note colour contrast 
issues, missing table 
headers, and images without 
alt text. 

Learn more about Outlook accessibility settings here. 

Further Resources 

Consider the Microsoft guide to Outlook accessibility. 
The website should responsively display information 
based on your device, but you can also switch tabs 
(Windows, Web, MacOS, iOS, Android) to see specifics 
for your device(s). 
When creating email lists, newsletters, or email 
campaigns, use the checker on accessible-email.org to 
ensure content is accessible. 
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Padlet 

Padlet allows users to 
collaborate on real-time shared 
digital ‘boards’ by adding posts 
including multimedia and links. 

On this page: 
Creating a new Padlet 
Appearance  Adding Images 
Adding Videos  Adding Links 
Adding Files  Links and Further 

Reading 

Creating a new Padlet 
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Give your Padlet a 
descriptive, unique title. 
Prefer Wall, Grid, or Stream 
formats to ensure a 
consistent flow of 
information, clarity, 
accessibility, and ease of use. 
For greater organization 
consider toggling Sections 
on. 

Use Freeform for 
brainstorming and mind 
mapping. 

When starting with Blank 
Board, users are offered a 
choice of layouts including 
Wall, Columns, Grid, Table, 
Freeform, Timeline, Stream, 
and Map. 

Use caution with the Table format as it is not 
properly coded to be accessible and meaningful to 
all users. 
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Sections are a useful feature 
to organize large and 
densely populated Padlets. 
Toggle Sections on when 
creating a Padlet or add 
Sections to an existing 
Padlet by selecting Settings 
> Layout and toggling Group 
posts by sections on. 

Change the layout of an 
existing Padlet via Settings > 
Layout > Format. 

Appearance 

Choose a neutral, uncomplicated wallpaper. Navigate to 
Settings and select Wallpaper to choose a background. 
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When selecting a wallpaper: 
Prefer 

• Solid colours 
• Gradients 
• Simple textures 

Avoid 

• Photos 
• Art 
• Illustrations 

Use the sans-serif (Alps) font to maximize readability. 
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When using images, add a 
succinct description to the 
alternative text form by 
clicking ALT in the lower left of 
the image preview. 

Or include relevant 
information in the Caption 
field. 

Set Post size to Wide to avoid excessive line breaks in text 
heavy posts. 

Posts can be made with different colours. Do not use colour 
alone to differentiate or group information. 

Adding Images 

Learn more about 
describing images 
and alternative text. 
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If visual content has a 
descriptive caption, the alt text 
field can be left blank. 

Adding Videos 

To orient users, add a descriptive, unique title to the Subject 
line of video posts. 

When adding videos, Padlet advises “users to choose videos 
which are appropriately captioned for the benefit of everyone” 
(Aditus, 2025). Consider uploading videos to Kaltura 
Mediaspace, editing the captions, and linking to them via 
Padlet. If linking to a video hosted elsewhere (such as YouTube 
or Vimeo), choose videos with closed captions. 

For videos recorded directly in Padlet or videos uploaded to 
Padlet, captions will be automatically generated. Padlet allows 
users to download subtitles, edit them for accuracy, and re-
upload. For existing videos, select Edit post, open the Subtitle
menu, and select Download subtitles. This downloads an .SRT 
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file which can editted using a plaint text editor such as TextEdit 
or Notepad. 

Learn more about closed captions. 

Adding Links 

When adding a link to Padlet, enter a description of the link 
destination in the Subject field. 
Consider best practices for linking, specifically including (PDF) 
or (Video) in the Subject when links land on a PDF or video. 
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Adding Files 

When uploading a file, write a descriptive title in the Subject 
line and include file type, such as PDF, Word, or PowerPoint. 
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Links and Further Reading 

Langara EdTech Padlet Information 
Padlet Accessibility Information 

Works Cited 

Aditus. “Padlet Accessibility Conformance Report International 
Edition.” Padlet, 2025. 
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PebblePad 

PebblePad is Langara’s online portfolio 
and experiential learning platform. 
PebblePad can be used to create 
portfolios, blogs, basic webpages, online 
collections of files, formal and informal 
reflections, action plans, and more. 

Regardless of type created, adding 
content is similar. This chapter will outline the steps to add 
accessible content to PebblePad. 

In addition to the steps below, follow the general better 
practices for accessible content creation covered earlier in this 
book. 

On this page: 
Font  Structure  Text Equivalents 

Font 

Ensure you use a readable font size and style. Prefer sans-serif 
or basic serif fonts in size 16 or larger. 

The toolbar appears when in an editable field. Use the Font 
Name and Font Size menus to adjust font. 

Review accessible font best practices. 
To change the font colour, select the font and use the Text 

Color and Background Color menus in the editor toolbar. 
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Ensure font colour has a contrast ratio of at least 4.5:1 against 
the background colour. PebblePad does not include a contrast 
checker, but third party tools like WebAIM’s Contrast Checker 
can be used to determined colour contrast ratio. 

The background colour of a text block can be changed using 
the Properties panel and selecting a colour from the menu in 
the Background colour section. 

When using banners, select Text below the 
image in the Properties panel to avoid difficult to 
read text and potential contrast issues between the 
banner image and text. 

Review accessible colour guidelines. 

Structure 

Title 

Ensure each page has a descriptive, unique title. Enter the title 
in the Enter your post title here… placeholder: 
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Or in the title field when you are prompted to save for the 
first time: 

Headings 

To create headings, use the Styles menu on the editor toolbar. 

Title is coded as a heading level 2 while SUB HEADER and 
Hint are coded as heading level 4. Skipping heading levels is 
not ideal, but use the heading tools available in PebblePad to 
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give longer content structure. Use Title for the main topic, SUB 
HEADER for subsections, and Normal for body text. 

Review accessible headings guide for more information. 

Lists 

Use numbered lists for steps in a process. Use bulleted lists for 
grouping of items. Use the Insert/Remove Numbered List and 
Insert/Remove Bulleted List buttons on the editor toolbar to 
create lists. 

Review list best practices. 

Columns 

Text blocks can be single 
column or two column. 

1. Select the text block. 
2. Open the 

Properties panel. 
3. Scroll to Text columns. 
4. Choose Two column. 
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Tables 

Tables can only be created in Templates and Workbooks. 
To create a table: 

1. Select Add Content. 
2. Choose Tables. 
3. Select table with appropriate header cell structure 

(column labels, row labels, or both). 

To modify table structure, 
select Get table cell options 
(the gear icon in the right of 
label cells). Use the menu to 
add or delete rows and 
columns and set required 
format type for column or 
row. 
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Text Equivalents 

Descriptive Hyperlinks 

Instead of pasting raw URLs or links that read “Click here” or 
“Read more” write descriptive hyperlink text that can be 
understood independent of surrounding content. To add 
hyperlinks: 

1. Write meaningful text that describe the destination of the 
link. 

2. Highlight the descriptive text. 
3. Select Link in the editor toolbar. 

4. Choose what type of element you wish to link to. 
1. In the case of a webpage, paste the URL in the 

dialogue box. 
2. Click Confirm Link. 

Consult accessible links chapter for more information. 
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Figure Captions 

When images contribute information, they must have 
alternative text. Adding a figure caption is an accessible 
method to provide text descriptions of visual information. 

To add a figure caption: 

1. Select an Image block and open the Properties panel. 
2. Scroll to the Caption section and check Add a caption. 

3. A caption placeholder will appear in the image block. Click 
on Please enter your caption here…

4. Type a descriptive caption 
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5. If an image has a descriptive caption, the alt text field can 
be left blank. 

Alternative Text 

When a figure caption is not preferred, use the alt text field 
to provide a description of visual information. Add alternative 
text to images in PebblePad when you upload the image as an 
asset in the alt text field. 

Or add alt text when adding an image block by selecting Add 
alt text. 
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If an image already has alt text, the button changes to Edit alt 
text. 

Alt text can also be added via the Assets Store. Select an 
image file asset and scroll to the bottom of the page. Enter alt 
text in the provided field. 

Review alternative text guidelines for more information. 

Captioned Videos 

Use the Embed block for videos. Uploaded video assets in 
PebblePad only support open captions. Prefer closed 
captioned videos hosted on Kaltura Mediaspace, YouTube, or 
other supported platform. 

Consult closed captioning guide for best practices and tips. 
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Transcribed Audio 

Use the Audio block to upload audio recordings. Upload and 
link to a transcribed text version of the audio below the Audio 
block. 
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Reading Lists (Talis 
Aspire) 

Reading Lists organize all of the resources (or “readings”) for 
a course, whether it’s books, e-books, journal articles, scanned 
documents, films, or websites. They can easily be used as a 
digital alternative to print coursepacks. 

Reading lists can be integrated seamlessly into a Brightspace 
course or shared as a link. 

Review the Step-by-step Instructor Guide provided by the 
Langara Library to get started with Reading Lists and consider 
the following accessibility best practices. 

Naming 

Name your Reading List using the naming convention 
recommended by the library. Specifically, name your reading 
list as: Course Code + Course Number: + Title of Course + 
(Instructor Surname). Example: ENGL 1123: Introduction to 
Academic Writing (Smith). 

Organization 

Add sections to your reading list that mirrors your Brightspace 
module organization (week or topic). For more information, 
refer to Organize Reading Lists – Research Guides at Langara 
College. 

Best practice is to add your Reading List to your Brightspace 
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course with each section in the appropriate module AND as a 
source list of all the readings for the whole course. This helps 
students understand and manage readings without missing 
anything or becoming overwhelmed. 

Descriptive Titles 

When adding readings using the extension, Reading Lists will 
pull metadata from the source. However, that information, 
especially titles, may not always be accurate. Review and edit 
the auto-populated information. 

Scans 

Talis only accepts PDFs as uploaded documents. However, you 
may consider hosting content elsewhere, such as an 
opened.ca site, and then adding that source to your Reading 
List. For articles, try to find the original source via your library 
and add that to your Reading List. Most article databases offer 
HTML or PDF, allowing readers their preferred choice. 

Tags 

Open the Edit item menu  on the left side of an item 
record. Select Add tags and choose the appropriate tag to 
indicate the level of accessibility of the item. Choose from the 
following: 
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• Accessible PDF 
• Alternatives available 
• Includes captions 
• Includes captions (auto-generated) 
• Includes transcript 
• Library eBook 
• PDF 
• Scanned from print 

If you are unsure or would like more information about these 
tags, contact assistivetech@langara.ca 
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Social 
Media Accessibility 

On this page: 
Social Media Best Practices  Common Platform 

Instructions 

Follow these guidelines to ensure social media posts are 
accessible and inclusive. 

Social Media Best Practices 

Plain Language 

Plain language helps readers: 

1. Find what they need. 
2. Understand what they find. 
3. Use what they find. 

Review plain language best practices. 
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Tips for using plain language in social media: 

• Start with the most important information. 
• Use short, clear sentences. Avoid run-on sentences. 
• Choose common words with basic, direct meanings. 
• Avoid ableist language such as “lame” or “that’s crazy”. 
• Avoid clickbait, vague statements, or unncessary details. 
• Spell out acronyms and initialisms. 
• Use a link shortener (bit.ly or tinyurl) when appropriate. 
• Including #Hastags and @mentions in the middle of a 

sentence can be confusing. Consider placing them at the 
end of your post. 

Emojis and Hashtags 

Screen readers and many text to speech programs can read 
out unicode emoji graphics. However, text based emoticons 
created by combining slashes, colons, paranthesis, etc. are read 
out as their individual symbols. 

Even with accessible emoji graphics, use them sparingly. 
Consider that ⯑⯑⯑⯑ is not only visually obtrusive, a screen 
reader will read “smiley face smiley face smiley face smiley 
face.” 

Do: ⯑ 
Don’t: ⯑ or ⯑⯑⯑⯑ 
Place emojis at the end of sentences instead of the middle. 
In addition to considerate emoji use, avoid: 

• Leetspeak/Calculator spelling such as “80t5” in place of 
“bots” 

• Text emoticons such as >:( 
• ASCII art such as (^._.^)~ 
• Studly Case such as pReSsBoOkS 
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Hashtags 

When adding hashtags use Pascal case by capitalizing the first 
letter of each word. This makes hashtags more accessible to 
screen readers and text to speech software. Without Pascal 
case, hashtags are read as one long, incomprehensible word. 
Pascal case also allows visual readers to easily differentiate 
words in the hashtag. 

Do: #LangaraCollege #ThisIsTheBestWayToTypeAHashtag 
Do not: #langaracollege 

#thisisnotagoodhashtagandhardtoread 

Alt Text 

Alt text should provide a concise description including the 
essential information about the image. Consider how you 
would describe the image to someone over the phone. 
Machine-generated alt text is becoming more common, but is 
rarely accurate or useful; review and edit machine-generated 
alt text. 

Read more about alt text in the Alternative Text chapter of 
this Pressbook. Review the instructions for relevant platforms 
below. 

Use descriptive hyperlink text. Review the link best practices 
outlined earlier in this book. 

Closed Captions 

Most social media platforms offer automatic captioning. 
Automatic captions are rarely more than 80% accurate, but 
are a good place to start. Use automatic captioning and edit 
manually to improve accuracy. 
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Read the captioning chapter of this Pressbook for best 
practices. 

General Platform Instructions 

Facebook 

Facebook posts have a limit of 60,000 characters, so you have 
space to spell out acronyms and abbreviations. Introduce an 
acronym by spelling out the acronym in full with the acronym 
in parentheses following, for example: Canada-United States-
Mexico Agreement (CUSMA). 

When adding a link to a Facebook post, ensure you enter 
a description of the link’s destination in the Description field. 
Check the No Thumbnail before posting. 

In addition to adding alternative text to photos, you can also 
add a caption to photos. Alt text is coded for assistive 
technology, but captions are visible text to all users. Alt text 
should describe the image, but a caption could be a title or 
used to give credit. 

Alt Text 

To add alt text to a photo: 

1. Select the paint brush icon labelled Edit Photo 
2. Select the Alt Text tab and select Override generated alt 

text 
3. Add alt text in the text field and select Save. 

You can also edit alt text on existing photos. 

1. Find the photo and select Options. 
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2. Select Change Alt Text. 
3. Select Override generated alt text, enter a description, 

and select Save. 

Captions 

Adding captions to videos on Facebook profile 
Adding captions to videos on Facebook page 
Facebook Accessibility Help Center 
While you can add videos to Facebook, it might be better 

to upload your video to Kaltura and then provide a link on 
Facebook. This allows you to share the video on other 
platforms. 
Twitter 

Twitter’s short character limits make accessibility a challenge. 
Consider the following tips: 

• Avoid acronyms and abbreviations. When used, expand/
explain. 

• Consider providing indicators such as [PIC] or [VIDEO] 
when linking to such content. 

• Use a link shortener (bit.ly or tinyurl) when appropriate. 
◦ Use (part of) the tweet itself as a description of what 

the link is 
• Link to accessible content. 
• End with #Hastags and @mentions. 

◦ Use Pascal Case for hastags. 

Alt Text 

1. Attach photo to new Tweet. 
2. Select Add description. 
3. Type description and select Done. 
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Read about Twitter alt text badges. 

Captions 

Twitter now automatically captions videos. At the time of the 
writing of this Pressbook, these automatically generated 
captions cannot be edited. 

Captions display only when the viewer’s device is muted. 
Twitter also allows for uploading .SRT files (read more about 

.SRT in the Captions chapter of this Pressbook) 

1. Click on a video within your Media Studio library. 
2. Select the Subtitles tab in the pop-up window. 
3. Select the text language of your subtitle file from the 

dropdown menu. 
4. Click the Upload button and select the .SRT file from your 

local computer. 
5. Select Done. 

Instagram 

As with other social media platforms: 

• Use Pascal Case for hashtags. 
• Expand/explain acronyms and abbreviations. 
• Use the caption of your post to explain the connection 

between a series of photos. 

Alt Text 

1. Take photo, apply filters, and select Next. 
2. Select Advanced Settings. 
3. Choose Write Alt Text. 
4. Add alt text and select Done. 
5. Change/add alt text to existing photo by selecting Edit. 
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6. Choose Edit Alt Text. 
7. Enter description and select Done. 

Captions 

Currently, Instagram only offers captions on Stories. 

1. Upload video. 
2. Choose Stickers. 
3. Select Captions sticker. 
4. Choose caption style. 
5. Save. 

TikTok 

TikTok will warn creators when adding special effects that may 
trigger photosensitive epilepsy. 

When adding text overlays, select the text and choose Text-
to-speech. This will provide a voiceover of the text when the 
video plays. 

After uploading or recording a video, the editing page will 
prompt creators to enable automatic captions. Captions can be 
edited by selecting the pencil in the right hand panel. 

Visit Accessible-social.com for common social media 
accessibility best practices and additional resources. 
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Surveys and Forms 

Online forms are useful for data 
collection and surveys. Accessible forms 
are designed to meet the access needs 
of all respondents. Accessible forms 
increase inclusivity, usability, and the 
number of people who can participate. 

There are different online tools 
available, but it’s essential to consider the content and 
structure of your form or survey to make it accessible. 

Here are some best practices to improve accessibility, 
usability, and effectiveness of online forms: 

Suggested Platforms 

At Langara, we support Microsoft Forms, Brightspace Surveys, 
and Zoom polls. These platforms offer various question types 
and features. Consider that Zoom polls must be set up before 
the meeting begins. 

Avoid SurveyMonkey and Wufoo as they present many 
accessibility barriers to users. 

Form Best Practices 
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Provide clear instructions 

Start your form with clear instructions. Include information 
about: 

• Number of questions. 
• Time limit (if applicable). 
• Due date (if applicable). 
• How to complete the questions. 
• What the survey is about. 
• How required fields will be indicated 

◦ o Plain text “required” in the visible form label is the 
best method. 

• Instructions for form fields that require specific formatting 
or other requirements. 

• Help or contact information. 

Clear instructions help respondents budget their time, 
manage their expectations, and understand the purpose of the 
survey. 

Use Plain Language 

Use simple and direct language that everyone can understand. 
Avoid jargon, abbreviations, and acronyms or when you use 
them, explain them when they first appear. Avoid negative 
questions that might confuse respondents by requiring a ‘Yes’ 
to confirm a negative. 

Indicate Required Fields 

Indicate required fields in plain text labels or question prompts. 
Don’t rely on colour alone to indicate a required field. 
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Include Field Labels 

Every field should have visible labels and example placeholder 
text in the fields. Add meaningful labels above or to the left of 
each field. 

Number Questions 

Number each question and add a progress indicator to help 
respondents to understand the survey’s length. 

Allow Saving Progress 

If the platform allows, give respondents the option to pause, 
save, and resume the survey later. 

Avoid Time Limits 

Do not impose a time limit on respondents unless essential to 
the purpose. 

If a time limit is needed: 

1. Clearly communicate the time limit in the instructions. 
2. Provide a warning before time runs out. 
3. Offer a method to extend time at least once. 
4. Make sure the timer is obvious and accessible without 

being intrusive. 

Avoid Space Constraints 

Use long text or rich text fields that allow respondents 
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adequate space to answer. Ensure forms display properly on a 
mobile device. Pay attention to the layout of multiple-choice 
and radio buttons. 

Error Messages 

If respondents make mistakes or enter invalid data, show 
accessible error messages that specify the incorrect field and 
provide guidance on the required formatting. For example: 
“Dates should all be entered in the format mm/dd/yyyy, (as in 
06/29/2023)” or “Passwords must contain at least 8 letters and/
or numbers.” 

Check Focus Order 

Test the keyboard functionality of your form to ensure the focus 
order follows the visual layout. Use Tab to move between fields, 
Space to open a menu and select checkboxes, and arrow keys 
to navigate menus and radio buttons. 

Ensure there is an obvious visual indicator when a form field 
has keyboard focus, such as a noticeable ring around the field. 

Add Submission Confirmation Message 

After clicking the submit button, include a confirmation 
dialogue to prevent accidental incomplete submissions. 
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Teams and Zoom 

Making a virtual meeting or 
presentation accessible 
includes all attendees 
equitably. Consider the 
following tools and best 
practices for Zoom and 
Teams. 

On this page: 
Before Meeting  During Meeting  After Meeting 

Before Meeting 

Before a meeting, consider the following to ensure your 
meeting includes everyone: 

Include relevant information in the meeting 
invitation 

Copy Zoom meeting invitation and distribute with meeting 
invitation. 

 
 
Use Outlook to schedule a 

Teams meeting by toggling on Team meeting in Outlook. 
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Share material in advance 

If your event includes material, share it in advance. 

This helps: 

• Attendees follow along. 
• People consume information at their pace. 
• Improve comprehension and understanding by allowing 

people to make notes and annotations instead of 
frantically copying down the information. 

• People who prefer to print material. 
• People who wish to do preparatory reading. 
• Assistive technology users to access and navigate the 

content. 
• Interpreters, captioners, and transcribers to prepare and 

know names, terminology, and details. 

If there is no material, consider sending a read-ahead or 
agenda. No one likes surprises. In the context of a class, your 
content will likely be related to the readings or material on 
Brightspace, so you may not have to explicitly create anything 
extra. 

As always, ensure what you are sharing is accessible. 

Mute on entry 

For large groups, it may be best to have attendees muted when 
they enter to reduce confusion and crosstalk. People can 
unmute as needed later. 

When setting up a Zoom meeting, toggle on Mute all 
participants when they join a meeting. Learn how to mute all 
Zoom participants. 

In Teams, select Meeting options to set audio and video 
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In Zoom, ensure captions are 
enabled. In the Zoom toolbar, 
click the captions button and 
select Enable captions. 

This allows viewers to enable 
captions on their device. Learn 
more about Zoom automatic 
captions. 

permissions. Learn more about managing attendee audio in 
Teams. 

Enable automatic captions 

During Meeting 
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In Teams, select … More and 
select Settings > Accessibility.
In the Accessibility sidebar, 
toggle Always show captions 
in my meetings on. 

Use live captions in Microsoft 
Teams meetings 

Make a plan, ask for 
input, and 
communicate with 
attendees 

Outline the agenda, 
structure, and expectations 
of the Zoom session to help 
with accessibility and 
anxiety and ensure a 
smooth flow. Indicate if you 
plan to use breakout rooms, 
if there will be polls, and 
how you would like 
questions/comments to be 
communicated. 

Consider: 

• Asking how attendees 
would prefer to 
communicate and come to 
a group agreement about 
communicating. 

◦ Some students may not 
find it easy to access the 
chat window and video 
simultaneously. 

◦ Some students may prefer 
to ask questions via chat. 

• Repeating questions aloud 
before answering them. 

◦ This allows those not 
looking at the chat to know the question you are 
about to answer. 

• Asking a volunteer to monitor the chat and ask them to 
notify you of questions. 
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To record a Zoom meeting: 

1. Select Record on the 
Zoom toolbar. 

2. Recording can be paused 
and stopped on the Zoom 
toolbar. 

1. The recording will be 
saved in the default 
location 
(Documents folder 
/ Zoom / Folder with 
meeting name, date, 
and time.) 

• Encouraging participants to mute their microphone when 
they are not speaking. 

Recording 
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To record a Teams meeting: 

1. Under More in the 
meeting controls, open the 
Record and Transcribe 
menu. 

2. Select Start recording. 
3. Set Spoken language and 

select Confirm. 
1. Recording a meeting 

automatically starts 
Transcription. 

The recording will be available 
in the Teams chat for the 
meeting as well as the host’s 
OneDrive Recordings folder. 
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In Zoom, open the participants 
panel and select Mute All. 

If appropriate, ensure Allow 
participants to unmute is 
checked.Learn more about 
muting participants in Zoom. 

In Teams, select People and 
click on the … More options 
menu in the top 

Mute all participants 
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right.Select Disable mic for 
attendees. 

Hosts can then allow individual 
users to unmute, or enable mic 
for attendees using the same 
menu. Learn more about 
managing attendees in a 
Teams meeting. 

In Zoom: 

1. Via the video settings 
menu, select Choose 
Virtual Background… 

Avoid complicated 
virtual backgrounds 

Animated virtual 
backgrounds may be 
distracting for some and 
could cause anything from 
motion sickness to seizures 
for others. If you want a 
virtual background, use 
blur or other solid colour. 
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2. The Zoom settings window 
will open to Background & 
Effects where you can 
choose a background. 

Read more about changing 
Zoom virtual background. 

In Teams: 

1. While you’re setting up 
your video and audio 
before joining a meeting, 
select Background filters. 

1. Your background 
options will display on 
the right. 

2. Select Blur to blur your 
background. 

Use tools to highlight 
specific attendees 

In Zoom consider pinning 
participants’ videos and 
allowing multi-pin. This will 
help attendees focus and/or 
pin the presenter and an 
interpreter. 

In Teams, use Spotlight 
and Pin for presenters and 
interpreters. 

Present with your 
audience in mind 

Learn more about inclusive 
content delivery. 

Additional 
Considerations 

If you are unsure how to 
assist a participant, ask 
them. They may have 
encountered a similar 
barrier before and may 
recall a solution. 

Ask participants if they 
would like any help or if 
anything is unclear. 

Be patient. Everyone 
faces unique circumstances 
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How to set a background filter 
in Teams. 

To save a Zoom meeting chat: 

1. Open the Chat panel. 
2. Select the … More menu 

and some may need 
additional time and 
patience. 

Respect participants 
desire to share or remain 
private. 

If presenting a 
PowerPoint, consider 

Present Live: Engage your audience with Live Presentations 
and Present from PowerPoint Live in Microsoft Teams. 

After Meeting 

Following a meeting there are a number of useful resources 
that can be shared: 

Chat 
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beside the meeting room 
name. 

3. Choose Save chat. 
1. The chat will be saved 

as a text file in the 
default location 
(Documents folder 
/ Zoom / Folder with 
meeting name, date, 
and time.) 

It is possible to disable the chat 
for a meeting to prevent 
participants from chatting with 
one another. 

In Teams, meeting chats are 
saved automatically in each 
user’s chat window under the 
name of the meeting. The chat 
can be manually copy and 
pasted into a document, 
however some formatting may 
be distorted. 
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To save the transcript in Zoom: 

1. Transcription and/or 
Closed Captioning must be 
enabled. 

2. Open the Captions menu 
on the toolbar and select 
Show full transcript 
or select the Transcript 
button from the toolbar. 

3. At the bottom of 
the Transcript panel, 
select Save transcript. 

4. The transcript will be saved 
as a text file in the default 
location 
(Documents folder 
/ Zoom / Folder with 
meeting name, date, and 
time.) 

Transcript 
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To save a transcript in Teams: 

1. Transcription must be 
turned on for the meeting. 

2. After the meeting, the 
Transcript will be available 
for download in the 
meeting chat. Depending 
on settings, the Transcript 
may only be available to 
the meeting host to 
download. 

Consider sending a follow-up email after the meeting has 
concluded. A follow-up email could include: 

• Reminders 
• Action items 
• Links or other resources shared in chat or discussions. 

◦ A useful method might be to look at the saved chat 
and glean links and talking points from that record. 

• Where and when appropriate, share a captioned video 
recording. 

• Presentation material or related resources, even if you 
shared them prior to the meeting. 
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For repeating meetings, check in with attendees periodically 
for feedback on what is working or what changes they might 
benefit from. Ask attendees about pace and breaks. Review 
protocols for communicating (raising hands, use of chat, etc.) 
and ask for suggestions. 
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WordPress and 
Pressbooks 

WordPress is one of the most common 
content management systems in use. 
Pressbooks is built on the WordPress 
platform, so many functions are the 
same. Langara’s iWeb and CourseWeb 
use WordPress and this resource is a 
Pressbook. 

On this page: 
Themes  Best Practices  Headings  Alt Text  Links  Tables 
Exporting  Further Reading 

Themes 

WordPress has thousands of themes. Some are free and many 
are paid. Regardless of what theme you use, it is easier to start 
with something accessible than fix an inaccessible theme. 

You can filter WordPress themes for “Accessibility Ready.” 

1. Click the Feature Filter button 
2. Check Accessibility Ready checkbox 
3. Click the Apply Filters button 

This reduces the list of themes significantly, but using an 
“Accessibility Ready” is not a guarantee of accessibility. 
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Best Practices 

Make content easy to read and navigate, by using: 
Plain language. Learn more about plain language. 
Structured content such as headings, lists, and tables. 
Consider font accessibility, including: 

• Standard font size is 16px, but use em and rem units in CSS 
for font size. 

• Avoid excessively decorative fonts; choose simple serifs or 
sans serif fonts. 

Font must have a contrast ratio of at least 4.5:1. Read more 
about contrast in the Accessible Colour chapter of this book. 

Avoid: 

• Leetspeak, calculator spelling (i.e., 80t5 for bots), text 
emoticons (i.e., >:( ), ASCII art (i.e., (^._.^)~) 

• All capitals 
• Excessive use of italics 
• Justified alignment 

Headings 

Headings provide structure for your page and the information 
it presents. Headings allow all users to skim and find what they 
need. Navigating a page by headings is essential for screen 
reader users to navigate the web. 

To designate text as a heading, highlight your text and select 
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the Paragraph dropdown to select your desired heading level. 

For more information, consult the headings quick guide in 
this book. 

Alt Text 
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WordPress/Pressbooks 
supports adding figure 
captions via the Media 
Library. When adding or 
editing an image add 
information to the caption 
field. If an image has a 
descriptive figure caption, 
the alt text field can be left 
blank. 
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If an informative image does 
not have a descriptive 
caption, enter an image 
description in the Alt Text 
field when uploading a new 
image. 

Or, edit an existing image to 
add alt text by selecting the 
image and choosing 
Edit and typing a 
description of the visual 
information in the alt text 
field. 

Or, manually change the alt attribute in the Text/HTML editor: 
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Include the alt attribute for all images. If there is no alt 
attribute, assistive technology will read the src attribute (the file 
URL) aloud. Mark decorative images with alt=”” or leave alt text 
field blank in Media Library. 

Refer to the Alternative Text chapter in this book for more 
information. 

If including multimedia, ensure videos are captioned and audio 
have transcripts available. 

Links 

To add a link, highlight text and use the Insert/edit link button 
or press Control/Command (on macOS) and K to insert a link. 

Good hyperlink text should: 

• Be descriptive, unique, and meaningful 
◦ Describe what a link is and why a reader would click 

on it 
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◦ Avoid using “click here” “read more” “download” etc. 
◦ Maintain meaning when removed from surrounding 

text 

Avoid using URLs as hyperlink text. If you must provide the 
URL, include useful hyperlink text as outlined above and then 
include the URL as non-linked, regular text. 

For more information read the accessible links chapter earlier 
in this book. 

Tables 

Insert tables using the Table tool on the editor toolbar. 

1. Change table appearance via Table > Table Properties 
2. Set cell type and scope via Table > Cell Properties 

1. Of particular importance is setting header cells 
2. Set header row via Tables > Row> Table Row 

Properties 

Avoid merged and split cells. You may use them, but additional 
work is required to set scope. 

Check function of table by placing cursor in call A1 and 
pressing Tab. Ensure a logical reading order is followed. 

Do not use tables for alignment or layout. 
Review table best practices for more information. 

Exporting Pressbooks 

HTML is a more accessible format than PDF. If you need to 
share a page as a PDF, make it accessible using Adobe Acrobat 

424  |  WordPress and Pressbooks



and the chapter on PDFs in this book. EPUB or other XML 
formats are more inherently accessible formats. 

Pressbooks offers many export options. To export your 
Pressbook: 

1. Navigate to the Dashboard 
2. Select Export from the sidebar 
3. Check the relevant formats 

1. PDF (for digital distribution) will be the best place to 
start in creating an accessible PDF copy 

2. EPUB 3 is one of the most accessible and 
customizable formats, but requires software for users 
to read 

3. PDF (for print) should only be used explicitly for 
printing purposes as it will retain none of the coded 
structure in you Pressbook 

4. There are other formats you find useful: 
1. XML and XHTML 
2. Common Cartridge for importing your Pressbook 

into a Brightspace course 
3. OpenDocument 

Further Reading 

Learn more about Accessibility in WordPress. 
Read about how to make your Pressbook accessible. 
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WordPress Block Editor 

Follow these best practices to create 
accessible pages and posts in the 
WordPress block editor. 
On this page 
Title  Font, Colour, and Formatting 
Headings and Structure  Alternative 

Text  Links  Plain Language 

Title 

Each page and post must 
have a descriptive, brief, and 
unique title. Select the Add 
title placeholder to create a 
title. 

Font, Colour, and Formatting 
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Use a sans-serif font like Arial 
or Verdana, with black text 
on white backgrounds or 
white text on a black 
background. Use fonts size 16 
pixels or larger. 

For accessibility do not use 
Langara orange (#f15a22) 
with white. For decency do 
not use Langara orange with 
black. 

If using font colours other 
than default, check text and 
background for sufficient 
contrast. The WordPress 
editor will note insufficient contrast, but if unsure check 
colours using the WebAIM colour contrast checker. 

Use built-in tools for lists and adjusting indent. 

Headings and Structure 
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Use headings to organize 
content. Headings should be 
brief (only a few words) and 
descriptive of the content 
contained below. Use 
heading levels in a 
sequential, nested structure. 
For example, begin with an 
H2 for your main point or 
theme. Use nested H3s for 
subtopics. Return to H2 for 
your second point with 
nested H3 subtopics, etc. 

To create a heading 
type /heading. 

To set heading level open the 
H2 menu in the editor 
toolbar and choose the 
appropriate heading level. 
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To review heading structure, 
open the Document 
Overview and move to the 
Outline tab. 

WordPress will 
note (Incorrect heading 
level). 

Do not use tables for alignment purposes, use the Columns 
block. 

Alternative Text 

Graphics that contain information must 
have a text equivalent. Often that is 
provided in the Alt Text field. Alt text is 
code that is read aloud to screen reader 
software and describes the information 
in a graphic to blind and low vision 
users. Write a brief description of the 
graphic in the Alt Text field in the 
Media Gallery Attachment Details 
panel. Learn how to write alt text. 

If an image does not include 
information, leave the Alt Text field 
blank. 

Best practice for many images, 
especially instructions, is to include a 
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text equivalent to compliment and support visual information. 
If a graphic contains information but is accompanied by 
adjacent equivalent text or a descriptive figure caption, leave 
the Alt Text field blank. 

Add a figure caption in the Media 
Gallery Attachment Details panel 
Caption field. Captions can be longer 
than alt text, but should be concise. 
Links and attributions should be in a 
caption, but never in alt text. 

If an image is a link, write the link destination in the Alt Text 
field. 

Links 

Do not include bare URLs as they are cumbersome for assistive 
technology and meaningless to all. Do use “read more” or 
similar language for links as it is not meaningful. 

To create accessible links: 

1. Write a brief description of the link destination. 
2. Select the text and choose the Link button in the editor 

toolbar. 
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Or, press Control (Command on macOS) k 
3. Paste the URL and press Enter. 

Plain Language 
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Use clear, concise language. 

• Avoid assuming recipients’ knowledge. 
• Explain abbreviations, initialisms, and acronyms. 
• Make clear requests. 
• Provide summaries of long emails. 

Consider Microsoft Word’s Document Stats for readability stats 
or AIOSEO Readability scores. However, as the author you know 
the material best and you are smarter than a computer. Learn 
more about plain language. 
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MATH ACCESSIBILITY 
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Accessible Math 

Math and science can be 
challenging for many learners 
regardless of ability or 
experience. If that content is 
not accessible, even more 
learners may be left behind. Creating accessible math and 
science content is straightforward using tools such as Equatio, 
Brightspace, and Office. 

A first step to accessible and inclusive access is to present 
information in multiple ways. For STEM content, consider 
presenting: 

1. Numerically 
2. Verbally 
3. Graphically 
4. In multiple formats 

Numerically 

1. Lay out the equation line by line, step by step. 
2. In digital spaces, insert symbols using equation editors 

instead of copying from elsewhere. 

Verbally 
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1. Read the equation or data aloud. 
2. Explain the steps and processes as you complete them. 

Don’t simply say “this equation here” or “on this line”. 

Graphically 

1. Use an accessible graphing tool such as Desmos (built-in 
to EquatIO). 

2. Also include accessible data in table format. 
3. For a simple diagram or chart, alt text may suffice. 

In Multiple Formats 

1. Convert handwritten math (such as notes, documents, 
whiteboard photos) using Equatio mobile. 

2. On a mobile device, navigate to m.equat.io and scan 
physical math 

1. Authenticate using your Langara email 
3. Send to Equatio Mathspace on desktop 

1. Authenticate using your Langara email 
4. Use the Equatio Screenshot Reader (more information in 

later chapters) to capture math from the web and digital 
documents. 

In digital formats ensure you use the proper symbols. Do not 
use the letter x or *, instead use the multiplication symbol . 
Avoid / for division, as assistive technology will read “21 forward 
slash 7”. Instead, include the division symbol . 
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Equatio Quick Start 
Guide 

Equatio is software that allows you to insert, edit, and interact 
with digital STEM content. 

Use Equatio to: 

• Create accessible STEM content in Google Docs, Microsoft 
Word and PowerPoint, and Brightspace. 

• Create and consume STEM content in a variety of formats. 
• Use multiple input options, text-to-speech, and accessible 

chemistry tools. 

Install 

1. Go to Equatio Desktop 

2. Choose Windows or Mac. 
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3. Follow the installation guide. 

Access 

Select Sign in with Microsoft and use your Langara email and 
password. 

Basic Function 

Creating STEM Content 

1. Open Equatio 
2. Open the Equation Editor to type math.
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3. Enter text as you would speak it, or with specific notation. 
Select appropriate suggestions as you type by pressing 
Enter. 

4. Click the Copy Math As… or Insert Math button to put 
accessible digital math in documents. 

Read STEM 

EquatIO’s Screenshot Reader can be used to capture images 
of math or other inaccessible math content. 

To use EquatIO’s Screenshot reader: 

1. Open Equatio. 
2. Select Screenshot Reader on the toolbar.

3. Draw a box around math in documents or on the web. The 
content will be read aloud and can be exported to various 
formats (MathML, LaTeX, accessible image) or opened in 
the equation editor for further revision or completion. 
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For more information contact assistivetech@langara.ca 
Read more EquatIO how-tos and resources. 
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EquatIO 

On this page: 
EquatIO  Input Methods  Other Tools  Mobile  Mathspace 
Options and Settings 

EquatIO 

EquatIO is very intuitive and easy to use. Anywhere you can 
input text, you can use EquatIO to write math. Anywhere you 
encounter math, you can use EquatIO to read and copy math. 
EquatIO handles multiple inputs and outputs including plain 
text, LaTeX, MathML, and images. EquatIO also has chemistry 
and graphing tools. Langara has a site license for EquatIO, 
which means faculty, students, and staff can log in with their 
Office365 email and use all features of EquatIO. 

Installing EquatIO 

Google Chrome Extension 
Download EquatIO for Mac/Windows 
Mathspace 
Access EquatIO on mobile devices. 
Log in with your Langara email account when asked to 

authenticate. 
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The following is an overview of Equatio for Google Chrome. To 
open the Chrome Extension: 

1. Select the EquatIO extension 
2. Or, press Alt Shift q 

Input Methods 

Typing 

Open the Equation Editor to type math (or paste from an 
existing accessible text format). Enter text as you would speak 
it, or with specific notation. Select appropriate suggestions as 
you type by pressing Enter. Press Enter to move to a new line. 

More information on prediction and alignment and a list of 
keyboard shortcuts. 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3857#oembed-1 
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LaTeX 

EquatIO accepts LaTeX input. LaTeX can be edited in EquatIO 
and exported as LaTeX or other formats. 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3857#oembed-2 

Speech 

EquatIO can accept speech input. Speak slowly and as clearly 
as possible. 

Handwriting 

Write (with mouse, touch screen, or stylus) in the left panel 
and EquatIO will generate an accessible format in the right 
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panel. Scrub, like using an eraser, to erase your handwriting 
input. 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3857#oembed-3 

Screenshot 

EquatIO’s screenshot tool can be used to capture images of 
math or other inaccessible math content. Use the tool to draw 
a box around inaccessible math. The content will be read aloud 
and can be exported to various formats or opened in the 
equation editor for further revision or completion. 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3857#oembed-4 

Select EquatIO > Options > Chrome Options to change Speech 
Speed. 
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Exporting Math 

Once math is in the EquatIO editor, it can be exported in 
several formats. EquatIO can be used to insert math anywhere 
there is a text edit field. If you have a document open (a 
Brightspace file or Word Document for example) you can 
select Insert Math. 

For additional options, select the Copy Math As… button on 
the bottom right of the screen.

This allows users to export math in various markup 
languages (MathML, LaTeX, HTML, SVG), as an image with a 
spoken version of the math as the alternative text, or as spoken 
text into a document. 

When inserting math into a document, users can make 
changes by clearing the equation editor, selecting the inserted 
math, and choosing the Edit Math button on the toolbar. 

Other Tools 

Discoverability 

The discoverability tool will highlight any detected math on 
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a webpage.

Recognized math will be enclosed in a blue box and when 
hovered over will present a toolbar with options to dismiss or 
capture math (camera icon). Selecting the capture math tool 
will read the math aloud. By selecting the more options button, 
you can then copy the math as MathML, LaTeX, or Edit with 
EquatIO which copies the math to the toolbar editor. 

STEM 

EquatIO has numerous other tools for math and science 
available on the toolbar. LaTeX and graphing tools are available 
on the toolbar, while a periodic table, scientific calculator, and 
molecule viewer are available under the STEM tools menu.
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Mobile 

EquatIO mobile allows users to capture math with a phone, 
including photos of math, math written on a touch screen, or 
math input using voice commands. 

1. Visit m.equat.io on a phone. 
2. Sign in with Langara email. 
3. Math can be saved as an accessible image or shared with 

an active EquatIO document on desktop or Chrome. 

Follow this link for additional instructions on EquatIO mobile. 

Mathspace 

Mathspace is a browser-based tool for creating math, featuring 
all the EquatIO features listed above (handwriting, text, and 
speech input; integration with EquatIO mobile; STEM tools), as 
well as additional tools for graphing, drawing, and shapes. Pre-
existing questions can also be inserted into Mathspace and 
spaces can be shared. Click the Share button in the top right of 
the window. 
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Consult the EquatIO Mathspace quick reference guide for 
more information. 

Options and Settings 

On the left of the menu, the EquatIO button contains a menu 
with links and options. 

1. Select Options 
1. Select Math Options to change font size, language, 

and prediction (autofill) settings. 
2. Select Toolbar Options to toggle on or off various toolbar 

buttons. 
1. A user navigating by keyboard may find it useful to 

hide unused tools. 
3. Select Chrome Options (or Desktop Options) to change 

playback speed when using the screenshot read to have 
math read aloud. 

Select Options to change tools appearing on the toolbar (via 
Toolbar options), change speech speed under Chrome 
Options, and various other settings under Math Options. 
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The desktop versions of EquatIO have additional options and 
the menu is laid out slightly differently. 

Learn more about Equatio 

Quick reference sheet for EquatIO in Google Chrome. 
EquatIO student resources. 
EquatIO Academy to search for articles and guides. 
EquatIO User Resources 
TextHelp quick guide for EquatIO mathspace. 
EquatIO Mobile allows users to capture math via 
mobile devices. 
Supporting Specific Learning Needs with EquatIO 
Langara support page for EquatIO 
Accessible math on the web 
Using EquatIO with NVDA. Additional information on 
using NVDA with EquatIO. 
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Equation 
menu on 
the 
Brightspac
e editor 
toolbar 

Brightspace Math 

There a number of ways to embed 
math and science content in 
Brightspace pages. 

Equation Tool 

1. Graphical Equation offers an additional toolbar and 
palettes of symbols to generate equations and is best for 
beginners or casual users. The graphical editor is not 
keyboard accessible. 

2. LaTeX requires a specific skillset and knowledge base but 
may be worth learning if you are frequently using math as 
it can be used very quickly once you ‘speak’ the language. 

3. MathML is an XML language that is rarely typed by hand. 
Use a MathML generator (EquatIO can easily do this) and 
paste the output here. Select the Insert button to paste 
your equation into your Brightspace file. 

4. Chemistry Equation is similar to the Graphical Equation 
tool but includes specialized symbols for chemistry 
formulas. 

Learn more about Brightspace equation editor. 
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One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3859#oembed-1 

Equatio Integration 

Equatio can be used to insert equations into Brightspace 
wherever the Editor toolbar is present. For example, Equatio 
can be used when creating content, submitting text 
assignments, or completing certain quiz questions. 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3859#oembed-2 

1. On the Editor toolbar, select Insert Stuff. 

2. Select Equatio. 
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The Equatio editor will appear. 
3. Use the various tools to generate your equation. 

1 Type math 

2 Type LaTeX 

3 Graph editor 

4 Handwrite math 

5 Speak math 

4. Select Insert Math. 

5. Select Insert again. 
6. The equation will appear in the Brightspace editor. 

Note, there are fewer tools available when running EquatIO via 
the Brightspace editor than when using the browser extension. 
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EquatIO Extension 

Use EquatIO to insert math into Brightspace. 

1. Open the Equatio extension. 
2. Use the Equation Editor to create math content. 
3. Open the Copy Math as menu and select image to paste 

directly into your Brightspace file or select copy math as 
LaTeX or MathML and use Brightspace Equation tool. 

One or more interactive elements has been 
excluded from this version of the text. You 

can view them online here: 
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=3859#oembed-3 
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Microsoft Office Math 

Microsoft Word, PowerPoint, and 
OneNote include tools to input or paste 
math. 
On this page: 
Office Equation Editor  General Tips 
Exporting  Ink to Math  MathML 
OneNote Math Tools 

Office Equation Editor 

1. Navigate to Insert > Equation

1. You can also press Alt + = (CTRL + = on macOS) 
2. An equation placeholder appears in the document 

1. The Equation tab will appear with additional options 
such as switching between formats like LaTeX and 
plain text as well as common equations and symbols. 

3. Type equation in LaTeX or use Word Equation Editor 
toolbar to build math.

4. Press Enter.
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General Tips 

Use Professional style. 

To center equations, use the alignment tools on Home > 
Paragraph group. 
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Users can save frequently used equations. 

1. Open the Equation Options menu and select Save as 
New Equation… 

2. Provide a name and other information and click Ok. 
3. Word will save this equation for quick access via Insert > 

Equation. 

456  |  Microsoft Office Math



Microsoft Office Math  |  457



Exporting to PDF 

While Word is a preferable format, math content may need to 
be exported to PDF. In that instance, use File > Export > Create 
Adobe PDF. Never use Print > Print to PDF or Save to PDF.
Such PDFs will be completely inaccessible. 

For further information, consider Microsoft’s guide to writing 
equations and formulas and formatting equations in LaTex and 
Unicode. 

Ink to Math 

1. Navigate to Draw tab. 
2. Select  Ink to Math. 
3. Draw math in box, verify in preview pane. 
4. Select Insert. 

MathML (Word only) 

1. Copy MathML from web or EquatIO. 
2. Paste in Word. 
3. Word will automatically render the math in your 

document. 

Additionally, you can use EquatIO’s desktop version to insert 
math into a Word or PowerPoint document. 
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Export to PDF 
If you intend to distribute material in PDF format, 
ensure the PDF is verified for accessibility. However, 
passing automated accessibility checks rarely 
ensures complete accessibility of PDFs, especially a 
document containing math. Best practice would be 
to create a Word document and export it to PDF, 
retaining the Word document as a template for 
future changes and exports. You could also 
distribute the Word document to those who need it, 
or best practice would be to distribute both formats 
to students, allowing them the choice based on 
preference or need. 

OneNote Math Tools 

Microsoft OneNote can also create and read math content. 
To create math in OneNote: 

1. Open a new notebook. 
2. Navigate to Draw 
3. Use the Pen tool to write math. 
4. Use Lasso Select to drag around your math. 
5. Select Math Assistant. 
6. In the sidebar, choose Fix it to amend any mistakes and 

then select Ink to Math. 
7. Your math will be pasted as text in your notebook. 
8. Select View > Immersive Reader to hear your math read 
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aloud. 

Math generated in OneNote can be copied as MathML for use 
on webpages or in Word documents. 
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Math Conversion Tools 

As of November 2023, it is not possible to go directly from a 
TeX document to an accessible PDF. One potential solution for 
converting LaTeX to an accessible PDF is MathPix. 

MathPix 

MathPix may be a useful tool for converting LaTeX to various 
formats including Word and PDF. MathPix is available free 
(with some limitations) to educators. 

To create an accessible PDF from LaTeX: 

1. From the MathPix homepage, select Note. 
1. Choose New blank note 
2. Or Upload a .md, .tex, or .txt file to upload an existing 

document. 
1. Note, this may make more work than it saves. 

3. Or write or paste LaTeX in left hand pane. 
4. Take note of output preview in right hand pane.

5. Select Export File and choose PDF (with HTML) or 
DOCX. 
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To make an existing math PDF more accessible: 

1. From the MathPix homepage, select PDF. 
2. Choose existing PDF to upload. 
3. Click Upload. 
4. When completed, PDF options will appear in left hand 

toolbar. 
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5. Select Convert to note. 
6. MathPix will display a side by side of LaTeX and potential 

output. 
7. Select Export File and choose PDF (with HTML). 

Some issues persist in conversion. Ensure content appears as 
intended before exporting. 

Use PDF only as a last option as it is an inherently 
inaccessible format. 

Math Converter 

Indiana University has developed a math converter tool to 
convert AsciiMath, LaTeX or MathML to English text. 

For example  would read: “x is 

equal to; the fraction with numerator; negative b plus or minus; 
the square root of b squared minus 4 a c, end root; and 
denominator 2 a; end fraction.” 

This could be useful for supplying alt text for an image of 
math, for people struggling to see math, and to understand the 
verbal syntax of math. 
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Math on the Web 

On this page: 
Math on the Web  LaTeX  MathJax  Images of Math 

Math on the Web 

The following video outlines how to use EquatIO to add 
accessible math to Pressbooks. You can use EquatIO to insert 
math as an image, LaTeX, or as MathML. Both LaTeX and 
MathML will be rendered by the MathJax plugin. The principles 
covered here may apply to additional web content as well. 

To use EquatIO to insert math: 

1. Open the Equatio extension. 
2. Enter your math in the editor. 
3. Click Insert Math to paste math as an image. 
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4. Use Copy math as LaTeX and use the LaTeX tool. 
5. Or Copy math as MathML and paste in the HTML editor. 

LaTeX and MathML will only work if your website has the 
Mathjax plugin installed. 

The following video outlines the steps to use EquatIO: 

One or more interactive elements has been 

excluded from this version of the text. You can 

view them online here: https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=3868#oembed-1 

Consider these sources on MathML: 
W3C overview of MathML. 
Mozilla Developer Networks explains how to write MathML. 
How to Make Math Accessible on the Web (TextHelp). 

LaTeX 

Learn about the LaTeX typesetting system. 
The TeX equation editor allows users to build LaTeX math 

equations even if they do not know LaTeX. 
Use TEMML to convert LaTeX math to MathML. Paste LaTeX 

as Input: and copy Output as MathML. 
The LaTeX to SVG tool converts LaTeX to SVG format. SVG 

image files can be resized without loss of resolution (which is 
important for math images/images of text). However, you must 
add alternative text to SVGs manually. 

EquatIO can also be used to convert math between formats 
such as plain text, MathML, images, and LaTeX. 
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MathJax 

Add the MathJax plugin to your website to render MathML and 
LaTeX content. Note: Pressbooks and Brightspace already have 
MathJax installed. 

As an example, consider how this LaTeX =\int_{ }^{ 
}\frac{x^2}{(u)^{101}}\left(\frac{du}{3x^2}\right) can be 
rendered: 

MathML, using MathJax: 

Image: 
 
 
Note, this image has 

alternative text that would 
read the formula aloud to assistive technology. This alternative 
text is generated automatically by Equatio and reads: “equals 
the integral from to of the fraction with numerator x squared 
and denominator u to the 101st power times open paren d u 
over 3 x squared close paren”. 

The most accessible method is MathML or LaTeX rendered 
with MathJax. This allows user to zoom, navigate within the 
formula, and hear it read aloud. However, that requires 
MathJax. For basic math, or when MathJax is not available, an 
image with alternative text is better than nothing. 

Images of Math 
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Where MathJax is not available, include math as an image. Add 
the spoken mathematic equivalent as the alternative text of 
the image. To do so: 

1. Use Equatio to create your math. 
2. Select Copy Math As… 
3. Choose Spoken Text to add the spoken equivalent of the 

math to the clipboard. 
4. Paste the description in the alt text field. 

Other considerations include: 

• Explain the concept in surrounding text, use the alt text to 
describe the specifics of the math. 

• Work in a linear fashion from left to right. 
• Use A Handbook for Spoken Mathematics to write out the 

verbal equivalent of math pronunciation and syntax. 
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Additional Resources 
Pressbooks supports LaTeX in the default editor. MathML can 
be pasted in the Text (HTML) editor. 

Desmos is an accessible graphing tool integrated into 
EquatIO to generate accessible graphs. 

Consider these Desmos resources: Getting started with 
Desmos, Accessibility features in Desmos, Desmos knowledge 
base. 

Windows includes a simple tool called Math Input Panel in 
which you can handwrite math to be exported in MathML. 

Solve math equations with Math Assistant in OneNote. 
Accessible Periodic Table of the Elements. 
Independence Science Periodic Table of the Elements. 
NIST Digital Library of Mathematical Functions. 
Chemistry add-in for Microsoft Word. 
AsciiMath is a markup language for maths that uses 

javascript and MathJax. The AsciiMath page offers details on 
AsciiMath syntax as well as instructions for adding AsciiMath 
via MathJax to your website (requires some coding knowledge 
to impliment). 

Math Detective allows user to upload images of math or 
blocks of text with inaccessible math. The math can then be 
read aloud of copied as MathML. 
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Further Reading 

Explore additional digital accessibility resources. 
Explore AbilityNet’s Digital Accessibility Resources for 

information on legal issues, business cases, how-to guides, 
tools & resources, and more. Read Creating Accessible 
Documents for general best practices and tips. 

Toronto Metropolitan University’s (TMU) Digital Accessibility 
Teaching and Learning Resources includes guides on web and 
document accessibility. Also consider Understanding 
Document Accessibility from TMU. 

Review the University of Colorado’s Content Accessibility 
Fundamentals and digital accessibility resources. They also 
offer a monthly accessibility newsletter. 

Section508.gov offers resources and guidance on digital 
accessibility. 

Use TMU’s SLICK acronym, Queen’s University Belfast’s 
THRIVES system, and the Worcester County Council’s SCULPT 
framework for basic accessibility checks. 

Browse the A11yProject’s accessibility resource list and this 
Accessibility Resources (Master List) for a massive range of 
sources, guides, and more. 
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Glossary 

Accessibility Checkers 

Automated tools built-in to many platforms that check for 
common accessibility issues. Are not to be considered a 
guarantee of accessibility. 

Accommodation 

A reactive adjustment to a resource or activity to make it 
accessible to a person with a disability. 

Alternative Text 

Alternative text is a text equivalent of graphics in a 
document or webpage. Alternative text is coded to be 
hidden visually, but read to a screen reader user. 

ARIA 

Accessible Rich Internet Applications are roles and 
attributes that can make Javascript widgets, error 
messages, and live content more accessible. 

Audio Description 

Additional audio added to a video that describes important 
visual details that are not conveyed by the main audio 
alone. 

Camel Case 

Capitalization of the first letter of each word in multi-word 
hashtags. Without Camel Case, hashtags will be read aloud 
as one long, unintelligible word. 

Also known as CamelCase, Pascal Case, or Title Case 
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Caret browsing 

Keyboard navigation using the text cursor to navigate a 
web page or document. Usually activated by pressing F7 in 
your browser. 

CCTV Magnifier 

Closed Circuit TV (CCTV) magnifiers are cameras used to 
magnify documents or books on a monitor. 

Closed captions 

A text equivalent of audio content in a video, displayed 
synchronously. Closed captions are toggled on or off by 
viewers, as opposed to open captions that are burned into 
the video and always displayed. 

Colour contrast 

Colour contrast is the difference in saturation, brightness, 
and pigment of different elements relative to one another. 
A contrast ratio of at least 4.5:1 between text and 
background is required by common accessibility 
standards. 

Contrast ratio 

The contrast ratio between the font colour and the 
background colour. Accessible contrast should be at least 
4.5:1. 

Decorative image 

An image that does not contain unique information or is 
used for visual appeal only. Decorative images must be 
marked as decorative or use alt="" 
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DOM 

The Document Object Module (DOM) represents the 
hierarchical, logical structure of a document/web page. 

EPUB 

Most common ebook file format. A very customizable and 
accessible format. 

example 

This is an example glossary term to illustrate how glossary 
terms work in Pressbooks. 

FAST 

A framework for assessing the accessibility of content, by 
focusing on key criteria, including: 

Function 
Appearance 
Structure 
Text Equivalents 

Flattened Copy 

A digital object that has been "flattened" into a single layer 
when exported. A scanned document or a PDF created 
using "Print to PDF" (or similiar) will be a flat image without 
recognizable text or digital document structure. A flat copy 
may visually appear as a document, but be completely 
inaccessible. 

Focus 

On a webpage, a control or content item that can receive 
focus by a mouse, keyboard, or screen reader. Typically 
links, buttons, forms, and menus are focusable. 
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Focus indicator 

A visual indicator of what element on a page is currently 
focused. This assists users to know where they are on a 
page and to select menus, links, and buttons with a 
keyboard. 

Focus order 

The order in which interactive elements on a page are 
focused. Focus order should follow a logical pattern that 
aligns with visual layout. 

Functional Accessibility 

When something does not meet accessibility standards 
but is still useable by users of assistive technology. 

Headings 

Headings are text used to organize a document. Headings 
are section and subsection titles used to logically separate 
content, build and show relationships between ideas, and 
explain the development of concepts. Headings must be 
hierarchical, not skip a level, and be semantically 
programmed, not merely cosmetic. 

Hyperlink 

Linked text to another document or part of document that 
the user can follow by selecting. Effective hyperlink text 
should make sense independent of the content around it. 

Image caption 

An image caption is text that provides supplemental 
context, explanation, or commentary about an image. 
Image captions generally appear below the image. Image 
captions may include comprehensive details as well as 
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supplemental information related to the image, such as 
citations, photo attribution, cultural context, historical or 
scientific information about the subject, complex data 
from charts, etc. Unlike alternative text, figure captions 
have no length limit. Figure captions are accessible and 
available to all users, whereas alt text is only available to 
assistive technology. 

Integrated description 

The practice of incorporating audio descriptions of actions 
or visual content into the flow of video content. For 
example, when recording a process on a computer, 
integrated description would include the narrator 
including steps such as: "Click on Add New. Type your 
answer in the textbox. Click Create." 

Keyboard trap 

When a user cannot navigate away from an interactive 
element using their keyboard alone. 

Label 

In HTML, the label element acts a caption for input fields, 
indicating what a control (form field, check box, radio 
button, etc.) relates to. 

MathML 

XML format used to add math to HTML. 

OCR 

Optical Character Recognition (OCR) is software which 
converts printed material or images of text into 
recognizable digital text. Scanned PDFs require OCR 
processes to be accessible. Adobe Acrobat includes builtin 
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OCR technology, but other assistive technology software 
also employs OCR. 

PDF 

Portable Document Format. One of the more difficult 
format to make accessible. Lacks customization options for 
readers (font customization, reflow, colour options, etc.) 

Plain language 

Language that is easily understood by the intended 
audience. Write for the audience using clear, simple 
language with focus on important information. Organize 
and group content. 

Reading order 

The order in which a screen reader reads content on a 
page. This should match visual order. Reading order also 
refers to how a PDF will reflow when zoomed. 

Responsive Design 

Responsive content automatically adapts to the size of the 
user's display (phone, laptop, tablet, etc.) 

Screen reader 

Assistive technology software that reads content aloud and 
helps blind and low vision users navigate and interact with 
their computers. 

Semantic markup 

The use of code (HTML attributes, PDF tags, XML, etc.) to 
distinguish content by meaning, not appearance. For 
example, a <h1> heading tag creates both a visual and 
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coded navigation waypoint whereas increasing the font 
size and bolding simply makes regular text appear larger. 

SEO 

Search engine optimization is the process of improving 
search engine ranking. 

Skip to main content 

Often hidden links accessible by keyboard navigation that 
assist users to skip over repeated parts of webpages or to 
different parts of a webpage, such as search or navigation 
region. 

Tables 

Information presented in a grid format of rows and 
columns, generally to show a relationship between sets of 
data 

Tag (PDF) 

A tagged PDF includes semantic information and 
structure to create an accessible document. This is done by 
adding tags to the document in Adobe Acrobat. 

Templates 

Preset document or file format, used for consistency 
without having to recreate each time 

Timestamp 

Specific time in video, often expressed as hh:mm:ss 

Transcripts 

Transcription is the process of converting audio into 
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written text. A transcript is a written record of all audio in 
media. Captions are synced to the content. 

Universal Design 

Design of content, software, facilities, and services so that 
they are useable, without accommodation, by the largest 
scope of users. 

W3C 

The World Wide Web Consortium sets web technology 
standards. 

WCAG 

Web Content Accessibility Guidelines are maintained by 
W3C and set the minimum standards for web accessibility. 
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