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“Clearing a Path for Everyone” Michael Giangreco And Kevin
Ruelle / University Of Vermont Center For Digital Initiatives
Collection (Source)

Introduction

This book was created by Luke McKnight (Assistive
Technologist, Langara College) and Briana Fraser (Educational
Technologist, Langara College) with assistance from Clover
Duong (Assistive Technologist Project Assistant, Langara
College). This resource is intended as a reference for educators
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and support staff to understand digital accessibility, create
accessible documents, and ensure the access means of all are
met.

Please use, share, and copy from this book as you see fit.

This work is licensed under a Creative Commons Attribution-
NonCommercial-ShareAlike 4.0 International License.
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Using This Book

First, a brief introduction to using this resource.

In This Chapter:

1. Navigation
2. Glossary
3. Hypothes.is
4. Videos
5. Accessibility Statement

Navigation

Use the next or previous buttons to move between chapters:

The Contents button will expand the table of contents menu
allowing you to navigate:
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Most chapters contains a table of contents that links to
specific sections of each chapter, such as:

Select any link to skip to that part of the chapter.
As you move down the page, a ‘back to top’ button appears:

Select this button to move back to the top of the page.
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Glossary

Click with a mouse, Tab to with a keyboard, or use the buttons
list on a screen reader to read glossary terms.

Glossary terms appear in bold, red text with a dotted
underline. They are in the keyboard tab order and presented as
buttons to screen readers.

Hypothes.is

Use Control (Command on macOS) and F to search for
keywords.

You can use the built-in hypothes.is annotation plugin to
highlight content in this resource.

Select the Annotation Sidebar in the top right of the page.

Using This Book | 5



Login or signup to hypothes.is
Highlight text and select Annotate to add a note or Highlight

to highlight content.

Videos

This book includes a number of interactive videos. The video
will display a process and then pause to present an overlay with
text equivalent instructions. Press the Play button to continue.
Text equivalent instructions will also be included immediately
following the videos. The screenshot below of a later chapter is
an example of what to expect.
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Accessibility Statement

The web version of this Pressbook conforms with Web Content
Accessibility Guidelines 2.0, level AA.

Of note:

• All text is 12 point or larger for body text
• All content has appropriate colour contrast (apart from

one instance of poor contrast intentionally included as a
bad example)

• Content in web and EPUB export can be zoomed to 200%
with no need for horizontal scrolling

• All videos with audio are captioned
• All images include alternative text or are marked
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decorative
• Tables are properly formatted
• All link text is descriptive
• Links do not open in a new window or tab
• All H5P activities are verified accessible by the author
• Math content is either an image with all information

contained in the alt text or created using LaTeX and
rendered with the Pressbook MathJax plugin

If you encounter an accessibility barrier or have any other
questions or comments, contact assistivetech@langara.ca.
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Why Digital
Accessibility Matters

Curb Cuts

Take a moment to consider who curb cuts are built for?
Many people’s first, and correct, thought is wheelchair users

and people who are blind. Curb cuts are essential for some
people to navigate and access the world.

But curb cuts have many other benefits.
Consider other people who might rely on curb cuts:

• People pushing a stroller or pulling a shopping cart
• People using a walker, walking stick, or cane
• Children learning to walk or anyone having difficulty

making the step up
• Cyclists locking up their bike
• Someone on crutches or with other temporary disability
• Movers, delivery people

The digital world includes elements like curb cuts: headings,
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colour contrast, alternative text, closed captions, and many
others. We may traditionally think of these as accommodations
essential for some users, but in fact they benefit everyone,
including content creators.

Consider that some accessibility needs are persistent, such
as blindness; some are temporary, such as screen fatigue; and
some are situational, such as forgetting one’s glasses or glare
from the sun. By designing material properly you ensure
everyone, regardless of access need or circumstance, will be
able to consume and engage with your material in a consistent
and functional way.

Digital accessibility, like accessibility in general, means the
ability for everyone regardless of access means to consume,
interact and engage with digital material. Digital accessibility
is an iterative process and digital accessibility is a spectrum;
few documents or webpages are 100% accessible. However,
increasing the accessibility of your content increases your
audience, their comprehension, and includes the maximum
number of people.

Accessibility is democratic, just, equitable, and inclusive
allowing all to access information. By following some simple
best practices and employing the resources found in this
guide, you can easily increase the digital accessibility of your
material.

10 | Why Digital Accessibility Matters



PART I

ACCESSIBLE CONTENT

Frankly, there are a lot of things to consider when creating
content.

Some basic elements to consider:

• Structure
• Colour and Contrast
• Use of images
• Links
• Plain English
• Tables

Or: SCULPT1

Additionally, you might focus on:

• Tables
• Hyperlinks
• Recordings
• Inclusive font
• Visuals
• Examine
• Structure

Or: THRIVES2

Those are a great place to start. In this guide we will focus on
making content accessible FAST.

When creating content, focus on:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1561#h5p-115

Accessible Content | 11



Additionally, use tools to assist you:

• Use built-in tools for tables, lists, and links
• Use templates
• Use accessibility checkers
• This Pressbook

This guide will expand on each of these principles, explaining
key concepts and instructions for creating accessible content
with common software and platforms.

Worcester County Council SCULPT

SCULPT by Helen Wilson is licensed under a Creative
Commons Attribution-NonCommercial-ShareAlike
4.0 International License. Based on work
at Worcestershire County Council.

Centre for Educational Development (CED)
THRIVES

THRIVES is licensed under a Creative Commons
Attribution-NonCommercial-ShareAlike 4.0
International License.
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1. Function

In this chapter:

1. Plain Language
2. Robust
3. Media

Plain Language

Create your content using plain language. Plain language best
practices include:

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2063#h5p-86

Consider the Plain Language Action guide and this guide
to using simpl(er) words and phrases.

Robust

Ensure your content works:

• Check your content on multiple devices and browsers
• Zoom in to 200%
• Use Tab to check reading order and focus states
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Media

Include captioned media in accessible players that do not
autoplay.
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2. Appearance

In this chapter:

1. Accessible Font
2. Hyperlink Text
3. Accessible Colour

Accessible Font

All text content needs to be readable. Accessible fonts are:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2065#h5p-87

Hyperlink Text

Use descriptive hyperlink text instead of pasting URLs directly.
Hyperlink text should be:

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2065#h5p-88
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Accessible Colour

Text must have a contrast ratio of at least 4.5:1 against the
background colour.

For example, black on white is 21:1 and orange on white is
3.37:1.

The next chapter examines colour in further detail.
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3. Accessible Colour

In this chapter:

1. Accessible Colour
2. Platform Specific Instructions
3. Colour Code Tools
4. Further Reading
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Accessible Colour

Colour contrast is a key element of accessibility. 1 in 12 men
and 1 in 200 women have some kind of colour vision deficiency.
This means it is important to ensure foreground information
has sufficient contrast against background colours and that
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colour is not the only means to convey or emphasize
information.

However, good colour contrast practices aren’t just for those
with an identifiable colour deficiency.

Benefits for students

• Includes all, regardless of access means
• Provides similar appearance regardless of

device and user settings
• Retains all information if printed in black and

white
• Reduces eye fatigue, glare from the sun, and

allows use of dark/night mode or custom contrast
settings

• Makes content easier to read for everyone

Benefits for instructors

• Allows for customization and styling without
excluding anyone

• Ensures information looks similar regardless of
device and user settings

• Retains all information if printed in black and
white
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• Reduces eye fatigue, glare from the sun, and
allows use of dark/night mode or custom contrast
settings

• Analyzing use of colour serves as a reminder to
emphasize important content in text form, not
solely relying on colour

Colour can be expressed digitally in different ways with Hex,
RGB, and HSL/HSV/HSB the most common colour codes.

In this guide, we refer to Hex colour codes, but the principles
are the same regardless.

For proper colour contrast, aim for at least a 4.5:1 ratio. To
(over)simplify, that means the text is 4.5 times brighter than
the background. For large text, size 18 point or greater, or 14
point or greater that is bold, requires only a 3:1 ratio. Logos and
decorative images have no requirements.

Black text on a white background is good colour contrast
(21:1). Orange text on a white background (or vice-versa) is not
(3.37:1)
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Platform Specific Instructions

To find appropriate colours and/or to change colours in:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=100#h5p-20

Colour Code Tools

There are many options for finding colour codes, when
necessary.

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=100#h5p-21

Accessible Colour | 21



Contrast Checkers

WebAIM (Accessibility in Mind) is an exceptional resource that
has a contrast checker, a link contrast checker, and additional
reading on colour contrast in general.

ACE (Accessibility Colour Evaluator) is an excellent tool for
checking colour contrast. You can set multiple colours for
multiple elements (background, text, link, hover, etc.) and see
the corresponding colour contrast ratios.

Consider some of these as well and find what works best for
you:

Color Contrast Checker
Palette Checker
Who can use this color combination?
Color Blind Web Page Filter
Safe Hexadecimal Color Codes

Further Reading

WebAIM guide to WCAG colour guidelines.
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4. Structure

In this chapter:

1. Structure

1. Navigation
2. Headings
3. Lists

Structure

Well structured documents are essential to allow assistive
technology to navigate your documents. Structured
documents help all readers with context, organization of ideas,
and clarity.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=2067#h5p-89

Navigation

◦ Add a table of documents to documents longer than 5
pages

◦ Provide skip links in HTML
◦ Include multiple ways to navigate (Previous and next

buttons, menus, site map, etc.)
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Headings

Headings are an important part of documents and web
pages. Screen reader users rely on headings to navigate the
web and longer documents. For anything beyond a few
paragraphs, headings are essential for screen reader users.

But, like curb cuts headings have many other benefits.

Benefits for students

• Includes all, regardless of access means
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• Provides context and explains relationships
between ideas

• Emphasizes key concepts
• “Bookmarks” in a long document for readers to

use to take breaks and resume their place
• Allows for skimming to review and find specific

content efficiently

Benefits for instructors

• In Word, headings can be used to create a table
of contents automatically

• Drag and drop headings in the Word
Navigation pane to move all subheadings and
subordinate content under that heading

• Update heading style to change the
appearance of all headings of that level

• See how information flows and review
relationships between concepts

• Create a summary or overview document

Lists

Use built-in list tools and semantic HTML lists.
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5. Text Equivalents

When creating something that isn’t text, add:

• Alt text to images and graphics
• Closed captions to videos
• Transcripts to audio
• Table data to charts and figures
• Captions to diagrams

Further, don’t rely on colour alone to convey meaning or
importance.

For example:

• Use colour, shapes, and text in charts and diagrams
• Add text indicators to highlighted table cells
• Include reminders like “important” or “remember” in

addition to bolding emphasized text

The next two chapters will expand on alt text and closed
captioning in greater detail.
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6. Alternative Text

In This Chapter:

1. Alternative Text
2. Common Platform Guides
3. Alt Text Decision Tree
4. Further Reading

Alternative Text

Alternative text (alt text) is a description coded into images
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that indicates the image’s meaning to screen reader software
and conveys the information to blind users. Alt text allows all
users to consider the purpose and function of images. If for
some reason an image cannot be viewed (slow connection,
error with hosted image, or use of assistive technology) alt text
provides the meaning and intent of an image.

According to WCAG 2.0 Guideline 1.1.1 : “All non-text content
that is presented to the user has a text alternative that serves
the equivalent purpose.”

Images and diagrams are excellent compliments to text and
vice-versa. Including visuals can break up large block of texts
and increase understanding. However, do not rely on any one
format alone.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=48#h5p-74

Tip: Consider why you have included a visual.

• If it is purely decorative mark it as such.

◦ If the image contains information
repeated in adjacent text, you can likely
mark it as decorative.

• If it is to add additional context, “Photo of
Michael Jordan” in an article about Michael
Jordan is useful alt text.

• However, if your image includes information,
try writing your alt text as how you might
describe the visual element to a friend over
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the phone.

◦ If you include an image of a bird, the alt
text should include the colour of its beak
and feathers, whether it is perched or
flying, or other activities and details
shown in the image.

◦ If there is an image of Mount Fuji,
effective alt text might be “A snow
capped mountain with a flat top,
surrounded by forest and farm land.”

▪ `However, including that image
in an article about Mount Fuji you
could likely use “Mount Fuji on a
rainy day”

Alt text is essential to screen reader users to understand
content.

But alt text has other benefits as well.

Benefits for students

• Includes all, regardless of access means
• Includes users with low bandwidth or

inconsistent connection
• Allows users with content blockers to
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understand images
• Provides context, purpose, and information of

the image if an image does not load

Benefits for instructors

• Provides clues for moved or missing image
source to be replaced

• Provides a built-in review of why you are
including an image

◦ o Is it decorative? Does it contribute useful
information? If not, is it necessary?

Common Platform Guides

How to add alt text to…
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=48#h5p-2
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Alt Text Decision Tree

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=48#h5p-73

Further Reading

Tips for alt text by type of image from W3C Web Accessibility
Initiative.

W3 Web Accessibility Initiative’s alt text decision tree is useful
for narrowing down what your alt text should convey.

WebAIM offers a comprehensive resource on alt text.
Diagram Center advanced alt text guidelines are helpful and

has an e-book of alt text samples organized by graphic type.
Additionally, Diagram Center’s training tool helps to better
understand how to write alt text.

Portland Community College has an excellent presentation
on alt text for complex images.

Read more about alt text for data visualization.
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7. Captions and
Transcripts

In This Chapter:

1. Captions
2. Platform Captioning Guides
3. Creating Caption Files
4. Transcripts
5. Further Reading

Captions
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Closed captions provide a text version of all audio elements in
a video, presented visually in time with the video. Traditionally,
we think of captions as an accommodation for viewers who
cannot hear the audio in a video due to hearing loss. Statistics
suggest 4-5% of the general population suffer some form of
hearing loss. That number increases to around 20% for people
over aged 60. However, 80% of 18 to 24-year-olds regularly use
subtitles when watching video.

While captions are essential for many, they have many other
benefits.

Benefits for students

• Includes all, regardless of access means
• Allows for better comprehension,

understanding, and focus
• Helps understand unfamiliar names and

terminology
• Assists with understanding accents different

from the viewers’ own
• Helps understanding for viewers with English

(or other language in video) as an additional
language

• Allows for watching in a loud environment or a
shared space (library, shared office, living room,
etc.) and/or without headphones

• Includes a viewer with an ear infection or pain
• Provides for user preference: ~80% of 18 to

24-year-olds regularly use captions when
watching video
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Benefits for instructors

• Allows for indexing and searching of video
• Improves SEO
• Assists in locating a specific term in a video and

directing viewers to a timestamp
• Allows for easily locating specific topics and

create video chapters
• Provides an easy method to convert a spoken

presentation to text form
• Ensure names and terminology are

communicated exactly as they are spelled

Best Practices

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=30#h5p-26
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Platform Captioning Guides

Kaltura

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=30#h5p-71

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=30#h5p-75

Other Common Video Platforms

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=30#h5p-1

Social Media
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An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=30#h5p-49

Creating Caption Files

You can also use a text editor (like Notepad for Windows or
TextEdit on MacOS) to create or edit .SRT files (.SRT and .VTT
are the most common file formats for subtitles). Consider this
guide for manually creating and editing .SRT files.

Creating .SRT and .VTT Files

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=30#h5p-62

Here is an example of the proper formatting of an .SRT file in
TextEdit:
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Use HappyScribe’s convert SRT to VTT tool or 3Play Media’s
caption converter tool if you need a different file format.

For instructions to upload caption files, consult the platform
guides earlier in this chapter.

Transcripts

Transcripts are a text document containing all the audio
content in media, including videos, podcasts, and audio
recordings. Transcripts may also include additional information
regarding visual elements and actions such as descriptions of
what is on screen. Unlike captions, transcripts are not
timestamped or synced with the media. A transcript is
particularly useful to text-to-speech and screen reader users
because many users set their software to read at a rate much
faster than natural human speech. Transcripts can also be
searched for words, names, and terminology.
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Transcription Tools

Use Word to transcribe either by recording directly in Word or
uploading an audio file.

Mac OS also supports dictation that could be used to develop a
transcript.

Google Docs also allows dictation that could be used to write a
transcript.

Further Reading

Toronto Metropolitan University’s guide to captioning and
description.

WebAIM guide to captions, transcripts, and audio
descriptions.

Described and Captioned Media Program’s guidelines and
best practices for captioning educational video.

BBC Subtitle Guidelines (the most extensive resource for
captioning guidelines on the web).

Google Chrome now offers live captioning on any video. This
feature does not absolve content creators/providers from
adding captions to video content, however, if encountering a
video without captions on the wild web, this feature can be
invaluable. This tool relies on the built-in captioning settings on
your computer. To view or change these settings:

• Use subtitles and closed captioning on Mac
• Change Windows caption settings
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8. Tools

Use built-in software and platform features to make your
content accessible.

• Use built-in tools for tables, lists, links, and styles
• Use templates
• Use accessibility checkers

◦ Office, Brightspace, and Acrobat Pro DC include
automated accessibility checkers

◦ Automated checkers will check for common issues
but do not guarantee accessibility

By using the best practices and tools introduced in this guide,
you create accessible content that allows for user choice.
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9. User Choice

Allow users to consume content as they want. Whatever you
create, assume readers will consume it in a different way than
you do. That may mean on a phone, on a magnified screen,
during their commute, or read aloud.

To ensure everyone can consume your content:

• Provide multiple formats
An interactive H5P element has been excluded
from this version of the text. You can view it online

here:
https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1569#h5p-85

• Ensure content is adaptive, responsive, and can reflow

◦ Web content, EPUB, and Word are excellent
◦ PDF is much more difficult
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PART II

SOFTWARE GUIDES

Next, learn how to make accessible documents on different
platforms.
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10. Microsoft Office
Accessibility

Microsoft Office includes built-in tools to assist you in making
accessible documents.

In This Chapter

1. Function

1. Write Plainly
2. Tables

2. Appearance

1. Accessible Font
2. Hyperlinks

3. Structure

1. Document Properties
2. Document Structure
3. Images and Graphics
4. Lists

4. Text Equivalents

1. Alternative Text
5. Tools to Avoid
6. Accessibility Checker
7. Sharing
8. Further Reading
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Write Plainly

Use the Editor tool to check reading level. Navigate to Home
> Editor and select Document Stats. Aim for a Flesch-Kincaid
score of 7-9.

Tables

Tables are useful for organizing data. Properly built and
formatted tables are completely accessible.

In Word and PowerPoint, navigate to:

1. Insert tab
2. Table
3. Insert Table
4. Indicate number of columns and rows and press Ok

1. You can add columns and rows later

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1553#h5p-24
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Accessible Font

For Word documents and Excel spreadsheets:

• Use sans-serif or simple serif font, size 11 or greater

◦ Size 9 is acceptable for foot/endnotes or captions
• For PowerPoint, use font size 18 minimum
• Use an accessible colour

◦ Font must have a contrast ratio of at least 4.5:1 against
the background

• Left-align text
• Use built-in tools for spacing and alignment

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-22

Hyperlinks

Create meaningful hyperlink text.

• Avoid vague instructions like “see” or “click here” or “read
more”

◦ Not only are those not helpful out of context, but self-
describing links may help you locate your resource if
the URL changes

• Do not paste URLs as hyperlink text

◦ If URLs must be included, provide self-describing
hyperlink text and format URLs as normal text with no
link attached.
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• Use default link styling (blue, underlined text)

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1553#h5p-29

Document Properties

The document title is announced to assistive technology and is
much more pleasant and informative than the file name (but
allows you to retain your file naming conventions). Other fields
are useful but not required.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-91

Document Structure

Providing structure to documents is essential for assistive
technology, but help all readers navigate your documents
efficiently and understand relationships between topics.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:
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https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-92

Microsoft guide to finding accessible templates for Office
products.

Images and Graphics

Apart from adding effective alt text to images, there are a few
additional considerations for visual elements in Office
documents.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-96

Lists

Properly formatted lists organize information and makes your
documents accessible.

• Use bullet lists for unorganized lists
• Lists where the sequence is not important

1. Use numbered lists for items where sequence is important
2. Such as steps in a process

To create a list:

1. On the Home tab
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2. Select Bullets, Numbering, or Multilevel List

1. The dropdowns accompanying each style offer more
options and customization.

Alternative Text

Assistive technologies employ alternative text (alt text)
attached to images to inform users of the context and purpose
of images and visual elements. Alt text is a text alternative to
non-text content to ensure all users can access information.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-90

Review this Pressbooks’ chapter on Alternative Text for more
information.

Include table data for charts.
Ensure embedded media has text equivalents. Videos must

have closed captions and audio must have a transcript.

Tools to Avoid

• Strikethrough
• Highlighting
• Dropcap
• Word Art, Smart Art, text effects
• Ungrouped related shapes
• Watermarks
• Symbols, except for the following safe characters:
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An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-48

Accessibility Checker

Use Office products’ built-in accessibility checker to check for
common issues. Note, these tools may not catch all possible
accessibility issues.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-81

In the Accessibility pane select Keep accessibility checker
running while I work checkbox to see a realtime accessibility
message in the bottom status bar. Click Accessibility:
Investigate at anytime to open the Accessibility pane.

Like any automated tool, Office’s accessibility checker will not
catch any and all accessibility issues. Here is a summary of what
it does look for and how well it catches those issues:
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Element checked Reliability of checker

Structure and use of heading
styles

Poor.

Will show if there are no
headings on a long document
but doesn’t flag issues on
shorter documents. A single
heading is enough to pass the
checker even though the
document remains inaccessible.
It cannot test the logic of the
heading structure.

Colour

Moderate.

Can find poor colour contrast
but cannot tell if colour has
been used as a sole indicator for
information.

Use of images

Moderate.

Will find images that have
neither Alt text, nor are marked
as decorative as well as those
where the Alt text is just the file
name. But it cannot identify
whether the Alt text is
appropriate or even meaningful.
It will find images that are not in
line with the text. In-line images
may not be as aesthetically
pleasing but they are easier for
screen readers to find.

Links
Poor.

It does not check for link text.

Plain English

Poor.

It does not check for this, but
you can check yourself by
switching on the readability
stats as described in the section
on Understandable Content.

Tables

Fair.

It finds whether the table has
the Header row marked. It may
warn if tables have split or
merged cells.
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Miscellaneous

Poor.

Does not check text justification,
videos for captions, or form
labels.

This table is adapted from work originally developed by AHEAD
and Alistair McNaught and is made available under a CC BY-
NC-SA creative commons license.

Read more about checking for accessibility issues with the
Office Accessibility Checker and learn about Office Accessibility
Checker rules and messages.

Sharing

Best practice is to share material in advance of presentation or
class.

◦ This allows users to check for barriers beforehand
◦ All users can take additional, in-depth notes and

understand terminology and names with greater
comprehension

◦ Users that experience barriers can zoom in or adjust
the documents to their viewing preferences

Sharing a read only file is the most accessible way to share
Office documents for reading.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-83

You can share Word and PowerPoint files with various levels of
permissions. There are additional options for protecting your
Excel workbook, sheet, or part of your spreadsheet.
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Export to PDF

You can very easily export Office documents to PDF. Keep in
mind, extra work may be needed in Acrobat DC Pro to ensure
the PDF is accessible. See this guide’s PDF accessibility chapter
for more information.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1553#h5p-82

Further Reading

Use this Word Accessibility quick guide (Word document,
49KB) as a reminder of Word’s accessibility tools.

Refer to this PowerPoint quick guide (Word document, 43KB)
for options and tools.

Use this Excel Accessibility quick guide (Word Document,
43KB) as a reminder of Excel’s accessibility tools.

Microsoft outlines best practices to make documents
accessible.

WebAIM guide to creating accessible documents in Word.
Contact assistivetech@langara.ca for further information or

assistance.
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11. Additional
PowerPoint and Excel
Features

More PowerPoint Features

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1873#h5p-93

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1873#h5p-94

More Excel Features

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1873#h5p-95
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12. Brightspace
Accessibility

Starting with an accessible course design will help ensure an
inclusive and equitable experience for all learners. The tips in
this chapter will refer to Brightspace, but the concepts
discussed apply to all online content.

In This Chapter:

1. Templates
2. Format Text
3. Headings
4. Alternative Text
5. Descriptive Hyperlinks
6. Lists
7. Tables
8. Uploaded Content
9. Accessibility Checker

10. Further Reader

Templates

Create great-looking, responsive, and accessible content topic
pages using the page layouts provided in the template
package. The layouts are designed to be edited using the HTML
Editor in the Learning Environment.
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Be consistent: use the introductory template for all
introductory pages, the video page for videos, etc.

To access the templates, Create a File and then click on
Select a Document Template menu next to the title text box.

Format Text

Use the built-in editor tools to change text. All font options are
available on the Brightspace editor toolbar.

• Use a sans-serif font with a minimum size of 11
• Avoid excessive italics
• Left align text for languages that read left to right

Colour Contrast

• Aim for at least 4.5:1 for normal text (11-12 point) and 3:1 for
large text (18 point +)
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• Use the Check Accessibility tool:

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=34#h5p-113

Do not use colour alone to convey meaning or emphasis. You
may use coloured text to highlight content, but best practice
would be to also bold the text and include an indication, such
as “important” or “remember” in text form. Further, ensure
charts and diagrams do not rely on colour alone to convey
meaning or relationships, consider using different line shapes,
symbols, and labels.

Headings

Headings allow learners to understand the logical structure
of the page and navigate to different sections. Assistive
technology can convey this structure to screen readers and
speech-to-text software if the headings are properly formatted,
not simply text with increased size or bold text.

Pages should begin with an H1, with H2s, H3s, etc. nested
below. Headings must be in sequential order. Do not skip a
heading level. Body or paragraph text may follow any heading
level. (Note: If the heading levels are not in order, the
Accessibility Checker will report Heading order must be
sequential.)

The HTML editor offers tools to build proper heading
hierarchies. Highlight text and choose the appropriate heading
level.
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Consider H1 as the title, H2 as section headings, H3 as sub-
section headings, etc.

Alternative Text

Screen reader software can read descriptions of images to
users. The alt text should convey the information and context
of the image in a concise way.

When adding an image, you will be prompted to add
alternative text:
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Enter the image description in the “Alternative Text:” box.
Images that do not convey information may be marked (“This
image is decorative”) as decorative and screen reader software
will ignore the image.

If you have an existing image without alt text, right-click on
the image and select Image:
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Enter alt text in Alternative description field and click Save:
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The Accessibility Checker will display “Images must have
alternative text” if alt text is not added. Alt text can also be
added from inside the accessibility report panel.

Read more about alternative text.

Descriptive Hyperlinks

Self-describing links are useful for all learners. A good
descriptive hyperlink tells the reader what the linked resource
is, a reason to visit the page, and who hosts it.

• Hyperlink text should be unique and descriptive.

◦ Do not rely on surrounding text to provide context.
• Do not paste URLs as text.

◦ Read a URL aloud to yourself. Is it is a pleasant
experience? Assistive technology will read the full URL
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aloud if present. Please avoid including the full URL. If
you feel it must be included, considering using a link
shortener like bitly

• Do not hyperlink phrases such as “click here,” “Link:,” “see,”
or “click for details.”

◦ Users know they must click on a hyperlink. Consider
telling users where the link will take them and why
they might want to go.

◦ Assistive technology indicates links to users. Using
“Link: example” will read as “Link link: example.”

• If multiple hyperlinks link to the same destination, make
the link text the same.

Consider the accessibility of the resource you are linking to.
Also, consider indicating that you are linking to a video or an
interactive element.

Adding Hyperlinks in Brightspace

1. Highlight your descriptive text
2. Right-click and click select the link icon (looks like a small

chain)
3. Or, press Control (Command on macOS) and K
4. Paste the URL in the dialog that appears

Additionally, you can insert a link via the format toolbar:

1. Choose the Insert Quicklink button and select URL.
2. Paste the URL in the appropriate field and add your

descriptive text in the Title field
3. Select Insert

Tip: Apart from accessibility, good self-describing hyperlinks
will allow you to re-locate the resource if the URL change.

Brightspace Accessibility | 61



Lists

• Bulleted (unordered) lists should be used for a list of items
with no emphasis on their order

• Numbered (ordered) lists should be used for items where
sequential order is important, such as steps in a process

• Properly formatted lists organize your information
effectively and communicate it to assistive technology
users as you intended

• Do not manually insert symbols and use Tab to create
indents. The Accessibility Checker may note improperly
formatted lists

To make a properly formatted list:

1. Select the content you wish to make into a list
2. Select the List menu button
3. Select Bulleted List or Numbered List
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Tables

Properly formatted tables are accessible to text-to-speech and
screen reader software.

Use the built-in tool to create a table.

Here are some common errors the Accessibility checker will
flag in table formatting.

1. Tables must have captions.
How to fix: set a brief descriptive text to indicate the
content of the table. The simplest way is via the
Accessibility checker tool which will prompt for a caption.
This will add <caption> to within the <table> element.
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2. Tables must have at least one header.
How to fix: the simplest way is via the Accessibility checker
tool which will prompt you to choose table header to
“Header Row” or “Header Column”, which will change the
selected data cells <td> to header cells <th>.

3. Table headers must be associated with cells.
How to fix: Set header scope to “Row” or “Column” for
simple table header, which will add scope attribute (<th
scope=”row”> or <th scope=”col”) to associate header cells
and data cells.

*If that all seems rather complicated, do not worry, the
Brightspace accessibility checker will walk you through step-
by-step to make tables accessible.

Uploaded Content

Included documents (Word, PDF, etc.) should be checked for
accessibility.

Embedded or linked videos should be captioned.

Accessibility Checker

The check accessibility tool may catch common accessibility
issues in your content and offer suggestions to help you fix the
issues on the spot. The accessibility checker is available on the
HTML editor toolbar in Brightspace.
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To use the accessibility checker, follow the steps in this video:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=34#h5p-61

The accessibility checker tool checks for a number of issues.
Below is a summary of what is checked and how well the
Brightspace checker does in flagging issues:
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Element checked Reliability of checker

Structure and use of heading
styles

Good.

Recognizes text that has been
formatted to appear as a header
but is not tagged as such. Also
flags headings out of sequential
order. Recognizes lists created
manually using symbols and
suggests creating a semantic
list.

Colour

Good.

Can recognize contrast errors
and offers easy methods to
improve contrast. Cannot
determine if colour is used as
sole indication of importance.

Use of images

Moderate.

Will find images that have
neither Alt text, nor are marked
as decorative as well as those
where the Alt text is just the file
name. But it cannot identify
whether the Alt text is
appropriate or even meaningful.

Links

Poor.

It does not check for link text.
Does note adjacent links
directed to the same URL.

Plain English

Poor.

No readability statistics, only
word, character, and paragraph
counts.

Tables

Good.

Notes lack of table caption. Asks
for table summary on complex
tables. Requires header cell(s).
Does not flag merged or split
cells as these are accessible in
HTML.

Miscellaneous Does not check text justification
or media for captions.
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The Preview tool will show you how the page will appear to
students. Use this as a last step to ensure that on top of being
accessible, your page appears as you want.

Further Reading

D2L article on using the Brightspace Accessibility Checker.
Meeting web content accessibility standards.
Accessible courses and course material.
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13. WordPress and
Pressbooks
Accessibility

WordPress is one of the most common content management
systems in use. Pressbooks is built on the WordPress platform,
so many functions are the same. Langara’s iWeb and
CourseWeb use WordPress.

In This Chapter:

1. Themes
2. Best Practices
3. Headings
4. Links
5. Alt Text
6. Tables
7. Exporting Pressbooks
8. Further Reading

Themes

WordPress has thousands of themes. Some are free and many
are paid. Regardless of what theme you use, it is easier to start
with something accessible than fix an inaccessible theme.

You can filter WordPress themes for “Accessibility Ready.”
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1. Click the Feature Filter button
2. Check Accessibility Ready checkbox
3. Click the Apply Filters button

This reduces the list of themes significantly, but using an
“Accessibility Ready” theme does not guarantee accessible
content.

Best Practices

Make content easy to read and navigate, by using:

• Plain language
• Structured content

◦ Use headings and lists
• Default fonts

◦ Standard font size is 16px, best expressed as [n]rem

• A simple font that has a contrast ratio of at least 4.5:1

◦ Read more about contrast in the Accessible Colour
chapter of this book

Avoid:

◦ Leetspeak, calculator spelling (i.e., 80t5 for bots), text
emoticons (i.e., >:( ), ASCII art (i.e., (^._.^)~)

◦ All capitals
◦ Excessive use of italics
◦ Justified alignment
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Headings

Headings provide structure for your page and the information
it presents. Headings allow all users to skim and find what they
need. Navigating a page by headings is essential for screen
reader users to navigate the web.

To designate text as a heading, highlight your text and select
the Paragraph dropdown to select your desired heading level.

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1267#h5p-97
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Links

To add a link, highlight text and use the Insert/edit link button
or press Control/Command and K to insert a link.

Good hyperlink text should:

• Be descriptive, unique, and meaningful

◦ Describe what a link is and why a reader would click
on it

◦ Avoid using “click here” “read more” “download” etc.
◦ Maintain meaning when removed from surrounding

text

Links should open in the same window by default. This helps
assistive technology and mobile users. Visitors to your page can
open links in a new tab if they choose. If a link opens in a new
window or tab, include “(opens in a new window)” in the link
text.

Avoid using URLs as hyperlink text. If you must provide the
URL, include useful hyperlink text as outlined above and then
include the URL as non-linked, regular text.

When linking to a file, indicate the file type either in context,
such as “Download a PDF copy of this page”, or in parentheses
at the end of the link text: “Download the report (Word
document)”.

Alt Text

Include the alt attribute for all images. If there is no alt
attribute, assistive technology will read the src attribute aloud.
Mark decorative images with alt=”” or leave alt text field blank
in Media Library.
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Enter an image description in the Alt Text field when
uploading a new image:

Or, edit an existing image to add alt text:
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Or, manually change the alt attribute in the Text/HTML editor:

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1267#h5p-98

Refer to the Alternative Text chapter in this book for more
information.
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Tables

Insert tables using the Table tool on the editor toolbar.

1. Change table appearance via Table > Table Properties
2. Set cell type and scope via Table > Cell Properties

1. Of particular importance is setting header cells
2. Set header row via Tables > Row> Table Row

Properties

Avoid merged and split cells. You may use them, but additional
work is required to set scope.

Check function of table by placing cursor in A1 and
pressing Tab. Ensure a logical reading order is followed.

Do not use an invisible table for alignment or layout.

Exporting Pressbooks

HTML is generally more accessible than a PDF. At the very least
it is much more difficult to make a PDF accessible than it is
HTML content. If you need to share a page as a PDF, make it
accessible using Adobe Acrobat and the chapter on PDFs in
this book.

Pressbooks offers many export options. To export your
Pressbook:

1. Navigate to the Dashboard
2. Select Export from the sidebar
3. Check the relevant formats

1. PDF (for digital distribution) will be the best place to
start in creating an accessible PDF copy
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2. EPUB 3 is one of the most accessible and
customizable formats, but requires software for users
to read

3. PDF (for print) should only be used explicitly for
printing purposes as it will retain none of the coded
structure in you Pressbook

4. There are other formats you find useful:

1. XML and XHTML
2. Common Cartridge for importing your Pressbook

into a Brightspace course
3. OpenDocument

Further Reading

Learn more about Accessibility in WordPress.
Read about how to make your Pressbook accessible.
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14. Accessible Video
Meetings

Making a virtual meeting or presentation accessible is a simple
process. Consider the following tools and best practices for
Zoom and Teams.

In This Chapter:

1. Zoom

1. Before Your Zoom Meeting
2. During Your Zoom Meeting

2. Teams

1. Before Your Teams Meeting
2. During Your Teams Meeting

3. Accessible Screen Sharing
4. After Your Meeting

Zoom

Before Your Zoom Meeting

Before your Zoom meeting, consider the following to ensure an
accessible meeting:

1. Include all information in invitation
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2. Share material in advance
3. Mute participants and/or mute on entry
4. Enable automatic captions

The following interactive is a guide to each of the above steps:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1909#h5p-118

During Your Zoom Meeting

During your meeting:

1. Make a plan and communicate to attendees
2. Mute all participants
3. Avoid virtual backgrounds
4. Consider accessible presentation tips
5. Use tools like co-host, multi-pin, and focus mode
6. Enable captions

The following interactive is a guide to each of the above steps:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

Accessible Video Meetings | 77



https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1909#h5p-119

Teams

Before Your Teams Meeting

1. Include useful information in the meeting invitation
2. Mute all participants
3. Share material in advance

The following interactive is a guide to each of the above steps:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1909#h5p-125

During Your Teams Meeting

1. Make a plan, ask for input, and communicate with
attendees

2. Mute all participants
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3. Avoid complicated background filters
4. Use tools like Spotlight and Pin
5. Enable live captions

The following interactive is a guide to each of the above steps:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=1909#h5p-126

Accessible Screen Sharing Best Practices

Consider the following when sharing your screen:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1909#h5p-123

Inclusive Presenting

To present inclusively, consider integrated description.
Integrated description means effectively describing visual
elements while presenting.

The most effective way to describe things is to be specific:

• Refer to size, position, or unique characteristics
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◦ Say: “The bookshelf is about six feet high, and is 75%
full of books.”

◦ Say: “I’m going to click on the close button in the top
right of the window.”

◦ Reference slide number, figure label, etc.
◦ In addition to point to an image or question, refer to

“the image of a horse in the top left” or “question
number three”.

• Spell complex words out letter by letter. This will aid all
participants with understanding and comprehension.

• Identify yourself and other speakers

◦ Use your own comfort level, but consider introducing
yourself and describing yourself.

Try to be concise and direct while including all relevant
information.

After Your Meeting

After your meeting, share as much as possible.
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=1909#h5p-122
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PART III

PDF ACCESSIBILITY

An accessible PDF is tagged with code that provides structure
for assistive technology. PDFs can be crafted from scratch, but
the most common method is to take an existing document or
presentation and export it to PDF. You might find that making
an accessible document or presentation is the best use of your
time and share those versions instead of, or in addition to, a
PDF.
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15. Creating Accessible
PDFs

PDFs are popular and useful but may not always be the best
choice. A PDF can be time consuming to repair for accessibility.
Consider providing Word or PowerPoint copies of material as
well as PDF (most documents can have editing restricted). If
linking to a PDF, indicate file type in the link text: “Syllabus 2021
(PDF)”, for example.

In This Chapter:

1. Export to PDF
2. Scanned PDFs
3. Accessible PDFs
4. Reading Order
5. Check Accessibility
6. Further Reading

Export to PDF

For the majority of PDF documents, you will be converting a
Word or PowerPoint document. Refer to previous chapters for
best practices to create accessible documents in those formats
and ensure you properly export the file to PDF.
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An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=37#h5p-45

Scanned PDFs

PDFs are a common output format for scanned documents.
A scanned document will be a flat PDF, essentially an image
of text. That is not accessible. Adobe Acrobat Pro DC provides
tools to fix this.

Consider looking for an existing accessible electronic version
of your resource.

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=37#h5p-44
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Accessible PDFs

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=37#h5p-111

Acrobat Accessibility Check

Using Adobe’s built-in tools will catch some accessibility issues
in your document. Completing this step will you save you from
having to do extra work later.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=37#h5p-99

Fixing Common Accessibility Issues

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=37#h5p-46

Remediating PDFs can be difficult and time-consuming.
Some people do this work full-time and still encounter
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difficulty. Please contact assistivetech@langara.ca for more
information about remediating PDFs.

Reading Order

One of the most important elements requiring manual
checking is the reading order of your document. Adobe
documentation suggests using the Reading Order pane and
Reading Order Panel. We recommend against this practice
because this method contributes to what some call the “Z
order problem.” When re-ordering content in Acrobat using
the Reading Order pane, some content may “disappear”
(YouTube opens in new tab).

To solve this issue:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=37#h5p-101

Reading Order determines the order of items
when the document is reflowed, such as when
zoomed or viewed on a mobile device. Changing
the reading order may affect the content hierarchy
and tags order. Any changes to reading order must
be checked in content and tags panes.

The Content pane is a hierarchical view of the
items within a PDF. Changing the order of content
will alter the visual appearance of the document.

86 | Creating Accessible PDFs



The Tags tree determines the reading order for
assistive technology, such as text-to-speech engines
and screen readers. Changing the order of tags does
not alter visual appearance of document.

This is a unique issue to the PDF file format.

Check Accessibility

After you remediate your PDF, run the Accessibility Check tool
again.

1. Select Tools

1. Accessibility > Accessibility Check or Full Check
2. Right click on various errors for explanation and tips

for fixing the error.
2. Read Out Loud will give an idea of how a screen reader or

text-to-speech software will read your document

1. Select View > Read Out Loud > Activate Read Out
Loud

3. Select View > Zoom > Reflow

1. As you zoom in, content should reflow into a vertical
column with no need for horizontal scrolling
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Further Reading

CreativePro’s 10 steps to accessible PDFs.
Adobe guide to making accessible PDFs in Acrobat Pro.
Adobe guide to Acrobat Pro Accessibility Check.
List of Adobe Acrobat DC accessibility training guides.
Adobe guide to OCR and editing scanned PDFs.

Microsoft guide to exporting documents to PDF.
Microsoft video guides to PDF accessibility.
Web Accessibility in Mind Guide to PDF Accessibility.
George Brown College in-depth videos of Adobe accessibility.
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16. PDF Forms

In This Chapter:

1. Best Practices
2. Acrobat Prepare Form
3. Initial Accessibility Checks
4. Automated Accessibility Check
5. Javascript

Best Practices

1. Ensure form has clear instructions
2. Create visual labels for all fields, place labels adjacent to

corresponding fields

1. Ensure labels are meaningful and clear
3. Use tooltips
4. Include meaningful group labels where appropriate
5. Indicate required fields and field constraints (such as

specific date format)
6. Provide help and hints where appropriate

How to create a PDF form in Acrobat
For additional information, consider WebAIM’s guide to form

tags.
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Acrobat Prepare Form

Create form layout in Word or InDesign and export as an
accessible PDF document. Open in Acrobat Pro DC.

1. Select Tools tab and find the Forms & Signatures section
2. Select Prepare Form tool and click Add or Add Shortcut
3. The Prepare Form tool will appear in the right side tools

pane

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=730#h5p-106

Initial Accessibility Checks

To assess the accessibility and usability of your form, check:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=730#h5p-102

You can add a single form field if you discover one missing
during your checks:

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=730#h5p-103
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Automated Accessibility Check

1. Select Tools

1. Accessibility > Accessibility Check or Full Check
2. Right click on various errors for explanation and tips

for fixing the error.
2. Read Out Loud will give an idea of how a screen reader or

text-to-speech software will read your document

1. Select View > Read Out Loud > Activate Read Out
Loud

3. Select View > Zoom > Reflow

1. As you zoom in, content should reflow into a vertical
column with no need for horizontal scrolling

Tab through your form once more to be sure.

Javascript

You can add Javascript to PDF. This may prove useful for certain
forms.

To create fillable text fields that include existing lines for
printing and filling by hand, use one of the following methods
to ensure accurate text entry:

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=730#h5p-104

You may also wish to include a clear fields button:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:
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https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=730#h5p-105
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17. Advanced PDF

Ensure you have Acrobat Pro DC, Acrobat Reader lacks the
features necessary to make PDFs accessible.

In This Chapter:

1. Manual Tags
2. Types of Tags

1. Artifacts
2. Tables

Manual Tags

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=722#h5p-108

Types of Tags

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=722#h5p-107
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Artifacts

If you want screen readers to ignore certain content, such as
decorative images, you must mark those items as Artifacts.

To mark objects as an artifact:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=722#h5p-109

Tables

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=722#h5p-110
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PART IV

ADVANCED GUIDES
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18. Other Document
Suites

If you are using a document suite other than Office, find
information for common platforms below.

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=528#h5p-39
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19. STEM Accessibility

Math and science can be complex for many learners regardless
of ability or experience. If that content is not accessible, many
learners may be left behind.

In This Chapter:

1. Using EquatIO
2. STEM in Brightspace
3. Math in Word Documents
4. Math on the Web
5. More Tools
6. Links and Further Reading

Creating accessible math and science content is easy using
tools such as Equatio, Brightspace, and Office. We will examine
the details below, but first let’s consider some best practices.

Present information in multiple ways:
An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-77

EquatIO

Langara has a site license for EquatIO, which means faculty,
students, and staff can log in with their Office365 email and
use all features of EquatIO. EquatIO is very intuitive and easy to
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use. Anywhere you can input text, you can use EquatIO to write
math, and anywhere you encounter math, you can use EquatIO
to read and copy math. EquatIO handles multiple inputs and
outputs including plain text, LaTeX, MathML, and images.
EquatIO also has chemistry and graphing tools.

The following is an overview of Equatio for Google Chrome.
Equatio is also available as a desktop application (Windows,
macOS), mobile (m.equat.io), and web portal
(equatio.texthelp.com).

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-68

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-37

STEM in Brightspace

There a number of ways to embed math and science content
in Brightspace pages.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-69
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Math in Word Documents

Microsoft Word includes an equation tool that can create
accessible formulas and equations.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-38

Microsoft Word Online includes an equation editor but does
not allow for full accessibility. Create and finalize your
documents in Word desktop (Windows or Mac).

Additionally, you can use EquatIO’s desktop version to insert
math into a Word document.

PDF

If you intend to distribute material in PDF format,
ensure the PDF is verified for accessibility. However,
passing automated accessibility checks rarely
ensures complete accessibility of PDFs, especially a
document containing math. Best practice would be
to create a Word document and export it to PDF,
retaining the Word document as a template for
future changes and exports. You could also
distribute the Word document to those who need it,
or best practice would be to distribute both formats
to students, allowing them the choice based on
preference or need.
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Math on the Web

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-70

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=32#h5p-76

Consider these sources on MathML:
W3C overview of MathML.
Mozilla Developer Networks explains how to write MathML.
How to Make Math Accessible on the Web (TextHelp).
MathJax organization.

More Tools

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=32#h5p-31
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Links and Further Reading

Accessible Periodic Table of the Elements
Independence Science Periodic Table of the Elements
NIST Digital Library of Mathematical Functions
Chemistry add-in for Microsoft Word
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20. Social Media
Accessibility

Social media is a dominant force in online life. By following
these easy steps, you can ensure your posts are accessible and
inclusive.

In This Chapter:

1. Social Media Best Practices
2. Common Platform Instructions

Social Media Best Practices

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=386#h5p-27

Common Platform Instructions

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=386#h5p-28

Visit Accessible-social.com for common social media
accessibility best practices and additional resources.

Social Media Accessibility | 103



21. Accessible Web
Content

Web accessibility best practices focus on removing barriers and
providing equal access to information and web content.
Barriers may be visual, motor, auditory, or cognitive. Web
design significantly impacts users’ experience and using
proper formatting and tools allows all users to access your web
content. The principles outlined here are essential for some
users, but benefit all including those using mobile devices,
different browsers or operating systems, or older hardware.

In This Chapter:

• POUR
• Easy Accessibility Checks
• Accessibility and Design
• Tools and Links

POUR

The best practice for web accessibility is to follow the POUR
principles. Web content should be Perceivable, Operable,
Understandable, and Robust.

An interactive H5P element has been excluded from
this version of the text. You can view it online here:

https://pressbooks.bccampus.ca/
accessibilityhandbook/?p=925#h5p-78
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Easy Accessibility Checks

Review your web content and consider the following questions:

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=925#h5p-53

Accessibility and Design

Most web accessibility features are invisible and will not
interrupt design choices:

• Alt text is hidden in code, read only to screen readers
• Form labels are expressed in visible text regardless and

made accessible with <label>
• Heading tags <H1> are code to provide structure

◦ Modify CSS to change style.
• Tables: <th> <tr> <td> are coded within the table and

do not change appearance
• Lists: <ul> <ol> <li> <dd> are code to organize lists, but

appearance can be modified with CSS
• Language and viewport attributes are part of your HTML

document
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• You can set a different language for part of your page:
<span lang=”es”>Hola. Me llamo Pablo</span>. This
has no effect on styling

• Making your page keyboard accessible changes nothing
about appearance or design

• Closed captions, transcripts, and audio descriptions are a
user choice

Tools and Links

Checklists

The Web Accessibility Checklist is extremely useful for initial
auditing.

The A11y project provides an interactive checklist to check
web accessibility.

Intopia’s Accessibility Not-Checklist is an excellent,
approachable resource.

Tools

W3C WCAG reference.
Lighthouse (Chrome DevTools) testing tool.
Understanding Lighthouse error messages.
Firefox Accessibility Inspector.
WAVE by WebAIM testing tool extension.
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An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=925#h5p-80

WebAIM WCAG Checklist.

Additional Accessibility Considerations

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=925#h5p-36
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22. Making Email
Accessible

Email is one of the most common forms of communication
and crafting accessible emails is simple. The specific
instructions below will refer to Outlook; however, the principles
are the same regardless of email client.

An interactive H5P element has been excluded

from this version of the text. You can view it online

here:

https://pressbooks.bccampus.ca/

accessibilityhandbook/?p=92#h5p-15

Further Reading
Consider the Microsoft guide to Outlook accessibility. The

website should responsively display information based on your
device, but you can also switch tabs (Windows, Web, MacOS,
iOS, Android) to see specifics for your device.
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23. Descriptive Audio

Descriptive audio presents an audio description of visual
narrative and elements in video. This ensures viewers who
cannot see the visuals displayed can still understand context
and information.

In This Chapter:

1. Described Video
2. Inclusive Presenting
3. Further Reading

Described Video

Described video includes a secondary audio track synchronized
with a video or presentation that provides descriptions of what
is happening on-screen. Often included are descriptions of
surroundings, speakers’ appearance, body language, and any
other non-audio information. The description is added during
pauses in dialogue. Some web video players allow for an
additional track, however it is not common. At this time,
described video is rare and not legally required.

Some principles of described video:

• Describe what is on screen
• Prioritize essential information
• Do not explain or elaborate, focus only on description
• Do not interpret, add opinion, censor, or summarize
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• Use the present tense
• Remain consistent with names of speakers and places

Inclusive Presenting

Many web video players do not allow for additional audio tracks
as descriptive audio is not yet required by law. However, the
principles of describing visual elements can create a more
inclusive environment while presenting. To incorporate those
principles, consider the idea of integrated description.
Integrated description means effectively describing visual
elements while presenting.

The most effective way to describe things is to be specific:

• Refer to size, position, or unique characteristics

◦ Say: “The bookshelf is about six feet high, and is 75%
full of books.”

◦ Say: “I’m going to click on the close button in the top
right of the window.”

◦ Reference slide number, figure label, etc.
◦ In addition to point to an image or question, refer to

“the image of a horse in the top left” or “question
number three”.

• Spell complex words out letter by letter. This will aid all
participants with understanding and comprehension.

• Identify yourself and other speakers

◦ Use your own comfort level, but consider introducing
yourself and describing yourself.

Try to be concise and direct while including all relevant
information.
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Further Reading

Consider AMI guides to described video for advanced
techniques.

W3 provides a brief guide to integrated description.
Deque’s blog on accessible speaking best practices covers

presenting more broadly.
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24. ePub

EPUB documents give extraordinary control and
customization options to readers.

EPUB documents allow readers to:

• Change background colour
• Change font style and size
• Add bookmarks and highlights
• Pick up where they left off
• Change spacing and alignment

EPUB documents automatically reflow, so when a reader
zooms in (or reads a document on a small screen) there is no
need for horizontal scrolling. Making a PDF reflow is possible
but requires a lot of additional work.

EPUB documents can contain multimedia, such as audio and
video files and interactive elements like links.

EPUBs are very secure. EPUB is a format for distributing a final
version. EPUBs are not meant for documents that will be
changed by another party; they are for consumption only.
When applicable, prefer EPUBs over PDFs.

The simplest way to make an EPUB file is to export a Word
document using WordToEPUB from The DAISY Consortium.
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Readers

Google Play Books

Apple Books

Thorium Reader (desktop)
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25. InDesign

Creating accessible InDesign documents is simple enough and
will save a lot of work when exporting InDesign documents to
PDF.

In This Chapter:

1. Metadata
2. Headings
3. Text Frames
4. Lists
5. Tables
6. Images
7. Links
8. Anchors
9. Table of Contents

10. Forms
11. Reading Order
12. Master Pages
13. Export
14. Import
15. Tools

Metadata

Add metadata to documents by navigating to File > Info and
add a document title and language. Metadata helps assistive
technology announce content to users and know what
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language to expect. Other metadata will help you and others in
searching for files.

Headings and Paragraph Styles

To create accessible headings in InDesign:

1. Under the Type menu, open the Paragraph Styles panel
2. Select New Style
3. Double click on the newly created style to open the Style

Editor
4. Assign a name under General > Style Name

1. Best practice would be to name it H1, H2, etc. as
appropriate

5. Modify the style’s visual appearance (font, font size, etc.)
6. In the Export Tagging category, move to PDF Tag selector

and choose H1, H2, etc. as appropriate
7. Select heading text in the document and choose newly

created style in Paragraph Styles panel
8. Repeat process for different heading levels and paragraph

text

Text Frames

For text columns or text divided by other document elements,
link text frames together for proper flow of text. To create
columns:

1. Create text frames
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2. Click on the small red plus icon near the lower right corner
of the frame

3. Select next text frame to be linked

Lists

• Use built in list tools
• Use bulleted lists when the order is not important. Use

numbered lists when the order is important, such as in
steps to a process

• Do not manually create lists

Tables

1. Create Tables via Table > Create Table
2. Designate header rows

1. Tables created in InDesign will need additional work to
ensure accessibility if exported to another format, such
as PDF

Images

Anchor Images

Anchor Images in their specific place within the document:
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1. Click and hold on the blue square in the upper right area
of the image container

2. Drag the image to its place in the document where you
want the alt text to be read Remember to consider
reading order of the image’s alt text relative to the
surrounding text

3. Release the mouse button and the blue square becomes a
blue anchor icon

Add Alt Text

Within InDesign consider “object export options” to be
synonymous with “alt text” in other platforms.

1. Select the image container and navigate to Object
> Object Export Options or Right-click the container (not
the image itself) and select Object Export Options

1. Choose the Alt Text tab, select Custom and type in alt
text

2. Move to the Tagged PDF tab

1. Select Apply Tag and choose From Structure
2. Under Actual Text Source select Custom
3. Type in alt text description in the text field

To mark an image as decorative:

1. Select the image container and navigate to Object
> Object Export Options or Right-click the container (not
the image itself) and select Object Export Options

2. Move to the Tagged PDF tab, Apply Tag and
choose Artifact
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Images of Text

For an image, such as a logo or decorative lettering, it may be
better to use InDesign’s actual text feature, rather than alt text.

1. Right-click on the object and select Object Export
Options

2. Select Tagged PDF tab
3. Choose Custom from Actual Text Source menu
4. Type the text included in the image
5. Click Done

Links

1. Highlight text to be linked
2. Right-click and select Hyperlinks > New Hyperlink
3. Choose Link to web URLs to create a link to a webpage
4. Choose Link to Text Anchors to create a link to a place

within your document

1. Select the appropriate anchor from the list

Anchors

To create a link to somewhere else in the document, use
anchors:

1. Navigate to Window > Interactive > Hyperlinks
2. Select the text to be used as an anchor
3. In the Hyperlink panel and select Option
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4. Choose New Hyperlink Destination
5. Add a descriptive name
6. To link to anchor:

1. Select text to be link
2. Right-click and choose Hyperlinks > New Hyperlink
3. Choose Link to Text anchor and choose anchor from

drop down list

Table of Contents

1. Select Layout > Table of Contents
2. Add a title
3. Designate paragraph styles in Other Styles box and

use Add button to move them to Styles in Table of
Contents column

4. Select Create PDF Bookmarks checkbox
5. Select Make text anchor in source paragraph checkbox to

allow you to create links within the document to headings,
in addition to the links generated in the table of contents

Read more about InDesign Table of Contents.

Forms

Creating form fields in InDesign will make exporting to PDF
easier.

To create a form:

1. Use the Frame Tool to draw a frame the size of the form
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field
2. Go to Window > Interactive
3. Select Buttons and Forms to open the Buttons and

Forms panel
4. With the newly drawn frame selected, choose type of form

field from Type menu in Buttons and Forms panel
5. In the dialogue that opens, the Description field will

become the tooltip (necessary for accessibility) when
exported to PDF

6. Select Ok

Form fields created this way will be automatically tagged in
PDF format.

Reading Order

Layers

InDesign files will likely include at least three layers: Text,
images, and background.

To ensure logical reading order:

1. Navigate to Window > Layers
2. Re-order text layers to read from bottom to top of the

Layers list

1. What is to be read first visually should be on the
bottom of the list. What is to be read last should be at
the top of the list.
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Articles

To ensure logical reading order:

1. Navigate to Window > Articles
2. The Article Panel will open, blank
3. Open the more menu and select Use for Tagging Order in

Tagged PDF
4. Click and drag the first item to the Article Panel and

provide a name for the article when prompted
5. Click and drag each item on the page to the Article Panel

in the order it is to be read

1. The order of items in the Article Panel indicates the
reading order for assistive technology and items in the
panel can be dragged and dropped to reorder

6. Repeat for each page of the document

Master Pages

Master pages can be used as a template when creating
InDesign documents. To use Master pages, select New Master
from the Pages panel. Select Override All Master Page Items
before creating articles and exporting to PDF.

Export

To export to PDF:

1. Navigate to File > Export
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2. Choose Adobe PDF (Interactive)
3. Click Save
4. On the General tab, select:

1. Create Tagged PDF
2. Use Structure for Tab Order
3. Forms and Media: Include All
4. Embed Page Thumbnails

5. Select Export
6. Open PDF in Acrobat Pro to verify accessibility

To export to EPUB:

1. Navigate to File > Export
2. Choose EPUB (Reflowable).
3. Click Save

1. Add a title to Metadata
2. Under Object settings choose CSS Size option

of Relative to Text Flow

Import

If you are importing a Word document into InDesign, only the
document’s text will be imported.

A properly formatted Word document with heading styles
can be imported into InDesign and retain the heading
structure (H1, H2, etc.)

1. Navigate to File > Place
2. Under Format choose Customize Style Import
3. Select Style Mapping

1. If you do not have any existing styles you will need to
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map the imported styles to heading tags in InDesign
2. If your InDesign document already has existing styles,

match the import equivalents to the styles from the
drop down list

3. Click Ok
4. Click Ok
5. Click in the document to place the imported text

Tools

MadeToTag is an InDesign plug-in that adds tools to create
InDesign documents for export as accessible PDFs. Read
MadeToTag’s seven steps to making tagged PDFs in InDesign.

Consider the Government of Minnesota guide to accessible
InDesign documents.

Download this chapter as an InDesign quick guide (Word
Document, 22KB).
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Glossary

accessibility checkers

Automated tools built-in to many platforms that check for
common accessibility issues. Are not be considered a
guarantee of accessibility.

Accomodation

A reactive adjustment to a resource or activity to make it
accessible to a person with a disability.

Alternative Text

Alternative text is a text equivalent of graphics in a
document or webpage. Alternative text is coded to be
hidden visually, but read to a screen reader user.

ARIA

Accessible Rich Internet Applications are roles and
attributes that can make Javascript widgets, error
messages, and live content more accessible.

Audio Description

Additional audio added to a video that describes important
visual details that are not conveyed by the main audio
alone.

Camel Case

Capitalization of the first letter of each word in multi-word
hashtags. Without Camel Case, hashtags will be read aloud
as one long, unintelligible word.

Also known as CamelCase, Pascal Case, or Title Case
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CCTV Magnifier

Closed Circuit TV (CCTV) magnifiers are cameras used to
magnify documents or books on a monitor.

Closed captions

A text equivalent of audio content in a video, displayed
synchronously. Closed captions are toggled on or off by
viewers, as opposed to open captions that are burned into
the video and always displayed.

Colour contrast

Colour contrast is the difference in saturation, brightness,
and pigment of different elements relative to one another.
A contrast ratio of at least 4.5:1 between text and
background is required by common accessibility
standards.

Contrast ratio

The contrast ratio between the font colour and the
background colour. Accessible contrast should be at least
4.5:1.

Decorative image

An image that does not contain unique information or is
used for visual appeal only. Decorative images must be
marked as decorative or use alt=""

DOM

The Document Object Module (DOM) represents the
hierarchical, logical structure of a document/web page.
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EPUB

Most common ebook file format. A very customizable and
accessible format.

FAST

Function
Appearance
Structure
Text Equivalents

Flattened Copy

A digital object that has been "flattened" into a single layer
when exported. A scanned document or a PDF created
using "Print to PDF" (or similiar) will be a flat image without
recognizable text or digital document structure. A flat copy
may visually appear as a document, but be completely
inaccessible.

Focus

On a webpage, a control or content item that can receive
focus by a mouse, keyboard, or screen reader. Typically
links, buttons, forms, and menus are focusable.

Focus indicator

A visual indicator of what element on a page is currently
focused. This assists users to know where they are on a
page and to select menus, links, and buttons with a
keyboard.

Focus order

The order in which interactive elements on a page are
focused. Focus order should follow a logical pattern that
aligns with visual layout.
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Functional Accessibility

When something does not meet accessibility standards
but is still useable by users of assistive technology.

Headings

Headings are text used to organize a document. Headings
are section and subsection titles used to logically separate
content, build and show relationships between ideas, and
explain the development of concepts. Headings must be
hierarchical, not skip a level, and be semantically
programmed, not merely cosmetic.

Hyperlink

Linked text to another document or part of document that
the user can follow by selecting. Effective hyperlink text
should make sense independent of the content around it.

Keyboard trap

When a user cannot navigate away from an interactive
element using their keyboard alone.

Label

In HTML, the label element acts a caption for input fields,
indicating what a control (form field, check box, radio
button, etc.) relates to.

MathML

XML format used to add math to HTML.

OCR

Optical Character Recognition (OCR) is software which
converts printed material or images of text into
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recognizable digital text. Scanned PDFs require OCR
processes to be accessible. Adobe Acrobat includes builtin
OCR technology, but other assistive technology software
also employ OCR.

PDF

Portable Document Format. Often inaccessible and
difficult to edit.

plain language

Plain language is communication your audience can
understand the first time they read or hear it.

Reading order

The order in which a screen reader reads content on a
page. This should match visual order. Reading order also
refers to how a PDF will reflow when zoomed.

Responsive Design

Responsive content automatically adapts to the size of the
user's display (phone, laptop, tablet, etc.)

Screen reader

Assistive technology software that reads content aloud and
helps blind and low vision users navigate and interact with
their computers.

Semantic markup

The use of code (HTML attributes, PDF tags, XML, etc.) to
distinguish content by meaning, not appearance. For
example, a <h1> heading tag creates both a visual and
coded navigation waypoint where as increasing the font
size and bolding simply makes regular text appear larger.
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SEO

Search engine optimization. The process of improve
quantity of web traffic coming from search engines.

Skip to main content

Often hidden links accessible by keyboard navigation that
assist users to skip over repeated parts of webpages or to
different parts of a webpage, such as search or navigation
region.

Tables

Information presented in a grid format of rows and
columns, generally to show a relationship between sets of
set

Tag (PDF)

A tagged PDF includes semantic information and
structure to create an accessible document. This is done by
adding tags to the document in Adobe Acrobat.

templates

Preset document or file format, used for consistency
without having to recreate each time

timestamp

Specific time in video, often expressed as hh:mm:ss

Transcripts

Transcription is the process of converting audio into
written text. A transcript is a written record of all audio in
media. Captions are synced to the content.
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Universal Design

Design of content, software, facilities, and services so that
they are useable, without accommodation, by the largest
scope of users.

W3C

The World Wide Web Consortium sets web technology
standards.

WCAG

Web Content Accessibility Guidelines are maintained by
W3C and set the minimum standards for web accessibility.
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